PDA

View Full Version : Scala Radio Stream URL?



Sb42
2019-02-25, 15:16
Hi,

Has anyone parsed the stream URL for https://planetradio.co.uk/scala-radio/ yet?

Please share.

thanks.

Got it! https://stream-mz.planetradio.co.uk/scalahigh.aac

rk19
2019-03-09, 04:10
Hi,

Has anyone parsed the stream URL for https://planetradio.co.uk/scala-radio/ yet?

Please share.

thanks.

Got it! https://stream-mz.planetradio.co.uk/scalahigh.aac

Many thanks. Couldn't find it.

Paul Webster
2019-03-09, 05:31
It is in TuneIn so a search in the Radio section of LMS finds it and it plays.
They currently offer 3 URLS - mp3, aac and lofi aac.

Sb42
2019-03-09, 07:41
It is in TuneIn so a search in the Radio section of LMS finds it and it plays.
They currently offer 3 URLS - mp3, aac and lofi aac.

Can you give me a little more detail as to where you found it? It's not in my TuneIn Search Box, just the test stream.

thanks

Paul Webster
2019-03-09, 11:07
I just tuned in via Radio/Search and heard the 18:00 news so I assumed it is live.
However, it then played
"Haydn - Symphony #100 , 3rd Mvt - Orchestra Of Italian Switzerland, Howard Shelley"
and their web site shows
"Jeremy Soule - Wind Guide You - Studio Orchestra"

So - you may well be right that they have not updated the URLs to match what they are live with.
Sorry about that.

whitman
2019-03-31, 02:05
Sb42's "Got it!" URL in post no.1 seems to be delivering the live stream this Sunday morning, though oddly they aren't giving time checks. Maybe because everything is pre-recorded?

Anyway, the daytime stuff seems rather bland, but I wonder if there's a way to get Scala's Listen Again feeds on LMS? I'd like to try out William Orbit In The Space, which sounds interesting, but never seem to be around for its 9-to-10pm slot.

Paul Webster
2019-03-31, 02:54
For William Orbit - In The Space ... try
http://bauerod.sharp-stream.com/scala/Scala-Mon-2100.m4a
for Monday and
http://bauerod.sharp-stream.com/scala/Scala-Sat-2300.m4a
for Saturday

You can guess the others ;)

whitman
2019-03-31, 10:20
Thanks very much Paul, I'll give those a go ... and do my best to guess the tortuous system.

whitman
2019-04-09, 07:13
Paul, I finally got around to trying those URLs, and neither of them works for me. Nothing plays.

Raymond Woodward
2019-04-09, 07:56
You're not missing anything, it is typical UK commercial radio - sad.

As to finding it, all I did was search for 'Scala' in 'Radio' (TuneIn) via my Squeezebox and then scrolled down to the listing ...

Percival Sweetwater
2019-04-09, 08:26
You're not missing anything, it is typical UK commercial radio - sad.


I added it to my favourites on the day it launched. I'll be removing it very soon...

Paul Webster
2019-04-09, 08:45
Paul, I finally got around to trying those URLs, and neither of them works for me. Nothing plays.

Double-check that you have the full URL ... and not a reduced size one that the forum can present.
Try the URL in a regular browser - such as Chrome. I just did that (frmo outside UK) and it worked fine.

If that URL works in Chrome then it is LMS that is not liking it.
Perhaps it has no handler available for the MP4 content.
Check the LMS logs to see if there are clues.

whitman
2019-04-10, 01:41
(We're talking about the Listen Again URLs in post #7, for some interesting-seeming evening shows. The live URL in post #1 works fine, should you be able to stand daytime Scala.)

Paul, yes, I gor the full URL by (on a Mac) right-clicking and Copy Link. Will not play on my LMS, as reported.

Tried it in a browser, and plays fine, as you suggested.

So can I fiddle with some LMS settings somehow to play .m4a streams?

Paul Webster
2019-04-10, 03:04
I suspect that @bpa will have best ideas for this.

I just tried it (from outside UK) and logs show

Slim::Player::Song::open (410) Error: Couldn't create command line for mp4 playback for [http://bauerod.sharp-stream.com/scala/Scala-Mon-2100.m4a]
So I suspect it needs a tweak to associate the data type with ffmpeg or similar.

bpa
2019-04-10, 05:16
I suspect that @bpa will have best ideas for this.

I just tried it (from outside UK) and logs show

Slim::Player::Song::open (410) Error: Couldn't create command line for mp4 playback for [http://bauerod.sharp-stream.com/scala/Scala-Mon-2100.m4a]
So I suspect it needs a tweak to associate the data type with ffmpeg or similar.

This is a streamed MPEG4 service. The normal LMS transcoder "faad" can handle MPEG4 files but not MPEG4 streams.
Player like squeezelite (and possibly Touch/Radio) can play the MEG4 stream natively but older player such as SB3, Classic, Receiver, Trasnporter and Boom - need a transcoder other than faad.

A custom-convert.conf file with the following rules should work for Linux system. Windows is a bit different. Not sure about OSX. Below has ffmpeg but if your distro has avconv - change the ffmpeg to avconv


mp4 mp3 * *
# FRB:{BITRATE=-B %B}T:{START=-ss %s}
[ffmpeg] -loglevel quiet -f mp4 -i $FILE$ -f wav - | [lame] --silent -q $QUALITY$ $BITRATE$ - -

mp4 pcm * *
# FRB:{BITRATE=-B %B}T:{START=-ss %s}
[ffmpeg] -loglevel quiet -f mp4 -i $FILE$ -f u16le -

mp4 flc * *
# FRB:{BITRATE=-B %B}T:{START=-ss %s}
[ffmpeg] -loglevel quiet -f mp4 $START$ -i $FILE$ -f flac -

whitman
2019-04-10, 07:18
Bpa, I'm using a couple of SB3s, and running LMS on my Mac, so from what you say, looks like I need another transcoder to play mpeg4 streams. But this is all a bit over my head. Can you explain what I need to do? Thanks!

Paul Webster
2019-04-10, 07:19
That did it.

I am running on pCP here - and ffmpeg is not installed by default so I used the pCP extension manager to install pcp-ffmpeg from pCP repository and then created a custom-convert.conf ... guide here
https://forums.slimdevices.com/showthread.php?107833-PiCoreplayer-LMS-custom-convert-conf

bpa
2019-04-10, 07:34
Bpa, I'm using a couple of SB3s, and running LMS on my Mac, so from what you say, looks like I need another transcoder to play mpeg4 streams. But this is all a bit over my head. Can you explain what I need to do? Thanks!

Mac aka OSX are "special" and I don't have experience with them.
So it'll be a case of you doing things one step at a time and testing on the way.
You didn't indicate your technical level.


ffmpeg is needed to transcode. ffmpeg is only available for 64 bit apple. What OS release is your Mac ? is it 64 bit ?

Can you download and install ffmpeg from this site http://ffmpeg.org/download.html - For Apple - hover over the Apple logo.

whitman
2019-04-17, 04:11
Mac aka OSX are "special" and I don't have experience with them.
So it'll be a case of you doing things one step at a time and testing on the way.
You didn't indicate your technical level.


ffmpeg is needed to transcode. ffmpeg is only available for 64 bit apple. What OS release is your Mac ? is it 64 bit ?

Can you download and install ffmpeg from this site http://ffmpeg.org/download.html - For Apple - hover over the Apple logo.

Bpa, thanks.

Hard to know how to describe my technical level, though I did indicate earlier that a lot of this is over my head. Let's say I know that my Mac is 64-bit (running macOS 10.14.4), but I had to look up what an ffmpeg is, if that helps.

Anyway, I've downloaded and unpacked the ffmpeg, as directed, and I now have a Unix executable file called ffmpeg.

bpa
2019-04-17, 04:24
Bpa, thanks.

Hard to know how to describe my technical level, though I did indicate earlier that a lot of this is over my head. Let's say I know that my Mac is 64-bit (running macOS 10.14.4), but I had to look up what an ffmpeg is, if that helps.

Anyway, I've downloaded and unpacked the ffmpeg, as directed, and I now have a Unix executable file called ffmpeg.

A Unix executable is unlikely to run on macOS. Can you run it in Terminal window to check you have a compatible version ?

whitman
2019-04-17, 06:34
A Unix executable is unlikely to run on macOS. Can you run it in Terminal window to check you have a compatible version ?

I went ahead and double-clicked it and got this in Terminal ...

libxvid --enable-libzimg --enable-libzmq --enable-libzvbi --enable-version3 --pkg-config-flags=--static --disable-ffplay
libavutil 56. 26.100 / 56. 26.100
libavcodec 58. 51.100 / 58. 51.100
libavformat 58. 27.102 / 58. 27.102
libavdevice 58. 7.100 / 58. 7.100
libavfilter 7. 48.100 / 7. 48.100
libswscale 5. 4.100 / 5. 4.100
libswresample 3. 4.100 / 3. 4.100
libpostproc 55. 4.100 / 55. 4.100
Hyper fast Audio and Video encoder
usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}...

Use -h to get full help or, even better, run 'man ffmpeg'
logout
Saving session...
...copying shared history...
...saving history...truncating history files...
...completed.
Deleting expired sessions...46 completed.

[Process completed]

bpa
2019-04-17, 09:45
Attached is a zipped file. The zip file is called custom-convert.zip and it contains one file called custom-convert.conf

Before you attempts the steps below you need to find out where LMS convert.conf file is located on your system. I don't know which directory is used on OSX.macOS system. The directory will contain file such as convert.conf and types.conf . Check there is no custom-convert.conf file already in the directory as replacing the existing file will break something else.

1. Download the attached zip file.
2. Unzip the zip file and save the file custom-convert.conf
3. Copy the file custom-convert.conf into the directory which has convert.conf
4. Make sure custom-convert.conf has the same ownership and permissions as convert.conf
5. Restart LMS
6. Check MPEG-4 entries in WebUI Settings/Advanced/FileTypes - that is showing ffmpeg and not faad (e.g. ffmpeg vs faad/flac)

whitman
2019-04-18, 04:13
I've followed your instructions, but now in MPEG4 in Settings/Advanced/FileTypes I get only "Native" next to AAC, rest greyed out Disabled. No sign of ffmpeg, and no sign of faad/flac, which was next to FLAC before.

bpa
2019-04-18, 05:17
I've followed your instructions, but now in MPEG4 in Settings/Advanced/FileTypes I get only "Native" next to AAC, rest greyed out Disabled. No sign of ffmpeg, and no sign of faad/flac, which was next to FLAC before.
That probably means LMS cannot "see" ffmpeg.

Which directory is ffmpeg executable installed ?

In WebUI Settings/Information - at the bottom there is a list of directories besides "Helper Applications Folder" - ffmpeg has to be in one of those directories and with permissions such that the LMS userid can execute it. This is macOS stuff - I don't know specifics, can only guide.

whitman
2019-04-18, 06:36
Ha, I'd forgotten to put ffmpeg into the relevant folder, it was still floating around on my desktop. Once I did that, it all fired up as expected—and the Scala Listen Again URLs work perfectly.

Thanks again, bpa, as ever, for your patience and help.

And if any other macOS users ever look at this, using macOS 10.14.4, I went to top level/Library/PreferencePanes/Squeezebox.prefPane, then right clicked and Show Package Contents, then I put bpa's custom-convert.conf file in Contents/server (which is where convert.conf and types.conf etc already reside), then dropped the downloaded ffmpeg file into Contents/server, which directed it into Contents/server/Bin.

whitman
2019-04-20, 08:37
A further report, now I have the MPEG4 streams working, related to the Scala Listen Again URLs, as given in post no. 7.

I tried the William Orbit In The Space one for Monday, as noted in that post, and made a URL for a Thursday version. Unfortunately, these streams run only for 10 minutes or so and then stop. Not sure if this is some sort of limitation that Scala puts on them, though that seems unlikely for what are supposed to be Listen Agains.

Anyway, no great problem for me, as those two short stretches of In The Space I heard were disappointing.

But thought I'd point it out.