PDA

View Full Version : Some questions about playlists



Marc Sherman
2005-01-11, 10:08
I'm a bit confused about how to use playlists in the slimserver and
squeezebox. Hopefully someone can shed some light on this.

Here's my setup: on my linux box pyloric, I've got my music library in
/srv/music/. This directory is shared via Samba to the windows machines
on my network as \\pyloric\music.

The music library is organized as Artist/Year-Album/NN-SongName.mp3, and
each album directory also contains a 00-playlist.m3u file generated when
I rip the CDs. I use those playlists when I'm playing music on the
windows machines directly from the samba share. Those playlists do not
show up in the squeezebox, but that's good, because the squeezebox can
play an album at a time quite nicely from the Browse Music menu.

I'd like to manually create some playlists in
/srv/music/00-Playlists/*.m3u, and have them show up in the squeezebox's
Browse Playlist menu. Is this possible? I haven't had any luck so far.
Ideally, those playlists would contain relative paths
("../Band/Album/00-playlist.m3u") so that they are useful both for the
slimserver in the local filesystem, and the windows machines via samba.

Currently, the slimserver is configured with it's playlist directory set
to /usr/lib/slimserver/playlists. I've been able to create playlists in
the web UI, and they get written into that directory, though with all
absolute paths. However, if I create a playlist on the squeezebox using
the Save Playlist plugin, nothing happens - the squeezebox says that
it's saved the playlist in the right place, but no file is there when I
check the filesystem. This is with 5.4.0, in case this is a known bug.

Thanks for any insight,
- Marc

kdf
2005-01-11, 10:56
Quoting Marc Sherman <msherman (AT) projectile (DOT) ca>:


> Currently, the slimserver is configured with it's playlist directory set
> to /usr/lib/slimserver/playlists. I've been able to create playlists in
> the web UI, and they get written into that directory, though with all
> absolute paths. However, if I create a playlist on the squeezebox using
> the Save Playlist plugin, nothing happens - the squeezebox says that
> it's saved the playlist in the right place, but no file is there when I
> check the filesystem. This is with 5.4.0, in case this is a known bug.

Its been a while since that one has been mentioned, but I believe this indeed
was a bug for 5.4.0. It is fixed in the 5.4.1 nightly builds (todays seems to
not be available for the moment)

-kdf

Marc Sherman
2005-01-11, 10:58
kdf wrote:
>
> Its been a while since that one has been mentioned, but I believe this indeed
> was a bug for 5.4.0. It is fixed in the 5.4.1 nightly builds (todays seems to
> not be available for the moment)

Thanks. I'll just disable the Save Playlist plugin until I upgrade to
5.4.1 then.

- Marc