PDA

View Full Version : Does Winamp act as an LMS player on Windows 10?



itm
2019-02-12, 10:36
I've been unable to resolve issues with my Squeezeplay client on Window 10 prematurely skipping to the next track, so am looking for an alternative player for Windows 10. I've tried installing Softsqueeze, but it cannot recognise my existing Java (v7) runtime, so am now looking for something else that might work. I saw Winamp listed on the Softsqueeze page - will this work as a player with LMS?

kidstypike
2019-02-12, 10:51
I've been unable to resolve issues with my Squeezeplay client on Window 10 prematurely skipping to the next track, so am looking for an alternative player for Windows 10. I've tried installing Softsqueeze, but it cannot recognise my existing Java (v7) runtime, so am now looking for something else that might work. I saw Winamp listed on the Softsqueeze page - will this work as a player with LMS?

I don't know about Winamp, but this works fine:

https://www.microsoft.com/en-gb/p/squeezelite-x/9pbhmtnp9037?activetab=pivot:overviewtab

Yatsushiro
2019-02-12, 11:16
I've been unable to resolve issues with my Squeezeplay client on Window 10 prematurely skipping to the next track, so am looking for an alternative player for Windows 10. I've tried installing Softsqueeze, but it cannot recognise my existing Java (v7) runtime, so am now looking for something else that might work. I saw Winamp listed on the Softsqueeze page - will this work as a player with LMS?

Squeezelite-X has it's own thread on this forum here:

https://forums.slimdevices.com/showthread.php?108550-Announce-Squeezelite-X

itm
2019-02-12, 11:17
I don't know about Winamp, but this works fine:

https://www.microsoft.com/en-gb/p/squeezelite-x/9pbhmtnp9037?activetab=pivot:overviewtab

Great - I had no idea that existed. Many thanks!

itm
2019-02-12, 11:30
Great - I had no idea that existed. Many thanks!

Oh no I'm getting the same problem....skipping to the next item in the playlist before the end of the track. It's strange because I don't get the problem on any of my other players (Squeezebox Booms and Squeezebox Classic). It's just the Windows players that have the issue.
???!!!

d6jg
2019-02-12, 12:15
Try turning off your anti virus

itm
2019-02-13, 03:35
Try turning off your anti virus

Just tried it. Sadly it didn't help :0(

d6jg
2019-02-13, 04:55
Just tried it. Sadly it didn't help :0(

Some more infor needed.
Where is LMS running ? On the W10 machine or elsewhere ?
Is the W10 PC wired or wireless ?

itm
2019-02-13, 05:18
Some more infor needed.
Where is LMS running ? On the W10 machine or elsewhere ?
Is the W10 PC wired or wireless ?

LMS (v7.9.1) is running on a Linux (Lubuntu) server. Both server and PC are connected via ethernet to the same switch.
In the attached log the skip occurred at about 16:17 on Feb 4th. It was playing Tom Waits "Mr Siegal" (on player 0a:00:27:00:00:02), then skipped before the end and started playing the Stereophonics "Don't Let Me Down".
26750

d6jg
2019-02-13, 06:24
LMS (v7.9.1) is running on a Linux (Lubuntu) server. Both server and PC are connected via ethernet to the same switch.
In the attached log the skip occurred at about 16:17 on Feb 4th. It was playing Tom Waits "Mr Siegal" (on player 0a:00:27:00:00:02), then skipped before the end and started playing the Stereophonics "Don't Let Me Down".
26750

These lines
Is the Player synced ?
It looks like LMS can't find a player with mac address cc:cc:0d:f8:b7:a7

[19-02-04 16:17:12.5757] Slim::Player::StreamingController::_eventAction (273) 0a:00:27:00:00:02: StatusHeartbeat in PLAYING-STREAMOUT -> Slim::Player::StreamingController::_CheckSync
[19-02-04 16:17:13.4760] Slim::Web::JSONRPC::requestMethod (455) cc:cc:0d:f8:b7:a7: request not dispatchable!
[19-02-04 16:17:13.6562] Slim::Player::StreamingController::_eventAction (273) 0a:00:27:00:00:02: StatusHeartbeat in PLAYING-STREAMOUT -> Slim::Player::StreamingController::_CheckSync
[19-02-04 16:17:14.7810] Slim::Player::StreamingController::_eventAction (273) 0a:00:27:00:00:02: StatusHeartbeat in PLAYING-STREAMOUT -> Slim::Player::StreamingController::_CheckSync
[19-02-04 16:17:15.0013] Slim::Player::StreamingController::_eventAction (273) 00:04:20:1f:00:c0: StatusHeartbeat in PAUSED-STREAMOUT -> Slim::Player::StreamingController::_CheckPaused

itm
2019-02-13, 06:28
These lines
Is the Player synced ?
It looks like LMS can't find a player with mac address cc:cc:0d:f8:b7:a7

[19-02-04 16:17:12.5757] Slim::Player::StreamingController::_eventAction (273) 0a:00:27:00:00:02: StatusHeartbeat in PLAYING-STREAMOUT -> Slim::Player::StreamingController::_CheckSync
[19-02-04 16:17:13.4760] Slim::Web::JSONRPC::requestMethod (455) cc:cc:0d:f8:b7:a7: request not dispatchable!
[19-02-04 16:17:13.6562] Slim::Player::StreamingController::_eventAction (273) 0a:00:27:00:00:02: StatusHeartbeat in PLAYING-STREAMOUT -> Slim::Player::StreamingController::_CheckSync
[19-02-04 16:17:14.7810] Slim::Player::StreamingController::_eventAction (273) 0a:00:27:00:00:02: StatusHeartbeat in PLAYING-STREAMOUT -> Slim::Player::StreamingController::_CheckSync
[19-02-04 16:17:15.0013] Slim::Player::StreamingController::_eventAction (273) 00:04:20:1f:00:c0: StatusHeartbeat in PAUSED-STREAMOUT -> Slim::Player::StreamingController::_CheckPaused

No, none of the players are synced

d6jg
2019-02-14, 06:43
No, none of the players are synced

This is most probably a network issue or something specific on your PC. Do you have another PC where you could install Squeezeplay for testing ?

bpa
2019-02-14, 07:23
About how much audio is being skipped ? 2 min ? 1 Min ? 30 secs ? 10 sec ? 5 sec ?

If it is very short up 10 to secs then it is likely the audio subsystem is telling player that all audio that has been sent has been played (i.e. sent to audio hardware) where in fact it hasn't.
If it is of the order of minutes - then the the issues is more likely network connections.

what is the output hardware/subsystem e.g. standard PC 3.5mm socket and normal windows audio, a USB DAC and using one of Windows "specialist" audio systems, somethign else (e.g. Bluetooth speaker)
what is the audio format being used e.g. CD 44.1kHz/16 bit in MP3 or HD 192kHz 24 bit WAV (compressed CD quality formats will have longer playing time in player buffer than HD uncompressed formats)

itm
2019-02-14, 09:50
About how much audio is being skipped ? 2 min ? 1 Min ? 30 secs ? 10 sec ? 5 sec ?

If it is very short up 10 to secs then it is likely the audio subsystem is telling player that all audio that has been sent has been played (i.e. sent to audio hardware) where in fact it hasn't.
If it is of the order of minutes - then the the issues is more likely network connections.

what is the output hardware/subsystem e.g. standard PC 3.5mm socket and normal windows audio, a USB DAC and using one of Windows "specialist" audio systems, somethign else (e.g. Bluetooth speaker)
what is the audio format being used e.g. CD 44.1kHz/16 bit in MP3 or HD 192kHz 24 bit WAV (compressed CD quality formats will have longer playing time in player buffer than HD uncompressed formats)

The amount being skipped varies enormously - e.g. sometimes it skips after a minute or so, sometimes 30 seconds from the end of the song.
As an experiment I disabled my ethernet adapter and switched to a USB Wifi dongle - I got the same problem. So it's not a problem specific to the NIC on the PC. I'll try it on a laptop next.
I'm using onboard audio via the 3.5mm socket and wired speakers.
The audio formats vary - 128kbps-320kbps + some VBR.

d6jg
2019-02-14, 09:59
The amount being skipped varies enormously - e.g. sometimes it skips after a minute or so, sometimes 30 seconds from the end of the song.
As an experiment I disabled my ethernet adapter and switched to a USB Wifi dongle - I got the same problem. So it's not a problem specific to the NIC on the PC. I'll try it on a laptop next.
I'm using onboard audio via the 3.5mm socket and wired speakers.
The audio formats vary - 128kbps-320kbps + some VBR.

A very cheap improvement over the 3.5 onboard audio would be one of these - https://www.modmypi.com/raspberry-pi/audio-dacampdigi/usb-sound-cards-1051/usb-sound-adapter-for-the-raspberry-pi

itm
2019-02-14, 10:11
So the laptop has exactly the same problem. I was using the Squeezelite-X app, over wifi, with the built-in speakers.
????

d6jg
2019-02-14, 10:28
So the laptop has exactly the same problem. I was using the Squeezelite-X app, over wifi, with the built-in speakers.
????

If it happens on two separate PCs wired or wireless means it must be on the server side. What is running LMS ?

itm
2019-02-14, 10:37
If it happens on two separate PCs wired or wireless means it must be on the server side. What is running LMS ?

LMS (v7.9.1) is running on a Linux (Lubuntu) server. The hardware is an HP Microserver (Gen 8) - Intel Celeron G1610T, 4GB RAM. Not much else running on it (I use it primarily as a NAS for storage of overnight backups)

d6jg
2019-02-14, 10:40
LMS (v7.9.1) is running on a Linux (Lubuntu) server. The hardware is an HP Microserver (Gen 8)

If you play a constant stream i.e Radio do you get skips or is it limited to local files ?
You said that native SB devices work OK. Have you played the same playlist on both a PC with squeezelite-X and an SB player to be 100% sure.

itm
2019-02-16, 10:03
If you play a constant stream i.e Radio do you get skips or is it limited to local files ?
You said that native SB devices work OK. Have you played the same playlist on both a PC with squeezelite-X and an SB player to be 100% sure.

It doesn't seem to be a problem with online radio stations. The problem is with random mixes, which is how I usually play my music. They work fine on the SB Booms/Classic. I'm trying playback of a full album on Squeezelite-X to see if I get the same issue.

itm
2019-02-16, 10:11
It doesn't seem to be a problem with online radio stations. The problem is with random mixes, which is how I usually play my music. They work fine on the SB Booms/Classic. I'm trying playback of a full album on Squeezelite-X to see if I get the same issue.

OK I just tried album playback on Squeezelite-X and it has the same problem, so it's not specific to random mixes.

itm
2019-02-17, 08:32
OK I just tried album playback on Squeezelite-X and it has the same problem, so it's not specific to random mixes.

I'm now beginning to think it's a problem with the client. Do Squeezelite-X and Squeezeplay share any components/libraries?

itm
2019-02-21, 07:58
I finally gave up and started researching other players for my Windows machine. Came across MusicBee and it really is excellent. Visually appealing, including a slideshow of various shots of the artist whle a track is playing (not just album covers), lyrics display, customisable random play features, and it handles my 92,000 track collection really well. Shame it doesn't integrate with LMS, but I guess beggars can't be choosers....