PDA

View Full Version : RPI-3 piCorePlayer, LMS can not connect with WDMyCloud



Dynaco_wjw
2019-01-05, 08:12
Hello,

On my RPI 3 I installed the piCoreplayer. When I go to the IP address :9000 I can configure LMS. I try to make the connection with a media map on my WDMycloud. There is a share made with the name 'Music' and it contains FLAC files.
With some kind of explorer I can choose /mnt/WDMyCloud but I can not choose the share 'Music'. So eventually there is no database built.

There is maybe another possibility when I go to the IP address of the RPI and I see the configuration panel of piCorePlayer/LMS. Here I have the possibility to mount a Remote Network Share.

I fill in:
Mount Point: /mnt/WDMyCloud
IP Address: 192.168.1.38 (this is the IP address of my NAS)
Share Name: Music (I made this share and put in my FLAC files here)
Share Type: CIFS (is this correct)

When I push 'set NET Mount' I get the message 'Disk Mount Error'.

What is going wrong?

kidstypike
2019-01-05, 09:31
Hello,

On my RPI 3 I installed the piCoreplayer. When I go to the IP address :9000 I can configure LMS. I try to make the connection with a media map on my WDMycloud. There is a share made with the name 'Music' and it contains FLAC files.
With some kind of explorer I can choose /mnt/WDMyCloud but I can not choose the share 'Music'. So eventually there is no database built.

There is maybe another possibility when I go to the IP address of the RPI and I see the configuration panel of piCorePlayer/LMS. Here I have the possibility to mount a Remote Network Share.

I fill in:
Mount Point: /mnt/WDMyCloud
IP Address: 192.168.1.38 (this is the IP address of my NAS)
Share Name: Music (I made this share and put in my FLAC files here)
Share Type: CIFS (is this correct)

When I push 'set NET Mount' I get the message 'Disk Mount Error'.


What is going wrong?

I use a WD MyCloud for my music storage, it works great.

In the options field type "uid=1001,gid=50,vers=1.0" (without quotes).

26487

Dynaco_wjw
2019-01-05, 10:30
Thank you for your answer. I tried it again but I get the next message:

26488

kidstypike
2019-01-05, 10:39
Thank you for your answer. I tried it again but I get the next message:

Have you installed the additional FileSystems?

26489

Dynaco_wjw
2019-01-05, 14:07
Many thanks. No I have not installed this. I will try this. I will put piCorePlayer again on a microSD card.
In the meantime I installed Volumio on the RPI. Now I could attach the desired share on the WD Mycloud.
Tomorrow I will take another microSD card and will install the extra item for additional filesystems.

Dynaco_wjw
2019-01-06, 11:44
Sorry for my late respons but first I wanted to try several things.

Now I installed the Additional Filesystems but no good results. It still does not recognise my /WDMyCloud/Music share.
I also installed a Samba server, but it does not start because I have to configure it and I have no idea how.

Yesterday I format the SD again and I put Volumio on that card. It all went well and during the installation process I could even choose the desired Music share on my WDMyCoud.
I installed the app Volumio on my Samsung Android A3 (2017) phone and I can play the files. Though the response is not very fast when playing files from the NAS. Playing from a USB stick in the RPi is quicker.

This morning I took another microSD (4GB) and I installed piCorePlayer again. Everything works well, also with 4 x 32GB USB attached to the RPi. Except for the database on my NAS.

Jeff07971
2019-01-06, 12:06
Thank you for your answer. I tried it again but I get the next message:

26488

Have you put in your username and password to the share ? They do not appear in the screenshot !

You do not need a Samba Server to mount a CIFS share


26501

Dynaco_wjw
2019-01-06, 13:18
Hello Jeff, thank you very much. I tried before with my username and password but that did not work! I tried everything. Now I tried again and it works!! So thanks a lot to bring me back to this point. Maybe it has to do with installing extended files, I can't remember all the trial anymore. Strange thing is, for Volumio I did not need to fill in any username or password vor the WDMyCloud. I guess I don't have a username and password for this share. Now LMS is making a mediascan of this share now.

Jeff07971
2019-01-06, 15:48
Hello Jeff, thank you very much. I tried before with my username and password but that did not work! I tried everything. Now I tried again and it works!! So thanks a lot to bring me back to this point. Maybe it has to do with installing extended files, I can't remember all the trial anymore. Strange thing is, for Volumio I did not need to fill in any username or password vor the WDMyCloud. I guess I don't have a username and password for this share. Now LMS is making a mediascan of this share now.

Enjoy !

Jeff

Jste84
2019-03-30, 11:00
Many thanks. No I have not installed this. I will try this. I will put piCorePlayer again on a microSD card.
In the meantime I installed Volumio on the RPI. Now I could attach the desired share on the WD Mycloud.
Tomorrow I will take another microSD card and will install the extra item for additional filesystems.

I had similar issues to you, got it working now I can't, any tips