PDA

View Full Version : Stream DVB-S Audio



steffen
2018-12-15, 02:00
Hi,

is there a possibility to stream radio from DVB-S like Astra?
I have a SatIp Server with tvheadend running.
The one how to in this forum did not work vor me.
Thank you.

bpa
2018-12-15, 02:04
The one how to in this forum did not work vor me.

Details ?
Specifically which method didn't work ?
What OS are you using ?
etc.

steffen
2018-12-15, 02:08
Logitech runs as Docker Container on a Synology Ds916+
TvHeadend on a Synology DS214.

Logitech is 7.9.2 / early December.

The Stream does not start. I had it one time working, but it stutters all the time. Next tries didnt even start. From the same bookmark.
Boxes are Softclients, Radios, Booms.

Paul Webster
2018-12-15, 02:49
Were you following this HowTo?
https://forums.slimdevices.com/showthread.php?108276-HowTo-Get-radio-streams-from-TVHeadend-server

bpa
2018-12-15, 04:48
I don't know the system in particular but stuttering and failing to start (but connected OK) generally indicate buffering/data flow issues could be related to transcoding especially as DS214 seems to have a low end CPU Armada 2 core CPU.

The audio stream could be AAC or MP2. If you are playing AAC or MP2 make sure the stream profile avoids transcoding if possible.

Boom does not support AAC natively - so avoid testing with it until Softclient (assuming it can do AAC native) and Radio work OK.

Enable LMS logging player.source to DEBUG to see how LMS has decided to play the stream - it may also give an indication why playing does not start.

pbg4
2018-12-19, 03:30
Hi,

the method described here

http://www.siski.de/~carsten/radio-streaming-squeezebox.html

works quite nicely with tvheadend and the german Astra 19.2 Radio Transponder,..
i.e. 320 kbit/s mp2 radio streams,

the metadata are also displayed, Carsten, the developer of ts2shout has also made
some commits to get the metadata displayed on the squeezebox Radio,

best wishes pbg4

steffen
2018-12-24, 06:33
Thank you. I'll try that out on the next days.
A solution without Logos would be good enough for me :)

steffen
2018-12-30, 01:52
I have the solution working, but it works very unreliable. Yesterday it worked and some time later, I tried again to stream a radio station about a hundred times and the stream did not work.

Using wget localhost/radio/ssl works, but not from squeezebox server.
This morning it worked without any issues. really odd.


Edit: It seems that it works when I switch from another stream to my satellite stream! Not if I turn on radio and start my satellite stream.