PDA

View Full Version : Squeezebox v3 died



Schomosport
2018-12-08, 09:53
The cats have rattled the Squeezebox back into the gap between the speaker on which it sits one time too many and now the display will no longer power on.

Having scanned through the forum I have tried:

Remove / replace wireless card
Wired connection to router with wireless card removed (except antenna cables)
Press firmly down on daughter board to check it hadn't been displaced
Reset Xilinix chip

Nothing doing with any of these - red light in the back of the fibre-optic port lights ok

Card sets smells gently warm, nothing stinking or notably hot to the touch.

Power supply voltage is 5.25V disconnected and 4.4V when connected and measured at the card. That seems a little low but I don't know if the culprit lies within the PSU module or the electronics and I don't have a spare to fault find by substitution.

Any suggestions as to how to proceed?

alfista
2018-12-08, 11:27
Most likely the power supply, voltage shouldn't drop that much when connected. Theoretically it could be something inside the SB3 drawing too much current, but given how prone the power supplies are to fail I'd say it's the place to start.

philippe_44
2018-12-08, 13:19
Most likely the power supply, voltage shouldn't drop that much when connected. Theoretically it could be something inside the SB3 drawing too much current, but given how prone the power supplies are to fail I'd say it's the place to start.

+1 for that - it really looks like the PSU is faulty

markm9999
2018-12-14, 00:22
Not sure if the OP resolved this, but in case somebody else comes upon this thread, there was another one and the person found OEM PSU's on eBay
https://www.ebay.com/itm/Logitech-Squeezebox-Slim-Device-Classic-Touch-Power-Supply-UL110-0520-NEW-OEM/360417980249?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2057872.m2749.l2649

Schomosport
2018-12-16, 08:30
Thanks, it was the power supply. Bought the necessary adapter and connected it up to my old laboratory power supply and it booted up just fine.

In the meantime I had trawled the web for trouble shooting info. in addition to this forum. A lot of information available at this link:

https://joes-tech-blog.blogspot.com/

tbessie
2018-12-18, 23:42
Ha! I came here JUST to say this same thing (well, without the cats); my Squeezebox 3 has been sitting on a shelf, plugged in, for many years. I rarely use it (I have a Boom, Radio and Duet that I use more), but still would like it to work.

The other day, without anything happening to it, it just... stopped turning on.

I do wonder if it's the power supply or something else; might be worth buying that power supply on eBay there.

- Tim

tbessie
2018-12-21, 14:05
Well hooray, it was just the power supply!

Thanks for supplying the link to the eBay sale! Saved me a lot of trouble!

- Tim