View Full Version : Hissing sounds and AlienBBC (Take 2)

Patrick Delamere
2005-01-09, 20:59
Sorry about the bad formatting of the previous mail.  I'll try again.  Still getting used to using Linux as a Desktop machine instead of Windows.  :-D


Hi All,

Just when I had my Linux setup all perfect, it was time to fiddle around again and break something!   :-)

Anyway, I've just completed the process of replacing all the operating system on all my machines (err, all 2 of them   ;-)  ) with SuSE Linux 9.2, and have
been working to rebuild my Slimserver.

At one stage, Slimserver, including AlienBBC was working fine, but somewhere, somehow along the line, a few installations later, these stopped working

2 scenarios are now occurring:

[1]  AlienBBC cannot bind to port 5123.
[2]  After one song, the sound stream stops completely and I just get a weird
continuous hissing sound (so far WMA files only).

Before I explain more about the above, below is my server spec:

Slimserver 5.4.0-1 AlienBBC 12 SuSE Linux 9.2 (2.6.8-24.10-default) AMD 2800+ Processor 1.5GB ram Wired 100bit LAN Perl v5.8.5 HTML::Parser (updated via CPAN) HTTP::Daemon (updated via CPAN)
Now to explain more about my 2 problems:

[1]  AlienBBC cannot bind to port 5123.

Basically, everytime I click on a radio playlist, I get the following log

Found lame at: /usr/local/bin/lame
Couldn't bind to port 5123 at /usr/local/slimserver/transcoder_proxy.pl line

Having searched around, I tried the standard few things:

[A]    http://<slimserver-ip-address>:5123/Status.     [ok]
        STATUS: OK
        Proxy Diagnostics:
        Proxy set to use mplayer

    Connect to http://<slimserver-ip-address>:5123/RealAudio/http://www.bbc.co.uk/radio2/realmedia/fmg2.rpm using
RealPlayer 10.  [ok]

[C]  Nothing else running on port 5123.  [ok]

So, despite the above tests running ok, I still get the above error when trying to connect via the AlienBBC web interface.

As well as the connection issues as described above, I also get

Going to play: /var/slimserver/playlists/AlienStream/Bayern2_Radio.smil
cannot connect to http daemon to get playlist
at /usr/local/slimserver/Slim/Utils/Scan.pm line 364.
going to Item: 6
Adding: Bayern1, index.html?menu=6.&play=6.0.
Adding: Bayern2 Radio, index.html?menu=6.&play=6.1.
Adding: Bayern3, index.html?menu=6.&play=6.2.
Adding: Bayern4 Klassik, index.html?menu=6.&play=6.3.
Adding: Bayern5 Aktuell, index.html?menu=6.&play=6.4.
Adding: DeutschlandRadio Berlin, index.html?menu=6.&play=6.5.
Adding: Deutschland Funk, index.html?menu=6.&play=6.6.
Adding: MDR Info, index.html?menu=6.&play=6.7.
Adding: N-Joy, index.html?menu=6.&play=6.8.
Adding: NDR2, index.html?menu=6.&play=6.9.
Adding: NDR Info, index.html?menu=6.&play=6.10.
Adding: NDR Kultur, index.html?menu=6.&play=6.11.
Adding: Radio Hamburg, index.html?menu=6.&play=6.12.
Adding: SWR1, index.html?menu=6.&play=6.13.
Adding: SWR3, index.html?menu=6.&play=6.14.
Adding: Talk Radio, index.html?menu=6.&play=6.15.
Adding: WDR2, index.html?menu=6.&play=6.16.
Adding: WDR5, index.html?menu=6.&play=6.17.
Adding: WDR Eins Live, index.html?menu=6.&play=6.18.
Adding: WXPN, index.html?menu=6.&play=6.19.
Adding: wdr5-wm32, index.html?menu=6.&play=6.20.
Adding: AlienBBC Home, index.html
Found lame at: /usr/local/bin/lame
Found lame at: /usr/local/bin/lame
Couldn't bind to port 5123 at /usr/local/slimserver/transcoder_proxy.pl line
Status requested
Closing Down
Use of uninitialized value in pattern match (m//)
at /usr/local/slimserver/Plugins/Alien/Plugin.pm line 596.

So, that's the AlienBBC issue.

[b][2]  After a few songs, the sound stream stops completely and I just get a
weird continuous hissing sound.

Like a very badly tuned radio, in fact, more like trying to a catch a station
on a desert island with no radio mast for hundreds of miles, after playing
one song, all I get is a continuous stream of hissing.

It's probably important to mention at this stage that I have just listened to
12 MP3 files in a row without any problems, so I think this is a WMA issue.
Below is my log output (whilst paying a few WMAs):

Press [q] to stop encoding
Error while decoding stream #0.0
size=    1056kB time=6.1 bitrate=1411.3kbits/s
video:0kB audio:1056kB global headers:0kB muxing overhead 0.004069%
Stream mapping:
  Stream #0.0 -> #0.0
Press [q] to stop encoding
Stream mapping:
  Stream #0.0 -> #0.0
Press [q] to stop encoding
Error while decoding stream #0.0
size=   30928kB time=179.5 bitrate=1411.2kbits/s
video:0kB audio:30928kB global headers:0kB muxing overhead 0.000139%
size=   45408kB time=263.6 bitrate=1411.2kbits/s
video:0kB audio:45408kB global headers:0kB muxing overhead 0.000095%
Stream mapping:
  Stream #0.0 -> #0.0
Press [q] to stop encoding

I hope it means something to someone, because it doesn't mean much to me.


After each song, I just seem to get:

Stream mapping:
  Stream #0.0 -> #0.0
Press [q] to stop encoding

and that's it, the end of play and I have to go back to the web interface to
select another song.

So far I am only experiencing this with WMA files?  Perhaps a problem with
LAME?  I am using the identical configuration (apart from software versions)
as I did prior to the server rebuild, so I don't think it is a Slimserver
configuration issue.

Also, there was a time when all this was working after the rebuild, but I
have installed so much onto the server now, that it's a big web to entangle
to find out exactly what I did to break it!  The same server that Slimserver
runs on, also runs Exim, Horde/IMP, Webmin, Jboss, Resin, Qpopper, MySQL,
Postgres, ClamAV, SpamAssassin, Apache & Php.  However, the server is not
stressed in the slightest, and the 1.5gb memory is more than sufficient.

Not sure this is relevant, but whenever I start slimserver.pl, I get the
following error line:

Subroutine HTML::Entities::decode_entities redefined
at /usr/lib/perl5/5.8.5/i586-linux-thread-multi/DynaLoader.pm line 253,
<DATA> line 1.

I would be very grateful indeed for some insight into the above problems.