PDA

View Full Version : Library appears to be completely empty and cannot rescan



bzlrbi
2018-12-02, 23:22
I don't know what happened here, but my Squeezebox libary appears completely empty. It seems that the artwork is still in there, but none of the underlying albums. Meanwhile, attempts to rescan either changed media files or to clear and rescan "terminate unexpectedly (Scanning Progress."

Here is the basic data:

Logitech Media Server Status
Logitech Media Server Version: 7.9.0 - 1451716652 @ Sat Jan 2 06:44:22 CUT 2016
Hostname: (redacted)
Server IP Address: 192.168.0.108
Server HTTP Port Number: 9000
Operating system: Windows 10 - EN - cp1252
Platform Architecture: 8664
Perl Version: 5.14.1 - MSWin32-x86-multi-thread
Audio::Scan: 0.95
Database Version: DBD::SQLite 1.34_01 (sqlite 3.7.7.1)
Total Players Recognized: 3

-----------------

I have a very large library, 13,000 "albums" spread over ~4 hard drives. That hasn't presented a problem in the past.

LMS seems completely operational, otherwise. I can stream CDs (using plugin) or those same "missing" albums using the "wavin" plugin, without any noticeable problems.

Is there anything I should try doing before I do a complete LMS uninstall/reinstall? I have tried rebooting hard drives, players and my LAN, without effect.

Thanks!

mherger
2018-12-02, 23:34
> Logitech Media Server Version: 7.9.0 - 1451716652 @ Sat Jan 2 06:44:22
> CUT 2016

That's almost 3 years old. I'd suggest you update to the latest 7.9.2
nightly (http://downloads.slimdevices.com/nightly/index.php?ver=7.9)

Then you run a full wipe & rescan, and upload you scanner.log.zip to
https://www.dropbox.com/request/T3RctyzGgNg0oFDubq6a

--

Michael

bzlrbi
2018-12-03, 08:36
Thanks! Will do this, and let you know my progress.

bzlrbi
2018-12-04, 21:06
Partial success. I went out of town about 30 hours ago and the scan is still showing the same folder. The abort button doesn't work. But, most of the library is back.

Further investigation in process. I don't see anything about that hung-up folder in the scanner log. I'm going to reboot (and stuff).

Thanks!

bzlrbi
2018-12-05, 07:11
A CPU reboot got me further along, but I still have an "unexpected" scan termination. Maybe this is more "form over substance" though?

The library appears to be (at least) mostly there, and for the first time in years, I can access Music Folders without everything "freezing" up. That's a great thing! I've spent hours tagging stuff to get around that.

DJanGo
2018-12-05, 14:15
Partial success. I went out of town about 30 hours ago and the scan is still showing the same folder.
Did you removed or added the "other" stuff like Pictures and videos (my lms runs with "--nomysqueezebox --noimage --novideo) for scanning?

bzlrbi
2018-12-10, 09:01
Did you removed or added the "other" stuff like Pictures and videos (my lms runs with "--nomysqueezebox --noimage --novideo) for scanning?

I just checked and it had reset itself to include those (whereas I usually leave unchecked). Thanks.