PDA

View Full Version : Airplay Stutter on Tune-In but not on MP3 from disk-drive



maeffjus
2018-10-10, 10:38
Hi Guys,

like many, I registered after having trouble now during my first steps with LMS.
I set up LMS recently on a Windows 2012 R2, with a local drive full of music.

I then added first a Pioneer VSX-830 via Airplay Bridge, which turned out to work great, both with internet-radio AND MP3 from the local disk.

In order to have a compact non-makeshift device in the kitchen I simply looked for a Airplay-speaker.
My choice was the AUGUST WS300G.
After I added it to my (Sophos 3xAP enterprise) Wifi, I started with playing different streams from Tune-In.
They had stutter & clicking noise (every 1-2-3 sec.), so I tried various streams, none was different. I also tried local MP3, which works great.
I also limited the bitrate for the speaker (in steps, down to 64kbit/s) and therefor installed lamenc. Did not help.

Finally I just now tried to use the Pioneer with Tune-In, which works still fine.
So in fact, settings for Pioneer & August are the same, but August is not being worth to turn on.

Do you guy have any idea? Otherwise I have to return the speaker..
Thanks in advance,

Maeffjus

BTW: Using the LMS for 4 days, awesome thing!

philippe_44
2018-10-11, 03:42
Hi Guys,

like many, I registered after having trouble now during my first steps with LMS.
I set up LMS recently on a Windows 2012 R2, with a local drive full of music.

I then added first a Pioneer VSX-830 via Airplay Bridge, which turned out to work great, both with internet-radio AND MP3 from the local disk.

In order to have a compact non-makeshift device in the kitchen I simply looked for a Airplay-speaker.
My choice was the AUGUST WS300G.
After I added it to my (Sophos 3xAP enterprise) Wifi, I started with playing different streams from Tune-In.
They had stutter & clicking noise (every 1-2-3 sec.), so I tried various streams, none was different. I also tried local MP3, which works great.
I also limited the bitrate for the speaker (in steps, down to 64kbit/s) and therefor installed lamenc. Did not help.

Finally I just now tried to use the Pioneer with Tune-In, which works still fine.
So in fact, settings for Pioneer & August are the same, but August is not being worth to turn on.

Do you guy have any idea? Otherwise I have to return the speaker..
Thanks in advance,

Maeffjus

BTW: Using the LMS for 4 days, awesome thing!

Sorry, itís confusing: The August, when accessed from LMS through the Airplay bridge is shuttering, but it does not when you access it directly from iTunes directly right?
If this is the case, because I have to play funny with offset timers in airplay bridge and some airplay clones donít handle it well, try to change the value of that delay in airplay plugin settings

maeffjus
2018-10-11, 04:05
Sorry, itís confusing: The August, when accessed from LMS through the Airplay bridge is shuttering, but it does not when you access it directly from iTunes directly right?
If this is the case, because I have to play funny with offset timers in airplay bridge and some airplay clones donít handle it well, try to change the value of that delay in airplay plugin settings

Hi philippe,

nope - it does stutter and clicker on playing any streaming-radio via LMS, but does not when playing locally stored (on the server) MP3-files via the LMS.
I never used it without LMS - I don't even have iTunes.... ;-)

It plays from the LMS local drive both CBR & VBR MP3 in various bitrates, but fails on CBR128kbit from tune-in.
Regards,
Matthias

philippe_44
2018-10-11, 08:32
Hi philippe,

nope - it does stutter and clicker on playing any streaming-radio via LMS, but does not when playing locally stored (on the server) MP3-files via the LMS.
I never used it without LMS - I don't even have iTunes.... ;-)

It plays from the LMS local drive both CBR & VBR MP3 in various bitrates, but fails on CBR128kbit from tune-in.
Regards,
Matthias

Did you try to use "proxied streaming" in the players's configuration (LMS 'settings', tab 'players', choose your player then 'audio')

maeffjus
2018-10-12, 01:10
Did you try to use "proxied streaming" in the players's configuration (LMS 'settings', tab 'players', choose your player then 'audio')

Sure, I did this as one of the first setting I've modified. I assume it puts my server in between.
Did not help - I've started a return on eBay and will now got for the Blaupunkt WG500, lets see how this one performs ;-)
(I'm looking for a device with a battery that I can also take outside from the kitchen to hear music when having a barbecue)

cpd73
2018-10-12, 04:16
Sure, I did this as one of the first setting I've modified. I assume it puts my server in between.
Did not help - I've started a return on eBay and will now got for the Blaupunkt WG500, lets see how this one performs ;-)
(I'm looking for a device with a battery that I can also take outside from the kitchen to hear music when having a barbecue)

I know they're a bit more expensive, but the Libratone Zipp works great with the Airplay bridge. If you wait, they're quite often £149 on Amazon.

Man in a van
2018-10-12, 04:23
I know they're a bit more expensive, but the Libratone Zipp works great with the Airplay bridge. If you wait, they're quite often £149 on Amazon.


There might be deals available, there is a new model to be released soon.

castalla
2018-10-12, 04:44
I know they're a bit more expensive, but the Libratone Zipp works great with the Airplay bridge. If you wait, they're quite often £149 on Amazon.

I second this recommendation -there's a new Zipp 2 coming out, but as it's airplay 2 compatible it may not work with the airplay bridge.

maeffjus
2018-10-12, 04:50
There might be deals available, there is a new model to be released soon.

Maybe I#ll think about it for another room, but I guess the Blaupunkt is another league of speaker. The libratone seems like a smaller device, the Blaupunkt is rather big, I hope this positively influences sound quality.
Here it is: https://www.amazon.de/gp/product/B01G934VRY
And I wonder, on the German / Austrian price comparison "Geizhals.net" it is for 169Ä, except for one seller on Amazon. Ebay is also way beyond with 170Ä.
Ebay UK has it for a whopping 285Ä plus 35Ä shipping..

So I think it might be a real deal-breaker for 99 bucks.

castalla
2018-10-12, 05:06
Maybe I#ll think about it for another room, but I guess the Blaupunkt is another league of speaker. The libratone seems like a smaller device, the Blaupunkt is rather big, I hope this positively influences sound quality.
Here it is: https://www.amazon.de/gp/product/B01G934VRY
And I wonder, on the German / Austrian price comparison "Geizhals.net" it is for 169Ä, except for one seller on Amazon. Ebay is also way beyond with 170Ä.
Ebay UK has it for a whopping 285Ä plus 35Ä shipping..

So I think it might be a real deal-breaker for 99 bucks.

Sound quality is so subjective .... the Zipp sound is very good IMHO. One advantage is that there's an equalizer function in the app which 'sticks' even when used with LMS airplay. Wifi reach is also excellent.

Paul Webster
2018-10-12, 05:59
I second this recommendation -there's a new Zipp 2 coming out, but as it's airplay 2 compatible it may not work with the airplay bridge.

Some work was done on the plugin recently to help with devices that support Airplay 2.
If you have one that did not work then it might be worth trying it again with most recent plugin version.

maeffjus
2018-10-12, 06:05
Sound quality is so subjective .... the Zipp sound is very good IMHO. One advantage is that there's an equalizer function in the app which 'sticks' even when used with LMS airplay. Wifi reach is also excellent.
Let's see, the AUGUST was okay in terms of bass, but the higher frequencies have been not very clear at all. The sound was more or less a bit "washed".

Wifi is no problem at all, I got an AP in between the basement and ground floor, one in between the ground & first floor and one in the courtyard. All of them build one huge mesh-network.
If there is one thing good, it is wifi in my house :-)
But these AP's have been more expensive each than the libratone Zipp (Sophos AP55, Sophos AP55C and Sophos AP15) when I bought them.

I started using the LMS for certain reasons:

1. Price: I'm running a 24/7 W2012 server, so why go with expensive Sonos stuff?
2. Existing devices: I got a 5.1 speaker-system in my living-room, why add one speaker more which only can be worse in terms of sound?
3. Freedom: The LMS is so flexible, why add constraints from stuff like Sophos & friends when I can do whatever I want?
4. Existing music: I got ~15.000 songs on my server, why just mostly stuck with radio-streaming when I also can make these available too?

In my bathroom there are already speakers in the ceiling, I also got a "Gira RDS radio" with line-in, I will just connect one PiZero W with the PhatDac. Beside this, the radio is quite bad - I only receive two channels in the bathroom...

castalla
2018-10-12, 06:17
Some work was done on the plugin recently to help with devices that support Airplay 2.
If you have one that did not work then it might be worth trying it again with most recent plugin version.

Still no luck with Sonos Beam ...

philippe_44
2018-10-13, 14:25
Still no luck with Sonos Beam ...

It's AirPlay2 only. The modification I've made are to support AirPlay devices that support AirPlay2 as well