PDA

View Full Version : AAC+ Transcoding help needed.



Wirrunna
2018-09-10, 21:14
Long time user of Inguz EQ, but only just tried internet radio streaming due to the demise of an old stereo receiver.

Discovered that the stations I want to get are AAC+ and play fine until the Inquz plugin is loaded.
Inguz plugin.pm creates a custom-convert.conf that directs files through the Inguz magic:


# Modified by InguzEQ, Tue Sep 11 13:59:02 2018: New configuration

# #inguzeq#begin#rev:0.9.33#client:7c:dd:90:bc:60:b1 # ***** BEGIN AUTOMATICALLY GENERATED SECTION - DO NOT EDIT ****

aap flc * 7c:dd:90:bc:60:b1
#IFR
[mplayer] -ac faad -demuxer aac -really-quiet -vc null -vo null -cache 64 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:file=/dev/fd/4 $FILE$ 4>&1 1>/dev/null | [InguzDSP] -id "7c:dd:90:bc:60:b1" -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

aif flc * 7c:dd:90:bc:60:b1
# FT:{START=-skip %t}
[InguzDSP] -id "7c:dd:90:bc:60:b1" -input $FILE$ $START$ -be -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

alc flc * 7c:dd:90:bc:60:b1
# F
[alac] $FILE$ | [InguzDSP] -id "7c:dd:90:bc:60:b1" -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

amb flc * 7c:dd:90:bc:60:b1
# IFT:{START=-skip %t}
[InguzDSP] -id "7c:dd:90:bc:60:b1" -input $FILE$ $START$ -amb -wavo -d 24 | [flac] -cs -5 --totally-silent -

ape flc * 7c:dd:90:bc:60:b1
# F
[mac] $FILE$ - -d | [InguzDSP] -id "7c:dd:90:bc:60:b1" -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

flc flc * 7c:dd:90:bc:60:b1
# FT:{START=--skip=%t}U:{END=--until=%v}
[flac] -dcs $START$ $END$ -- $FILE$ | [InguzDSP] -id "7c:dd:90:bc:60:b1" -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

mov flc * 7c:dd:90:bc:60:b1
# FR
[mov123] $FILE$ | [InguzDSP] -id "7c:dd:90:bc:60:b1" -be -wavo -d 24 | [flac] -cs -5 --totally-silent -

mp3 flc * 7c:dd:90:bc:60:b1
# IFD:{RESAMPLE=--resample %D}
[lame] --mp3input --decode $RESAMPLE$ --silent $FILE$ - - | [InguzDSP] -id "7c:dd:90:bc:60:b1" -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

mpc flc * 7c:dd:90:bc:60:b1
# IR
[mppdec] --silent --prev --gain 3 - - | [InguzDSP] -id "7c:dd:90:bc:60:b1" -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

ogg flc * 7c:dd:90:bc:60:b1
# IFD:{RESAMPLE=-r %D}
[sox] -t ogg $FILE$ -t wav $RESAMPLE$ -w - | [InguzDSP] -id "7c:dd:90:bc:60:b1" -be -wavo -d 24 | [flac] -cs -5 --totally-silent -

uhj flc * 7c:dd:90:bc:60:b1
# FT:{START=-skip %t}
[InguzDSP] -id "7c:dd:90:bc:60:b1" -input $FILE$ $START$ -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

wav flc * 7c:dd:90:bc:60:b1
# FT:{START=-skip %t}
[InguzDSP] -id "7c:dd:90:bc:60:b1" -input $FILE$ $START$ -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

wma flc * 7c:dd:90:bc:60:b1
# F:{PATH=%f}R:{PATH=%F}
[wmadec] -w $PATH$ | [InguzDSP] -id "7c:dd:90:bc:60:b1" -wavo -d 24 | [flac] -cs -5 --totally-silent -

wvp flc * 7c:dd:90:bc:60:b1
# FT:{START=--skip=%t}U:{END=--until=%v}
[wvunpack] $FILE$ -wq $START$ $END$ -o - | [InguzDSP] -id "7c:dd:90:bc:60:b1" -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -


# #inguzeq#end#client:7c:dd:90:bc:60:b1# ***** END AUTOMATICALLY GENERATED SECTION - DO NOT EDIT *****

I suspect the first line is the problem = mplayer was replaced during LMS 7.2 or thereabouts.
Now I tried

[faad] -q -w -f 1 $FILE$ | [InguzDSP] -id "7c:dd:90:bc:60:b1" -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -
but that didn't work.
As it is relatively simple to alter the code in Inguz plugin.pm I was hoping one of the gurus could offer a helpful suggestion.

bpa
2018-09-11, 00:22
What version of LMS are you running ?

AAC and AAC+ support are the same.

IIRC Before LMS 7.3 or maybe 7.5 - streaming AAC was not supported as standard by LMS so I wrote a plugin (PlayAAC?) which defined a type "aap" and used mplayer to decode AAC .

When LMS started supporting streaming AAC - with type "aac" and faad - there was no need for the PlayAAC plugin - in fact the plugin should be removed.

Unless you are still running 7.2 I'm guess you still have the PlayAAC when it should have been removed.

edit:

The PlayAAC plugin had to be installed manually and so removed manually (i.e. pre Plugin manager capability) and as such if using LMS 7.5 onwards may not appear on the WebUI Setting/Plugins page.

Wirrunna
2018-09-11, 01:00
bpa,
Logitech Media Server Version: 7.9.2 - 1535981655 @ Mon Sep 3 15:44:00 CEST 2018, on a Vortexbox, Fedora 25.

It is the Inguz created custom-convert.conf that is the problem. With Inguz plugin uninstalled the aac+ streams play.

I set logging on player.source to debug and generated a lot of messages

[18-09-11 12:42:47.2437] Slim::Player::Song::__ANON__ (298) Found a playlist
[18-09-11 12:42:47.2472] Slim::Player::Song::getNextSong (229) http://opml.radiotime.com/Tune.ashx?id=s99441&formats=aac,ogg,mp3&partnerId=16&serial=03f508163b94b494e97bf5545cd5bcc0
[18-09-11 12:42:47.2474] Slim::Player::Song::_getNextPlaylistTrack (212) Getting next audio URL from playlist (after )
[18-09-11 12:42:47.2475] Slim::Player::Song::_getNextPlaylistTrack (218) Got next URL from playlist; track is: http://live-radio01.mediahubaustralia.com/2FMW/aac/
[18-09-11 12:42:47.2476] Slim::Player::StreamingController::_nextTrackReady (737) 7c:dd:90:bc:60:b1: nextTrack will be index 0
[18-09-11 12:42:47.2477] Slim::Player::StreamingController::_eventAction (273) 7c:dd:90:bc:60:b1: NextTrackReady in STOPPED-TRACKWAIT -> Slim::Player::StreamingController::_Stream
[18-09-11 12:42:47.2478] Slim::Player::StreamingController::_Stream (1203) Song queue is now 0
[18-09-11 12:42:47.2479] Slim::Player::StreamingController::_Stream (1206) 7c:dd:90:bc:60:b1: preparing to stream song index 0
[18-09-11 12:42:47.2479] Slim::Player::Song::open (364) http://live-radio01.mediahubaustralia.com/2FMW/aac/
[18-09-11 12:42:47.2481] Slim::Player::Song::open (388) seek=false time=0 canSeek=0SEEK_ERROR_TYPE_NOT_SUPPORTEDm3u
[18-09-11 12:42:47.2482] Slim::Player::TranscodingHelper::checkBin (242) Checking formats for: aap-aac-squeezelite-7c:dd:90:bc:60:b1
[18-09-11 12:42:47.2483] Slim::Player::TranscodingHelper::checkBin (242) Checking formats for: aap-aac-*-7c:dd:90:bc:60:b1
[18-09-11 12:42:47.2484] Slim::Player::TranscodingHelper::checkBin (242) Checking formats for: aap-aac-squeezelite-*
[18-09-11 12:42:47.2484] Slim::Player::TranscodingHelper::checkBin (242) Checking formats for: aap-aac-*-*
[18-09-11 12:42:47.2485] Slim::Player::TranscodingHelper::checkBin (242) Checking formats for: aap-ogg-squeezelite-7c:dd:90:bc:60:b1
[18-09-11 12:42:47.2486] Slim::Player::TranscodingHelper::checkBin (242) Checking formats for: aap-ogg-*-7c:dd:90:bc:60:b1
[18-09-11 12:42:47.2486] Slim::Player::TranscodingHelper::checkBin (242) Checking formats for: aap-ogg-squeezelite-*
[18-09-11 12:42:47.2487] Slim::Player::TranscodingHelper::checkBin (242) Checking formats for: aap-ogg-*-*
[18-09-11 12:42:47.2488] Slim::Player::TranscodingHelper::checkBin (242) Checking formats for: aap-flc-squeezelite-7c:dd:90:bc:60:b1
[18-09-11 12:42:47.2488] Slim::Player::TranscodingHelper::checkBin (242) Checking formats for: aap-flc-*-7c:dd:90:bc:60:b1
[18-09-11 12:42:47.2489] Slim::Player::TranscodingHelper::enabledFormat (209) Checking to see if aap-flc-*-7c:dd:90:bc:60:b1 is enabled
[18-09-11 12:42:47.2489] Slim::Player::TranscodingHelper::checkBin (250) enabled
[18-09-11 12:42:47.2490] Slim::Player::TranscodingHelper::checkBin (252) Found command: #IFR
[18-09-11 12:42:47.2491] Slim::Player::TranscodingHelper::getConvertCommand 2 (446) Matched: aap->flc via: #IFR
[18-09-11 12:42:47.2492] Slim::Player::Song::open (409) Transcoder: streamMode=I, streamformat=flc
[18-09-11 12:42:47.2492] Slim::Player::Song::open (462) Opening stream (no direct streaming) using Slim::Player::Protocols::HTTP [http://live-radio01.mediahubaustralia.com/2FMW/aac/]
[18-09-11 12:42:47.3229] Slim::Player::Song::open (483) URL is a song (audio): http://live-radio01.mediahubaustralia.com/2FMW/aac/, type=aap
[18-09-11 12:42:47.3231] Slim::Player::TranscodingHelper::tokenizeConvertCo mmand2 (617) Using command for conversion: #IFR
[18-09-11 12:42:47.3233] Slim::Player::Song::open (559) Tokenized command: #IFR
[18-09-11 12:42:47.3339] Slim::Networking::IO::Select::__ANON__ (131) Error: Select task failed calling Slim::Networking::Async::_async_read: open2: exec of #IFR failed: No such file or directory at /usr/lib64/perl5/vendor_perl/Slim/Player/Pipeline.pm line 138.
; fh=Slim::Networking::Async::Socket::HTTP=GLOB(0x55 ab3a0e05e0)
[18-09-11 12:42:49.0025] Slim::Player::StreamingController::_eventAction (273) 7c:dd:90:bc:60:b1: StatusHeartbeat in STOPPED-TRACKWAIT -> Slim::Player::StreamingController::_NoOp
[18-09-11 12:42:53.0024] Slim::Player::StreamingController::_eventAction (273) 7c:dd:90:bc:60:b1: StatusHeartbeat in STOPPED-TRACKWAIT -> Slim::Player::StreamingController::_NoOp
[18-09-11 12:42:57.0016] Slim::Player::StreamingController::_eventAction (273) 7c:dd:90:bc:60:b1: StatusHeartbeat in STOPPED-TRACKWAIT -> Slim::Player::StreamingController::_NoOp

bpa
2018-09-11, 01:22
bpa,
Logitech Media Server Version: 7.9.2 - 1535981655 @ Mon Sep 3 15:44:00 CEST 2018, on a Vortexbox, Fedora 25.

It is the Inguz created custom-convert.conf that is the problem. With Inguz plugin uninstalled the aac+ streams play.

1. Squeezelite can play AAC streams natively.
2. The PlayAAC plugin is install as I can see the "aap" type being checked.
3. The following fails becuase LMS code has changed and PlayAAC is trying to call a routing in Pipeline.pm.


[18-09-11 12:42:47.3339] Slim::Networking::IO::Select::__ANON__ (131) Error: Select task failed calling Slim::Networking::Async::_async_read: open2: exec of #IFR failed: No such file or directory at /usr/lib64/perl5/vendor_perl/Slim/Player/Pipeline.pm line 138.
; fh=Slim::Networking::Async::Socket::HTTP=GLOB(0x55 ab3a0e05e0)



Stop LMS and manually delete the PlayAAC plugin directory and then restart LMS.

bpa
2018-09-11, 01:45
Looking back at old threads - there was a period where I did not have a plugin so support for AAC+ for streams was done via manual mods to conf files. Perhaps there is an old conf file somehwere on your system.

Find the types.conf or custom-types.conf file with the following line as it defines the "aap" tyoe which is now non-standard and not required in LMS..


aap ? audio/aacp audio


It's a long time ago but didn't InguzDSP somehow scan various conf files to generate its conf file ?

Wirrunna
2018-09-11, 04:16
It's a long time ago but didn't InguzDSP somehow scan various conf files to generate its conf file ?

Inguz created custom-convert.conf files based on "client type" -


# transcode for 24-bit FLAC output (sb2, sb3, transporter)
sub template_FLAC24
{
return <<'EOF1';

aap flc * $CLIENTID$
#IFR
[mplayer] -ac faad -demuxer aac -really-quiet -vc null -vo null -cache 64 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:file=$PIPEOUT$ $FILE$ $PIPENUL$ | [$CONVAPP$] -id "$CLIENTID$" -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

aif flc * $CLIENTID$
# FT:{START=-skip %t}
[$CONVAPP$] -id "$CLIENTID$" -input $FILE$ $START$ -be -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

alc flc * $CLIENTID$
# F
[alac] $FILE$ | [$CONVAPP$] -id "$CLIENTID$" -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

amb flc * $CLIENTID$
# IFT:{START=-skip %t}
[$CONVAPP$] -id "$CLIENTID$" -input $FILE$ $START$ -amb -wavo -d 24 | [flac] -cs -5 --totally-silent -

ape flc * $CLIENTID$
# F
[mac] $FILE$ - -d | [$CONVAPP$] -id "$CLIENTID$" -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

flc flc * $CLIENTID$
# FT:{START=--skip=%t}U:{END=--until=%v}
[flac] -dcs $START$ $END$ -- $FILE$ | [$CONVAPP$] -id "$CLIENTID$" -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

mov flc * $CLIENTID$
# FR
[mov123] $FILE$ | [$CONVAPP$] -id "$CLIENTID$" -be -wavo -d 24 | [flac] -cs -5 --totally-silent -

mp3 flc * $CLIENTID$
# IFD:{RESAMPLE=--resample %D}
[lame] --mp3input --decode $RESAMPLE$ --silent $FILE$ - - | [$CONVAPP$] -id "$CLIENTID$" -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

mpc flc * $CLIENTID$
# IR
[mppdec] --silent --prev --gain 3 - - | [$CONVAPP$] -id "$CLIENTID$" -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

ogg flc * $CLIENTID$
# IFD:{RESAMPLE=-r %D}
[sox] -t ogg $FILE$ -t wav $RESAMPLE$ -w - | [$CONVAPP$] -id "$CLIENTID$" -be -wavo -d 24 | [flac] -cs -5 --totally-silent -

uhj flc * $CLIENTID$
# FT:{START=-skip %t}
[$CONVAPP$] -id "$CLIENTID$" -input $FILE$ $START$ -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

wav flc * $CLIENTID$
# FT:{START=-skip %t}
[$CONVAPP$] -id "$CLIENTID$" -input $FILE$ $START$ -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

wma flc * $CLIENTID$
# F:{PATH=%f}R:{PATH=%F}
[wmadec] -w $PATH$ | [$CONVAPP$] -id "$CLIENTID$" -wavo -d 24 | [flac] -cs -5 --totally-silent -

wvp flc * $CLIENTID$
# FT:{START=--skip=%t}U:{END=--until=%v}
[wvunpack] $FILE$ -wq $START$ $END$ -o - | [InguzDSP] -id "$CLIENTID$" -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

EOF1


The Inguz plugin.pm performs two basic functions -
1. gather filter data - eg graphic equaliser filters, room correction filters etc and set filters for the convolver
2. generate custom-convert.conf settings for each particular file type.
Now here is where I get a bit selfish, I only have flac and mp3 in my library and those work fine through Inguz, but now I want to play an aac+ stream and it doesn't even play. I have tried deleting the aap (aac plus) line from the cuctom-convert.conf but it still didn't play

bpa
2018-09-17, 13:32
Now here is where I get a bit selfish, I only have flac and mp3 in my library and those work fine through Inguz, but now I want to play an aac+ stream and it doesn't even play. I have tried deleting the aap (aac plus) line from the cuctom-convert.conf but it still didn't play

you got rid of aap in custom-convert.con but the aap must still be defined in custom-types.conf somewhere ?

Wirrunna
2018-12-09, 15:50
I could not get AAC radio stations to play until JohnB sent me a PM with the AAC custom-convert.conf entry he uses -
aac flc * 00:04:20:23:09:e3
# IFT
[faad] -q -w -f 1 $FILE$ | [InguzDSP] -id "00:04:20:23:09:e3" -wav -wavo -d 24 | [flac] -cs -0 --totally-silent -

I modified the InguzEQ plugin.pm to replace the aap entry in the template used to generate custom-convert.conf,


# transcode for 24-bit FLAC output (sb2, sb3, transporter)
sub template_FLAC24
{
return <<'EOF1';

aac flc * $CLIENTID$
# IFT
[faad] -q -w -f 1 $FILE$ | [InguzDSP] -id "$CLIENTID$" -wav -wavo -d 24 | [flac] -cs -0 --totally-silent -

aif flc * $CLIENTID$
# FT:{START=-skip %t}
[$CONVAPP$] -id "$CLIENTID$" -input $FILE$ $START$ -be -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

alc flc * $CLIENTID$
# F
[alac] $FILE$ | [$CONVAPP$] -id "$CLIENTID$" -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

amb flc * $CLIENTID$
# IFT:{START=-skip %t}
[$CONVAPP$] -id "$CLIENTID$" -input $FILE$ $START$ -amb -wavo -d 24 | [flac] -cs -5 --totally-silent -

ape flc * $CLIENTID$
# F
[mac] $FILE$ - -d | [$CONVAPP$] -id "$CLIENTID$" -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

flc flc * $CLIENTID$
# FT:{START=--skip=%t}U:{END=--until=%v}
[flac] -dcs $START$ $END$ -- $FILE$ | [$CONVAPP$] -id "$CLIENTID$" -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

mov flc * $CLIENTID$
# FR
[mov123] $FILE$ | [$CONVAPP$] -id "$CLIENTID$" -be -wavo -d 24 | [flac] -cs -5 --totally-silent -

mp3 flc * $CLIENTID$
# IFD:{RESAMPLE=--resample %D}
[lame] --mp3input --decode $RESAMPLE$ --silent $FILE$ - - | [$CONVAPP$] -id "$CLIENTID$" -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

mpc flc * $CLIENTID$
# IR
[mppdec] --silent --prev --gain 3 - - | [$CONVAPP$] -id "$CLIENTID$" -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

ogg flc * $CLIENTID$
# IFD:{RESAMPLE=-r %D}
[sox] -t ogg $FILE$ -t wav $RESAMPLE$ -w - | [$CONVAPP$] -id "$CLIENTID$" -be -wavo -d 24 | [flac] -cs -5 --totally-silent -

uhj flc * $CLIENTID$
# FT:{START=-skip %t}
[$CONVAPP$] -id "$CLIENTID$" -input $FILE$ $START$ -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

wav flc * $CLIENTID$
# FT:{START=-skip %t}
[$CONVAPP$] -id "$CLIENTID$" -input $FILE$ $START$ -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

wma flc * $CLIENTID$
# F:{PATH=%f}R:{PATH=%F}
[wmadec] -w $PATH$ | [$CONVAPP$] -id "$CLIENTID$" -wavo -d 24 | [flac] -cs -5 --totally-silent -

wvp flc * $CLIENTID$
# FT:{START=--skip=%t}U:{END=--until=%v}
[wvunpack] $FILE$ -wq $START$ $END$ -o - | [InguzDSP] -id "$CLIENTID$" -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

EOF1
}





InguzEQ then generates the following custom-convert.conf



# #inguzeq#begin#rev:0.9.33#client:00:04:20:1e:34:b9 # ***** BEGIN AUTOMATICALLY GENERATED SECTION - DO NOT EDIT ****

aac flc * 00:04:20:1e:34:b9
# IFT
[faad] -q -w -f 1 $FILE$ | [InguzDSP] -id "00:04:20:1e:34:b9" -wav -wavo -d 24 | [flac] -cs -0 --totally-silent -

aif flc * 00:04:20:1e:34:b9
# FT:{START=-skip %t}
[InguzDSP] -id "00:04:20:1e:34:b9" -input $FILE$ $START$ -be -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

alc flc * 00:04:20:1e:34:b9
# F
[alac] $FILE$ | [InguzDSP] -id "00:04:20:1e:34:b9" -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

amb flc * 00:04:20:1e:34:b9
# IFT:{START=-skip %t}
[InguzDSP] -id "00:04:20:1e:34:b9" -input $FILE$ $START$ -amb -wavo -d 24 | [flac] -cs -5 --totally-silent -

ape flc * 00:04:20:1e:34:b9
# F
[mac] $FILE$ - -d | [InguzDSP] -id "00:04:20:1e:34:b9" -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

flc flc * 00:04:20:1e:34:b9
# FT:{START=--skip=%t}U:{END=--until=%v}
[flac] -dcs $START$ $END$ -- $FILE$ | [InguzDSP] -id "00:04:20:1e:34:b9" -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

mov flc * 00:04:20:1e:34:b9
# FR
[mov123] $FILE$ | [InguzDSP] -id "00:04:20:1e:34:b9" -be -wavo -d 24 | [flac] -cs -5 --totally-silent -

mp3 flc * 00:04:20:1e:34:b9
# IFD:{RESAMPLE=--resample %D}
[lame] --mp3input --decode $RESAMPLE$ --silent $FILE$ - - | [InguzDSP] -id "00:04:20:1e:34:b9" -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

mpc flc * 00:04:20:1e:34:b9
# IR
[mppdec] --silent --prev --gain 3 - - | [InguzDSP] -id "00:04:20:1e:34:b9" -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

ogg flc * 00:04:20:1e:34:b9
# IFD:{RESAMPLE=-r %D}
[sox] -t ogg $FILE$ -t wav $RESAMPLE$ -w - | [InguzDSP] -id "00:04:20:1e:34:b9" -be -wavo -d 24 | [flac] -cs -5 --totally-silent -

uhj flc * 00:04:20:1e:34:b9
# FT:{START=-skip %t}
[InguzDSP] -id "00:04:20:1e:34:b9" -input $FILE$ $START$ -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

wav flc * 00:04:20:1e:34:b9
# FT:{START=-skip %t}
[InguzDSP] -id "00:04:20:1e:34:b9" -input $FILE$ $START$ -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

wma flc * 00:04:20:1e:34:b9
# F:{PATH=%f}R:{PATH=%F}
[wmadec] -w $PATH$ | [InguzDSP] -id "00:04:20:1e:34:b9" -wavo -d 24 | [flac] -cs -5 --totally-silent -

wvp flc * 00:04:20:1e:34:b9
# FT:{START=--skip=%t}U:{END=--until=%v}
[wvunpack] $FILE$ -wq $START$ $END$ -o - | [InguzDSP] -id "00:04:20:1e:34:b9" -wav -wavo -d 24 | [flac] -cs -5 --totally-silent -

# #inguzeq#end#client:00:04:20:1e:34:b9# ***** END AUTOMATICALLY GENERATED SECTION - DO NOT EDIT *****


and as bpa pointed out, the custom-types.conf needs to reflect the change from aap to aac


# InguzEQ types

################################################## #######################
#ID Suffix Mime Content-Type Server File Type#
################################################## #######################
amb amb ? audio
uhj uhj ? audio
aac - audio/aacp,audio/aac audio
xaml xaml application/xaml+xml -



This change has opened up the radio streams and limited testing has not found a stream that won't play.

I will post the edited InguzEQ plugin.pm and custom-types.conf in the InguzEQ thread in the Audiophile forum.

Thanks to JohnB and bpa, anymore suggestions welcome.