PDA

View Full Version : piCorePlayer v4.0.0-b7, no audio from Squeezelite after ~8 hours with Schiit USB DACs



bisto
2018-09-02, 14:20
Hi, I am running piCorePlayer v4.0.0-b7 (experimental realtime kernel build) on an RPi 3 B+ and a 16 GB SanDisk microSDHC Class 4 card. I am using it with a Schiit Modi 2 Uber DAC through its USB input. The audio output device of Squeezelite is set to "USB Audio" and the output setting is "sysdefault:CARD=Uber".

After about 8 hours, the audio output from Squeezelite drops out except for a occasional popping. This happens whether Squeezelite is playing a track or is just idle. The Squeezelite log level is set to "all=sdebug" but I don't see anything obvious in the log file. As a test, I tried running the same setup with my Schiit Fulla 2 USB DAC, an output setting of "sysdefault:CARD=Schiit", with the same results; the audio drops out after ~8 hours. The audio output is restored after restarting Squeezelite. If I change the audio output device to "Analog audio", the problem doesn't happen.

I first started with a fresh install of the piCorePlayer 3.5.0 audio optimized build and ran into this problem, so I thought I would try pCP v4. I checked "USB Audio tweaks" but I didn't see anything that might apply to a Schiit USB DAC. Is there something I should look for in the Squeezelite log to help debug this problem? Thank!

bisto
2018-09-06, 11:15
Follow-up: Squeezelite muted audio output was not restored after a few successive restarts in piCorePlay v4.0 beta 7 and instead needed a reboot of the RPi. I went back to piCorePlayer v3.5.0 and this time I tried setting the output of Squeezelite to "front:CARD=Uber,DEV=0" instead of "sysdefault:CARD=Uber". Squeezelite output is OK so far after running for 27 hours, so i think that setting is the solution.