PDA

View Full Version : Picoreplayer on Pi : problem to access remote NFS drive



tparvais
2018-09-01, 05:06
Hello

Upgrading my PCP to beta 4 I try a new config with LMS installed locally and USB drive for caching.
I want to mount via NFS music folder from my synology. I use synology standard NFS parameter that work from others devices, but not from PCP.
Everything seems working on the web interface, but when in LMS I configure this extra music source (/mnt/ds916) , it does not display the /mnt/ds916 music subfolders.
I have the feeling there is a RW acecss permission issue on /mnt/ds916 on PCP

When looking with SSH, I can access /mnt/ds916 only if I'm root but not with normal "tc" user account.

any idea ?

Thank you

paul-
2018-09-01, 05:15
Expand the more> in the web interface and read the field help.


More than likely you are not specifying the nfs vers. For synology, typically, you need vers=3 in the mount options.

tparvais
2018-09-01, 09:14
Expand the more> in the web interface and read the field help.


More than likely you are not specifying the nfs vers. For synology, typically, you need vers=3 in the mount options.

I did that, read the explanations and set vers=3, does not work (right issue?)

paul-
2018-09-01, 10:04
I did that, read the explanations and set vers=3, does not work (right issue?)

I use a synology nfs mount, here is the mount configuration.

25550

How is your NFS setup on the synology.

tparvais
2018-09-01, 11:53
I use a synology nfs mount, here is the mount configuration.

25550

How is your NFS setup on the synology.

here is mine: identical to your's

25553

my syno config:

25554

thank you

anadigi
2018-09-01, 12:15
One of my NAS is Thecus, it never works. After I put vers=4, it works!

paul-
2018-09-01, 12:21
That all looks good, What version of DSM? I'm using the latest DSM 6.2-23739

You'll have to check the logs on your synology device and see why it is blocking the connection.

bearcat
2018-09-02, 00:56
here is mine: identical to your's

25553

my syno config:

25554

thank youYou might have to spesify the netmask on yor Syno:
192.168.0.*/24 (or 255.255.255.0)


Sent fra min KIW-L21 via Tapatalk

paul-
2018-09-02, 05:41
Actually that is what I have in my syno, I overlooked that when translating the French.

192.168.0.0/24