PDA

View Full Version : Can't make Benchmark DAC work



joosemcgee
2018-08-27, 17:58
I feel like I must be missing something relatively simple.

I can play everything fine from my setup using a simple USB ODAC from JDS Labs but I cannot get any sound at all from my Benchmark DAC2L.

Based on the USB DAC list, I should be able to get some sound at least.

I haven't tried every single setting so far but a few days of on and off tinkering has gotten me no where. I don't seem to be able to find the settings mojo that will produce anything but errors.

After initial failures, I restarted from scratch with a new image to see if I had set something up previously that was interfering; no luck.

aplay -L lists the Benchmark by name as a USB DAC but no output options succeed.

Debug logging continually shows an error when trying to play that says "unable to set hw params: input/output error"

The Benchmark never indicates a failure but also always seems to be expecting a 96k sample rate.
This never changes.

I have tried both with and without WIFI just in case.
No change.

Hopefully someone can suggest next steps.
Sorry if this is the wrong forum.

Thanks,
Joose

RPi 3 Model B Rev 1.2
Linux version 4.14.26-pcpCore_v7
PiCore version 9.1pCP
piCorePlayer version 3.5.0

joosemcgee
2018-08-28, 18:29
So it was something simple that I had overlooked.

I failed to set the Benchmark to USB2 mode. Once changed, everything connected right up and works so far without issue.

Thanks for the hard work from all the people that make this stuff happen.

-Joose