PDA

View Full Version : iPlayer only works with 2min delay



rbl
2018-08-15, 08:57
To get BBC iPlayer to work well I have to set the "seconds to delay start live stream" to 2 minutes. If I set it to 1 minute the playback breaks up every few minutes. If I set it to 15 seconds not only does playback break up, but it also takes about 30 seconds to start playback at all. I think this is quite an old problem. Just wondering if there is a fix yet?

BBC iPlayer v1.5.4.5
Buffer fullness set to 255.
Live Stream Pref=DashFlac->Dash
Bitrate for Live stream DASH = Use highest bitrate available
Repository=http://downloads.sourceforge.net/project/bpaplugins/V154testrelease-repo.xml
1 year old PC running Windows 10 64bit, i5, 8GB, SSD.

bpa
2018-08-15, 11:44
To get BBC iPlayer to work well I have to set the "seconds to delay start live stream" to 2 minutes. If I set it to 1 minute the playback breaks up every few minutes. If I set it to 15 seconds not only does playback break up, but it also takes about 30 seconds to start playback at all. I think this is quite an old problem. Just wondering if there is a fix yet?

BBC iPlayer v1.5.4.5
Buffer fullness set to 255.
Live Stream Pref=DashFlac->Dash
Bitrate for Live stream DASH = Use highest bitrate available
Repository=http://downloads.sourceforge.net/project/bpaplugins/V154testrelease-repo.xml
1 year old PC running Windows 10 64bit, i5, 8GB, SSD.

Are you in the UK ?

This should only affect live streams and by "old" problem - it is only about 12-18 months.

It is a problem only with Windows systems mainly 10 but I suspect also 8 but oddly not all configurations.
I don't have a Windows 10 system so I can't reproduce it nor debug it.

I'm pretty sure the problem is due to a change in Windows process scheduling made in Win8/10 and it has affected the LMS support app socketwrapper. It will only be examined and possibly fixed by me when I get a Win 10 system - however for the moment my Win7 is adequate.

Try reducing buffer fullness down to 50 - it will speed start up but too small also causes break-ups.

You can always play the MP3 streams.

edit:

You are in UK - jusrt noticed your "London" and are using "Highest".

rbl
2018-08-21, 10:34
Are you in the UK ?

This should only affect live streams and by "old" problem - it is only about 12-18 months.

It is a problem only with Windows systems mainly 10 but I suspect also 8 but oddly not all configurations.
I don't have a Windows 10 system so I can't reproduce it nor debug it.

I'm pretty sure the problem is due to a change in Windows process scheduling made in Win8/10 and it has affected the LMS support app socketwrapper. It will only be examined and possibly fixed by me when I get a Win 10 system - however for the moment my Win7 is adequate.

Try reducing buffer fullness down to 50 - it will speed start up but too small also causes break-ups.

You can always play the MP3 streams.

edit:

You are in UK - jusrt noticed your "London" and are using "Highest".

I tried various combinations of Buffer Fullness and "Seconds to delay start live stream", but it had varying degrees of unreliability until the delay was set to 2 minutes. Oddly when the delay was set to either 15s or 1 minute, there was an actual delay of about 1'45 compared to DAB. With the delay set to 2 minutes, the actual delay was 2'35.

Worth mentioning I have a good fibre connection so I don't think anything is going on there...

On another note, the BBC 3 flac stopped working some time ago. I think there was a setting or something to get that FLAC stream to work? It display the programme information, but doesn't actually play any music..

bpa
2018-08-21, 12:17
I tried various combinations of Buffer Fullness and "Seconds to delay start live stream", but it had varying degrees of unreliability until the delay was set to 2 minutes. Oddly when the delay was set to either 15s or 1 minute, there was an actual delay of about 1'45 compared to DAB. With the delay set to 2 minutes, the actual delay was 2'35.
It's a Windows thing and I can't reproduce on my Win 7 system.


Worth mentioning I have a good fibre connection so I don't think anything is going on there...
It's a Windows thing - not an ISP.


On another note, the BBC 3 flac stopped working some time ago. I think there was a setting or something to get that FLAC stream to work? It display the programme information, but doesn't actually play any music..

The Flac was a trial transmission by BBC which was repeated for last year's Proms and ended at Prom end in Sept. BBC did not commit to any further trials of Flac broadcast (or even spatial audio which they also trialled during Proms).

Man in a van
2018-08-21, 13:34
The Flac was a trial transmission by BBC which was repeated for last year's Proms and ended at Prom end in Sept. BBC did not commit to any further trials of Flac broadcast (or even spatial audio which they also trialled during Proms).

There a few headphone thingy Proms this year, but there has been little promotion.

https://www.bbc.co.uk/programmes/p06drb3s

bpa
2018-08-21, 13:57
There a few headphone thingy Proms this year, but there has been little promotion.

Also UK only.