PDA

View Full Version : Please Help. PCP-Kali-piano 2.1 dual mono channel imbalance



LanceL
2018-08-12, 17:38
I recently received a Allo kali and piano 2.1. Getting up and running has been no problem, however, I cannot run dual mono without a significant channel imbalance between left/right volume noticeably shifting the image.
I have used pcp 3.5 audio optimized and 4.0 audio RT kernel,,,and with a pi 2 and a pi3b+...and different sd cards.
If I run dual stereo each dac is balanced stereo although Dac A stereo outputs are also measurably louder than dac b's (sub) stereo outputs.
If I ssh into alsamixer I can see that the master volume as well as digital/sub volumes show to be same /identical.....I am a bit defeated does anyone have any experience-suggestions
Thx in advance

paul-
2018-08-12, 18:01
I normally run this card everyday.

Are you using the correct Piano driver? You want the Allo Piano Dac plus 2.1/2.2. Are you setting this through the card control screen? When in Dual mono mode, which RCA jacks are you connected too. Should be using the far left and far right jacks.

LanceL
2018-08-12, 18:17
yes, driver is correct piano plus 2.1/2.2 as set in the card control and I am using the correct outputs left and sub right...the audio is there but with a volume imbalance left louder than right (sub)
As stated even when running dual stereo while each individual stereo pair is in balance if I measure the output from dac a stereo outputs it is louder than dab b ( sub) stereo outputs...wondering if a have a problem Kali 2.1 board
Thx

LanceL
2018-08-12, 18:22
Paul..quick thought could you tell me (or screen shot)your settings in advanced Squeezelite and card control to make sure I donít have something else wrong, missing
Thx

paul-
2018-08-12, 19:58
I just ran through some tests, as I forgot how the card worked. When in dual mono mode, if you use alsamixer, be sure not to play with the subwoofer volume control.....as that will override the Master, and mess up the right volume. Be sure to only use Master. And also don't take the Master volume above 0db......which you can in alsamixer.

Here is my setup. I'm not currently using my Kali, Since you are running the Kali, you need to check the glb_mclk option.

25448

LanceL
2018-08-13, 03:02
Thx much, how about of your Squeezelite advanced settings, ( buffer, harfdware, priority, other controls, rtc)

paul-
2018-08-13, 06:37
I just use the default settings.

LanceL
2018-08-13, 12:42
Aok...thx again

LanceL
2018-08-16, 03:54
As one last try I downloaded and wrote both volumino and picoreplayer 4.0RT images on a neighbors desktop pc.....SOB, both worked completely normal in dual mono and has been stable over the last 12 hours
It appears that even though I am getting no download, checksum error or file corruption on my pc that has been used extensively for these purposes in the past ( including recent past) I have something going on with this pc in downloading and writing images onto sdcards.....at a loss as to what is going on to break the images in a way that is not generating any message/notification but will resolve it
But these new images from different pc are working normally, at least if I leave all default settings besides for selecting driver, gd-blck and dual mono settings. For the moment, I am a little gun shy in messing with any other settings in Squeezelite advanced 😊
Thanks much to all who has offered assistance...as always a learning experience

Greg Erskine
2018-08-16, 04:20
hi LanceL,

Very strange! Burning an SD card is so simple its hard to imagine where something could go wrong.

Here is the procedure I have used on a couple of Windows PCs, hundreds, probably a thousand times now without issue. Lucky pCP is so small it takes less than 10 seconds to burn!

https://www.picoreplayer.org/how_to_burn_pcp_onto_a_sd_card.shtml

I have had one faulty SD card, I broke one, and one SD to uSD adapter plays up. These resulted in go/no go results not corrupted images.

Please let us know what the cause is if you find it.

regards
Greg

LanceL
2018-08-16, 04:49
Thanks Greg...I am with you...while my experience pales compared to yours I have certainly done dozens. If not a hundred without the slightest thought or concern. Once had a bad card and maybe once or twice a file corruption ( not pcp) All easy to diagnose or be notified......I am still stumped as to how the images got broken
When I regain a little energy/ motivation I will try to see if I can track down just whatís going on/ happened,
Thx again for talking the time to respond

diamonddust
2018-08-19, 11:52
hi LanceL,
this is my configuration for Piano2.1 + Kali, in my case I have to enable +6db otherwise I get unbalance signal. This are the setting that I use and I got them from soundcheck's blog (https://soundcheck-audio.blogspot.com/).
25489
25490

forgot... in LMS I upsample my flac to 352k8/384k via C-3PO plugin, that way you bypass the internal DAC filters

soundcheck
2019-04-08, 23:42
Hi there.

The other day I ran once more into a strange behavior of the Piano21.
That DAC is a little tricky!
Especially the Dual-Mono related controls get mixed up once on a while.
Getting back to normal is not that easy.
Unfortunately pCP doesn't cover a proper DAC initialization if things get
messed up.


That's why I wrote myself a Piano21 init script:



#!/bin/sh
#
# script to initialize alsamixer settings for
# Allo Piano 2.1 in Dual-Mono config
#
# written by soundcheck for
# pCP >4.1
# Rev 1 - Mar-01-2019
#
################################################## #################

[ $(whoami) != root ] && { echo "*** Please, run as root!"; exit 1; };

pgrep squeezlite >/dev/null && pkill squeezelite

rm -f /var/lib/alsa/asound.state

CARDNR="$(cat /proc/asound/cards | grep "\[PianoDACPlus" | awk -F " " '{print $1}')"

alsactl init $CARDNR >/dev/null 2>&1
amixer -q -c $CARDNR set 'Dual Mode' 'Dual-Mono'
amixer -q -c $CARDNR set 'Subwoofer mode' 'None'
amixer -q -c $CARDNR set 'DSP Program' 'Ringing-less low latency FIR'
amixer -q -c $CARDNR sset 'Digital' unmute
amixer -q -c $CARDNR sset 'Digital' frontright,mute
amixer -q -c $CARDNR set 'Digital' '100%'
amixer -q -c $CARDNR sset 'Subwoofer' unmute
amixer -q -c $CARDNR sset 'Subwoofer' frontleft,mute
amixer -q -c $CARDNR set 'Subwoofer' '100%'
amixer -q -c $CARDNR set 'Master' '100%'
amixer -q -c $CARDNR set 'Analogue Playback Boost' '0%'
amixer -q -c $CARDNR set 'Analogue' '100%'
amixer -q -c $CARDNR set 'Deemphasis' 'off'
amixer -q -c $CARDNR set 'Volume Ramp Down Rate' '1 sample/update'
amixer -q -c $CARDNR set 'Volume Ramp Up Rate' '1 sample/update'
amixer -q -c $CARDNR set 'Volume Ramp Down Step' '1dB/step'
amixer -q -c $CARDNR set 'Volume Ramp Up Step' '1dB/step'

alsactl store $CARDNR
chmod 666 /var/lib/alsa/asound.state

filetool.sh -b >/dev/null

echo "*** Please, reboot the system now!"


exit 0


ssh as tc, "su root", copy/paste above into the shell, and then run "reboot".

Let me know if it works.

Enjoy.