PDA

View Full Version : New music is not in “New Music”



mandryka
2018-07-26, 13:29
Suddenly LMS has become very unreliable at finding new music, the music is in the database if I search for it, but it doesn’t appear under “New Music.” It works sometimes but increasingly unreliably.

Mostly Flac files, Windows 10. I have tried clearing the library and rescanning everything.

Any ideas about whether it can be fixed?

Paul Webster
2018-07-26, 13:33
I think it is based on the last modified date of the audio file.
If you increase the log level of the scanner and then make a new flax file by whatever means you usually use and then run a scan for new files ... hopefully the scanner log will give a clue about what is happening.

DJanGo
2018-07-27, 00:29
I think it is based on the last modified date of the audio file.
Thats exactly how it works.

But:
if someone set the value for show new tracks to eg 1 there is only a single track.
or using "backups" from somewhere and copy the files with the timestamps - it never apears under new unless these files are newer than (set counter) than any other track.
Just edit the tags of the files, do a rescan and voila.

In this case LMS is very reliable if you understood the logic behind it.

Mnyb
2018-07-27, 02:39
Ive set the new album limit to a very high value so a basically sees my whole collection by modified date .

A snag can be if ripped a long while ago and did not emidiatly put the album on the server albums you added meanwhile shows up before or if the album cover mes from and old backup and just forgot them for 6 months and they have old modified dates as suggested.