PDA

View Full Version : piCorePlayer and USB Audio



schiff1108
2018-07-02, 11:27
I would like to activate the USB Audio interface to connect an external DAC.

As I do have only little Linux know-how and no experience with ALSA, I am wondering what are the thyical steps to get an external DAC configured.
I do not find any ressources in the internet what are of help for me.

Would be great if somebody could help or direct me to a useful page in the internet.

Roland0
2018-07-02, 14:24
I would like to activate the USB Audio interface to connect an external DAC.
As I do have only little Linux know-how and no experience with ALSA, I am wondering what are the thyical steps to get an external DAC configured.

(NB: since I'm not familar with piCorePlayer, the following is generic):
You probably don't need to activate anything, if USB audio is enabled in the kernel (which is very likely), it should be detected automatically (both by the USB subsystem, and ALSA)
Plug it in and check (example from a RPi3, edited for clarity):


user@raspi3-64$ dmesg|grep USB
[ 2.351587] usb 1-1.3.4: New USB device found, idVendor=10c4, idProduct=8a27
[ 2.353278] usb 1-1.3.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 2.354949] usb 1-1.3.4: Product: HIRESFI USB DAC ES9023
user@raspi3-64$ aplay -L
default:CARD=ES9023
HIRESFI USB DAC ES9023, USB Audio
Default Audio Device
user@raspi3-64$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ES9023 [HIRESFI USB DAC ES9023], device 0: USB Audio [USB Audio]


You'll have to configure squeezelite to use it, which probably can be done from the web interface. If not, add something like -o hw:CARD=ES9023 to squeezelite's options.

kidstypike
2018-07-02, 14:29
I don't know a thing about USB audio, but there's a whole gang of options on the "Squeezelite Settings" page . . .

25243

paul-
2018-07-02, 18:19
Just select the usb option from the dropdown. Then expand the outputsettings line on the squeezelite options, and pick an output.......there are some other USB tweaks. But we need the know what usb dac that you have.

schiff1108
2018-07-03, 13:55
I want to connect to Mutec MC-3+ Smart Clock USB - an audio re-clocker.

It was much easier then I thought to get sound.
piCorePlayer is well helping to understand the content of the output setting string.
25251
There is sound in all sample rates from 44.1 to 192. Stream is working w/o any interruptions :cool:

Can / Must I do anything to improve sound quality?
eg Max Sample Rate, Unmute ALSA control, ALSA volume control, any Tweak?

paul-
2018-07-03, 15:49
On the tweaks page, there is a section called USB Audio Tweaks.

They may or may not help you.....just experiment.

maoz
2018-08-30, 05:35
Hi all,

I'm using this thread because I've the same problem descripted here..

I've tried with dmesg|grep USB, and this is the result:
[ 1.090870] dwc_otg 20980000.usb: new USB bus registered, assigned bus number 1
[ 1.091249] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[ 1.091260] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[ 1.092038] hub 1-0:1.0: USB hub found
[ 1.097483] usbhid: USB HID core driver
[ 1.552216] usb 1-1: new full-speed USB device number 2 using dwc_otg
[ 1.834283] usb 1-1: New USB device found, idVendor=08bb, idProduct=2704
[ 1.834300] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 1.834308] usb 1-1: Product: USB Audio DAC
[ 1.838938] input: Burr-Brown from TI USB Audio DAC as /devices/platform/soc/20980000.usb/usb1/1-1/1-1:1.2/0003:08BB:2704.0001/input/input0
[ 1.902489] hid-generic 0003:08BB:2704.0001: input,hidraw0: USB HID v1.00 Device [Burr-Brown from TI USB Audio DAC ] on usb-20980000.usb-1/input2

but with aplay -l:
aplay: device_list:268: no soundcards found...
and aplay -L:
null
Discard all samples (playback) or generate zero samples (capture)

The USB DAD is a cheap PCM2704 card, that I've already used with piCore years ago.. but now with a fresh installation I'm not able to manage the card in order to work.. have you any ideas how I've to setup Squeezelite?

Thanks in advance,

Mauro

Greg Erskine
2018-08-30, 16:29
hi Mauro,

What is unusual is it doesn't find the built-in audio either?

I just tested my Generic USB DAC on pCP4.0.0-b7 and everything looks as expected. I am a little lost because all you have to do is plug it in as you have done.

Power problem?

regards
Greg