PDA

View Full Version : manuelly install version 7.9.2?



squeezebox_Fan
2018-05-31, 09:58
Hello to all,

I updated from version 7.8. to 7.9 on UBUNTU 10.04. That worked fine.

But if I try to update to version 7.9.1 or 7.9.2 it tells me all dependencies are met, but than nothinh realy happens.
If I try to install it via commandline


sudo dpkg -i /media/hd/home/reel/Downloads/logitechmediaserver_7.9.2~1527493162_i386.deb

I get this message:


reel@ReelBox:~$ sudo dpkg -i /media/hd/home/reel/Downloads/logitechmediaserver_7.9.2~1527493162_i386.deb
(Lese Datenbank ... 152509 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereiten zum Ersetzen von logitechmediaserver 7.9.0~1475243668 (durch .../logitechmediaserver_7.9.2~1527493162_i386.deb) ...
Stopping Logitech Media Server.
Entpacke Ersatz für logitechmediaserver ...
dpkg-deb: Datei »/media/hd/home/reel/Downloads/logitechmediaserver_7.9.2~1527493162_i386.deb« enthält nicht verstandene Datenelemente data.tar.xz , gebe auf
dpkg: Fehler beim Bearbeiten von /media/hd/home/reel/Downloads/logitechmediaserver_7.9.2~1527493162_i386.deb (--install):
Unterprozess dpkg-deb --fsys-tarfile gab den Fehlerwert 2 zurück
Making sure that Logitech Media Server is not running first: start-stop-daemon: warning: failed to kill 16564: No such process
No process in pidfile '/var/run/logitechmediaserver.pid' found running; none killed.
Starting Logitech Media Server.
Fehler traten auf beim Bearbeiten von:
/media/hd/home/reel/Downloads/logitechmediaserver_7.9.2~1527493162_i386.deb


Now, I was abel to unpack the deb file manuelly in a diffrent directory. is it posibel just to overwrite my existing installation 7.9 with the newer version?

Or is there another trick to do it?

Thanks for all help

mherger
2018-05-31, 13:27
> I updated from version 7.8. to 7.9 on UBUNTU 10.04. That worked fine.
....
> dpkg-deb: Datei »/media/hd/home/reel/Downloads/logitechmediaserver_7.9.2~1527493162_i386.deb« enthält nicht verstandene Datenelemente data.tar.xz , gebe auf
> dpkg: Fehler beim Bearbeiten von /media/hd/home/reel/Downloads/logitechmediaserver_7.9.2~1527493162_i386.deb (--install):
> Unterprozess dpkg-deb --fsys-tarfile gab den Fehlerwert 2 zurück

Most likely dpkg in your ancient Ubuntu 10.04 doesn't support xz
compression yet. I think that's a rather recent addition (like: less
than five years old...).

You could certainly install the tarball manually. But are you sure you
want to stick with that old a system? It's asking for trouble. I bet
you'd fail to use https, too, as its libraries and certificates must be
way outdated.

--

Michael

squeezebox_Fan
2018-06-01, 00:12
Hi Michael,

thanks for your replie. The old Ubuntu is the base for my TV disk recorder (spezial hardware) and the company REEL is dead. So I don´t get a newer Ubuntu.

But in general you are right. I will think about something new as well.

greetings and a happy weekend