View Full Version : Squeezebox classic has stopped working

2018-04-27, 20:33
My Squeezebox Classic is not quite working. It has not been used for a year or so. It is connected to LMS on a PC that is also in semi-retirement. If I can get it working, I would like to connect it to some speakers in our garage.

The failure description is that the player begins playing about 10 seconds of every track, but then it quits. This failure occurs with local flac files, and also with Pandora. I am not sure, but I may have updated LMS back when the failure started, but never really tested the update.

Below are some particulars of the server and player.

Logitech Media Server Status
Logitech Media Server Version: 7.8.1 - 1475785403 @ Fri Oct 21 03:05:25 CUT 2016

Player Information
Player Model: Squeezebox Classic
Firmware: 137
Wireless Signal Strength: 58%

I would be very grateful if anyone has advice regarding how I might fix this failure, or whether my Squeezebox Classic has an uncorrectable failure.


2018-04-27, 21:15
That could be a WiFi problem it's getting iffy with anything but 100% signal strength 58% as you have may suffice for low rate MP3 can be that LMS transcodes pandora then again you are at flac rates , and server is also a bit old 7.9.1 is out now but thatís probably unrelated to the problems.

Test to do .

Run the player wired with Ethernet . Also the pc with the server is it also wired ?

If itís working fine on Ethernet you may beging the tedious process faultracing and improving WiFi or just accept that and go with Ethernet.

2018-04-28, 16:56
Today I moved my Squeezebox Classic closer to my router. The WIFI signal strength moved up to 99%. It still failed to sustain playing either MP3 or FLAC files for more than about 6 seconds. Then it just quits. Also, I tried connecting it to the LMS that runs my Squeezebox Touches. That server version is 7.9.1. The Classic stills fails.

I may still try using an Ethernet cable as Mnyb suggested, but I am not very hopeful about that. If anyone has another idea, I would love to hear it. Perhaps I could try reloading the firmware, but I am not sure where to find it. Short of success either from Ethernet, or new firmware, I may have to abandon this old Classic. :(


2018-04-28, 18:59
You may have to remove the wifi card in the SB in order to use wired Ethernet. I was told a bad WiFi card (in my SB3) can interfere, with an Ethernet connection too. Good luck !

2018-04-28, 19:55
Ok you got a Touch .

You can try the SB3with the Touchs powersupply .

If you want to use Ethernet you have to do the network setup again , not just connecting a cable .
If you are close to the router it is easy to try with a short cable .
No other weird issues itís not rebooting itself ?

If the WiFi card is failing it can get all sorts of random issues . It can be removed and there is a tread on the forum about replacing the WiFi card the tricky part is to find a similar one .

Some chose to run it with Ethernet instead or use an external ap .

2018-04-29, 06:16

Thanks very much for the suggestions regarding my Squeezebox Classic.

Using the power cord from a Touch did not help. I will try using an Ethernet cable rather than wifi as Mnyb suggested. If that does not help, I will try removing the wifi card altogether as chamonix suggested. First I will wait until after my wife returns from her trip tonight, so she can see what the front panel of the unit is displaying.

Because I am blind, I access the player using the web interface, and even more often via the iPeng app on an iPhone. Neither of those interfaces is reporting a problem. They only show that the player has stopped when I refresh the displays on those devices. I will have Vivian look at the front panel of the classic itself to see what it is showing.

It may be a few days before I write back with any results, because I do not like to dump my home audio projects on Vivian right as she gets home from a trip. :)

In case the Squeezebox Classic does not ever work again, I am not without plenty of other Squeeze resources. I have Squeezebox Touches connected to our 5.1 living room system, and one connected to our 2.1 high-end bedroom music system, and a third is in its box in one of our closets. Besides all of those, I also have the iPeng player on my iPhone, and on Vivian's iPhone. I was hoping to set up the unused Squeezebox Classic with a speaker in Vivianís art studio. If that does not work out, she can just use the iPeng Squeeze player on her iPhone in the studio. She has an iPhone x, and the sound quality from its built-in speaker is really amazing. The only thing that I know that player cannot do is play Napster, but neither can the Squeezebox classic.

Thanks again for the help! I will update about the Classic in a few days.


2018-04-29, 22:22
Hi Tom

can you upload your server.log file to my dropbox:


You would find the download link in Settings/Information in the web
interface. There's an "Everything" link to get a full copy.



2018-05-01, 11:40
Hi Michael,

Thanks for your help. I believe that I uploaded the server.log file you suggested to your Dropbox account. I found the link to capture this data in the "logging" tab of server settings. There are several options regarding how much data to capture, so please let me know if I did not get it right.

My wife discovered something important that I had not known about when she looked at the display on my Squeezebox Classic. The unit is resetting when I select to play an MP3 or FLAC file. It starts to play a file for about 5 seconds, and then it chokes for a few seconds, and then it appears to be going through the power up sequence.

Thanks for any help,

2018-05-02, 03:46
It starts to play a file for about 5 seconds, and then it chokes for a few seconds, and then it appears to be going through the power up sequence.
That's not unseen for classic SBs. I would try these steps in order:
- use the remote control (http://wiki.slimdevices.com/index.php/Special_IR_Keys_on_Reboot_for_Factory_Reset_and_La st_FW) to perform a factory reset,
- use the remote control to perform a xilinx reset on the SB3,
- use another, known to work, PSU
- Try with ethernet,
- simplify the network (server, player, DHCP server alone on a network segment)
- wiggle the round PSU connector in the SB3, see that it is tight and there is no rust/dust in the power inlet,
- open the SB3 and re-seat the mezzanine board that hosts the wifi card.

Good luck.

2018-05-04, 07:08
Thanks to all who tried to help fix the failure with my Squeezebox classic. I think I will have to consider the unit dead.

Factory reset failed to fix the issue. Reprogramming the Xilinx did not fix it either.

Last night I removed the wireless card and connected it to my router via Ethernet. The squeezebox played music only for a few seconds (as it did before), only instead of rebooting, it just disconnected from the server.

I am going to give up trying to put this Squeezebox in my wife's art studio. Instead, she can use iPeng on her iPhone. If she needs more volume, I can just get her a Bluetooth speaker.

Thanks again for the help. The Squeezebox community is really great!