PDA

View Full Version : Creat Playlist with Web Interface



Mark Steinemann
2005-01-05, 09:10
Hi

I try to find a possibility to add playlists via the web interface but can't find it anymore. I find delete and edit playlists but create nowhere.
Even i the doc I find only edit and delet playlists.

I use v5.4.0 for Windows.

Any help is greatly appreciated
--

Anthony James
2005-01-05, 09:38
On Wed, 05 Jan 2005 17:10:20 +0100, Mark Steinemann
<steinemann (AT) swissmail (DOT) com> wrote:
> Hi
>
> I try to find a possibility to add playlists via the web interface but can't find it anymore. I find delete and edit playlists but create nowhere.
> Even i the doc I find only edit and delet playlists.
>

It might vary by Skin. Certainly in Fishbone the options above the
current 'now playing' playlist are Download, Save and Clear. Hitting
'save' lets you give the playlist a name.

kdf
2005-01-05, 10:37
Quoting Mark Steinemann <steinemann (AT) swissmail (DOT) com>:

> Hi
>
> I try to find a possibility to add playlists via the web interface but can't
> find it anymore. I find delete and edit playlists but create nowhere.
> Even i the doc I find only edit and delet playlists.

Creating a playlist is done by brosing the song first and either playing or
adding them to the 'current playlist'.

In the player UI, you can use the arror keys to browse music, or search music.
From there, move right to select continually more specific. Press PLAY if you
want to make that selection your playlist and start playing. Press ADD if you
want to add that selection to the end of then current playlist. Press-and-hold
ADD if you want to insert the selection into the playlist immediately folowing
the current song.

Through the Web UI, browsing and searching are handled through links from the
home pags on the left side of the window. The player status and current
playlist are displayed on the right. [+] icons indicate ADD, |> icons for
PLAY, >| is teh icon for inserting an item after the next song, and in some
skins [-] is used to remove that selection.

On the right side, you have up and down arrow icons that allow you to move a
song up or down in teh playlist. Links at the top (save, download, clear)
allow you to save the playlist with a name you choose, download the playlist as
an m3u file, and clear the current playlist. Saving playlists does require
that you have a valid playlist folder set in the server setings.

cheers,
kdf

John Rakestraw
2005-01-05, 19:32
kdf wrote:

> Creating a playlist is done by brosing the song first and either playing or
> adding them to the 'current playlist'.

<snip>

Thanks for this detailed explanation. But it's not working for me.

I've designated a folder to use for playlists.

I have a playlist in the right column that I want to save. So I click on
"save." Whatever's in the left column disappears, and I see "save this
playlist as" followed by a textbox with the default text "untitled" in
it. Below this is a horizontal rule, and below that is this:

This entire playlist > +
Empty

The playlist I want to save is still on the right side of the screen. I
change "untitled" to "Mozart" and I get the response "Note: The name you
chose is already taken. Please choose another name for your playlist, or
check 'confirm overwrite' to replace your existing playlist." There's no
playlist called "mozart," and it seems not to matter what I put in this
box. I check off the "confirm" block and try again, but I get the same
response. And the playlist isn't saved.

I still see

This entire playlist > +
Empty

below the "save this playlist as" line.

I've constructed some playlists in a text editor, and slimserver can see
them. But it can't delete them. When I try to edit one of these
playlists, I'm allowed to make changes, but I can't seem to save them.

I looked through the debugging options, checked off "d_playlist," and
tried to save another playlist. But the log file is empty.

Perhaps this is a permissions issue? I've tried unsuccessfully to give
others write permission to the playlists folder -- chmod -v 777 tells me
that permissions have been changed, but ls -l tells me that permissions
are still 755.

I'm running Fedora Core 3 and slimserver 5.4.0-1.

I suspect I'm missing something simple.........

Thanks.

kdf
2005-01-05, 21:23
Quoting John Rakestraw <lists (AT) johnrakestraw (DOT) com>:

> kdf wrote:
>
> > Creating a playlist is done by brosing the song first and either playing or
> > adding them to the 'current playlist'.
>
> <snip>
>
> Thanks for this detailed explanation. But it's not working for me.
>
> I've designated a folder to use for playlists.
>
> I have a playlist in the right column that I want to save. So I click on
> "save." Whatever's in the left column disappears, and I see "save this
> playlist as" followed by a textbox with the default text "untitled" in
> it. Below this is a horizontal rule, and below that is this:
>
> This entire playlist > +
> Empty
>
> The playlist I want to save is still on the right side of the screen. I
> change "untitled" to "Mozart" and I get the response "Note: The name you
> chose is already taken. Please choose another name for your playlist, or
> check 'confirm overwrite' to replace your existing playlist." There's no
> playlist called "mozart," and it seems not to matter what I put in this
> box. I check off the "confirm" block and try again, but I get the same
> response. And the playlist isn't saved.

The response you see 'the name is already taken' is a bit more specific than the
real meaning. If the server tries to write the playlist and fails, then this
error will show. Double check that the playlist folder you have chosen is
actually writeable for the user running slimserver, or for the system user if
you run as a service.

The empty playlist is a mystery. I'd have to dig through the code to confirm,
but perhaps its a result of the same problem.

-kdf

John Rakestraw
2005-01-07, 16:39
Thanks again, kdf. However, I still can't create a playlists directory.
I acknowledge that this could be operator error (I'm still learning my
way through Linux), and it's not clear to me whether it's a slimserver
set-up issue or a Linux issue. Here's what I've tried:

First, I have the flac files on an external hard drive connected to my
Linux (FC3) box. FC3 auto-mounted it (including setting up a line in
/etc/fstab) when I plugged it in. The drive came formatted as FAT32, and
I left it that way so that I could connect the drive to a Windows box
with all the files intact if I decided to do that. The drive itself
mounts as owned by me, with 755 privileges. And I can't figure out how
to change the privileges. chmod says that it's changing it to 777, but
it doesn't stick. It doesn't let me change the owner either. I couldn't
figure out how to get beyond that, so I decided just to put the playlist
folder on an internal hard drive.

I opened a terminal, created the folder, and set permissions to 777.
However, when I try in the slimserver web interface to set this as the
playlists folder, I get the response "New value for Playlists Folder
rejected: Oops - "/path/to/playlists" doesn't seem to be a valid
directory. Try again." (I even copied and pasted the output of pwd to
make sure I wasn't mistyping the path.)

So slimserver accepts the first directory, but can't write to it because
the permissions are 755 and it's owned by someone else. And it doesn't
accept the second directory, even though the directory exists.

Slimserver is running as a service.

So what am I doing wrong? I'd be happy if I could get this working
either way (or some other way).

--John

kdf wrote:
> Quoting John Rakestraw <lists (AT) johnrakestraw (DOT) com>:
>
>
>>kdf wrote:
>>
>>
>>>Creating a playlist is done by brosing the song first and either playing or
>>>adding them to the 'current playlist'.
>>


>><snip>
>>
>>Thanks for this detailed explanation. But it's not working for me.
>>
>>I've designated a folder to use for playlists.
>>
>>I have a playlist in the right column that I want to save. So I click on
>>"save." Whatever's in the left column disappears, and I see "save this
>>playlist as" followed by a textbox with the default text "untitled" in
>>it. Below this is a horizontal rule, and below that is this:
>>
>>This entire playlist > +
>>Empty
>>
>>The playlist I want to save is still on the right side of the screen. I
>>change "untitled" to "Mozart" and I get the response "Note: The name you
>>chose is already taken. Please choose another name for your playlist, or
>>check 'confirm overwrite' to replace your existing playlist." There's no
>>playlist called "mozart," and it seems not to matter what I put in this
>>box. I check off the "confirm" block and try again, but I get the same
>>response. And the playlist isn't saved.
>
>
> The response you see 'the name is already taken' is a bit more specific than the
> real meaning. If the server tries to write the playlist and fails, then this
> error will show. Double check that the playlist folder you have chosen is
> actually writeable for the user running slimserver, or for the system user if
> you run as a service.
>
> The empty playlist is a mystery. I'd have to dig through the code to confirm,
> but perhaps its a result of the same problem.
>
> -kdf
>

kdf
2005-01-07, 16:46
Quoting John Rakestraw <lists (AT) johnrakestraw (DOT) com>:


> And I can't figure out how
> to change the privileges. chmod says that it's changing it to 777, but
> it doesn't stick. It doesn't let me change the owner either. I couldn't
every time the server mounts that external hard drive, the permissions are reset
to the values it is told to have from teh /etc/fstab file. Recent versions of
linux also tend to have security checks that will re-establish permission
settings every so often on critical items. Check the mount settings for that
drive in whatever control panel type thing you have in FC3 (I have Mandrake)

>
> I opened a terminal, created the folder, and set permissions to 777.
> However, when I try in the slimserver web interface to set this as the
> playlists folder, I get the response "New value for Playlists Folder
> rejected: Oops - "/path/to/playlists" doesn't seem to be a valid
> directory. Try again." (I even copied and pasted the output of pwd to
> make sure I wasn't mistyping the path.)

try doing same for /path, and /path/to instead of just playlists.

-kdf

> So slimserver accepts the first directory, but can't write to it because
> the permissions are 755 and it's owned by someone else. And it doesn't
> accept the second directory, even though the directory exists.
>
> Slimserver is running as a service.
>
> So what am I doing wrong? I'd be happy if I could get this working
> either way (or some other way).
>
> --John
>
> kdf wrote:
> > Quoting John Rakestraw <lists (AT) johnrakestraw (DOT) com>:
> >
> >
> >>kdf wrote:
> >>
> >>
> >>>Creating a playlist is done by brosing the song first and either playing
> or
> >>>adding them to the 'current playlist'.
> >>
>
>
> >><snip>
> >>
> >>Thanks for this detailed explanation. But it's not working for me.
> >>
> >>I've designated a folder to use for playlists.
> >>
> >>I have a playlist in the right column that I want to save. So I click on
> >>"save." Whatever's in the left column disappears, and I see "save this
> >>playlist as" followed by a textbox with the default text "untitled" in
> >>it. Below this is a horizontal rule, and below that is this:
> >>
> >>This entire playlist > +
> >>Empty
> >>
> >>The playlist I want to save is still on the right side of the screen. I
> >>change "untitled" to "Mozart" and I get the response "Note: The name you
> >>chose is already taken. Please choose another name for your playlist, or
> >>check 'confirm overwrite' to replace your existing playlist." There's no
> >>playlist called "mozart," and it seems not to matter what I put in this
> >>box. I check off the "confirm" block and try again, but I get the same
> >>response. And the playlist isn't saved.
> >
> >
> > The response you see 'the name is already taken' is a bit more specific
> than the
> > real meaning. If the server tries to write the playlist and fails, then
> this
> > error will show. Double check that the playlist folder you have chosen is
> > actually writeable for the user running slimserver, or for the system user
> if
> > you run as a service.
> >
> > The empty playlist is a mystery. I'd have to dig through the code to
> confirm,
> > but perhaps its a result of the same problem.
> >
> > -kdf
> >

John Rakestraw
2005-01-07, 19:02
kdf wrote:

> every time the server mounts that external hard drive, the permissions are reset
> to the values it is told to have from teh /etc/fstab file. Recent versions of
> linux also tend to have security checks that will re-establish permission
> settings every so often on critical items. Check the mount settings for that
> drive in whatever control panel type thing you have in FC3 (I have Mandrake)

In this instance, the change doesn't happen at all. If I do ls -l
immediately after running chmod 777 on the directory (or the drive), it
still says 755. And if I try to change it using the GUI file browser
(right-click on directory, click on permissions tab, click in check
boxes for "write" privileges for group and other), the check marks
appear for a split-second and then disappear. However, there's better
news on the other option........

<snip>
>
> try doing same for /path, and /path/to instead of just playlists.

I didn't want to do this because playlists is in my home directory and I
don't want my home directory to have permissions set at 777, so I put a
directory at the / level, changed permissions, and now it works.

Thanks for your patience.

--John

kdf
2005-01-07, 19:22
Quoting John Rakestraw <lists (AT) johnrakestraw (DOT) com>:


> I didn't want to do this because playlists is in my home directory and I
> don't want my home directory to have permissions set at 777, so I put a
> directory at the / level, changed permissions, and now it works.
>
> Thanks for your patience.

cool :)
you skipped a step on me. if it worked, I was going to suggest putting the
permissions back and moving the playlists ;)

glad it finally got there.

-kdf