PDA

View Full Version : Receiver has Died



SilverSix
2018-03-01, 09:33
Have had issues for a few days with receiver, the colour led kept changing colour, and when trying to play a track it produces strange noises for a few seconds then silence. I kept repowering the controller which only brought on the same cycle as above. So i pulled the power lead to the receiver for a few minutes hoping it would reset but now its dead, no colour leds at all. I have tested the power supply which is fine, outputting a steady 9.1v and when the power lead is in the receiver you can see red lights behind the optical port so I reckon power is not the problem. Have read other posts and tried to reset the receiver by holding down the front button before powering on but nothing produces and led response. Have you got any suggestions or had experience of similar issues?

w3wilkes
2018-03-01, 09:38
What happens if you pull the wifi card and apply power while holding the front button?

SilverSix
2018-03-02, 05:43
What happens if you pull the wifi card and apply power while holding the front button?
I have not taken the receiver apart yet, I guess you have to lever open the top to access the wifi card?

bpa
2018-03-02, 05:57
I have not taken the receiver apart yet, I guess you have to lever open the top to access the wifi card?

No - peel back rubber foot at corners carefully and then unscrew

See https://www.youtube.com/watch?v=03D_RtV7u90

SilverSix
2018-03-08, 00:28
No - peel back rubber foot at corners carefully and then unscrew

See https://www.youtube.com/watch?v=03D_RtV7u90

Thanks, I will give it a try at the weekend