PDA

View Full Version : [MAC] Slimserver not picking up iTunes library



Joe Hickey
2005-01-04, 13:14
Thanks for your replies...

kdf wrote:
> if you've installed slimserver for a particular user, it coudl be
> unaware of the
> 'shares' and thus not work across the network.
> -kdf

kdf, nope, it's installed for all users

Steven Moore wrote:

> Do you have your server starting up when the system boots?
yes, it's set to start up for all users
> I have a similar set up to yours and tried the when the system boots
> option and found 0 songs etc.
> Try setting it to when I log in.
> I am probably wrong here but If your index is in your home folder it
> may not be accessible until you log in. Someone can corect me on this.
> Also, if you've been using itunes the day before it will rescan
> anyway(automatically) as the playlists have changed once you log in and
> the server starts up.

Sally wrote:
> Searching the archives, I find a note, "SlimServer can't follow
> aliases, but can follow unix symbolic links." Incidently, iTunes can
> follow symlinks too. Here's a URL to the FAQ
>
> http://www.slimdevices.com/su_faq.html#troubleshooting-macalias
>
> Here's what I do:
> - iTunes Music Library.xml and iTunes Music Library are in the normal
> spot ~/Music/iTunes Music
> - a symlink ~/Music/iTunes Music/iTunes Music ->
> /Volumes/diskname/foldername
>
> This way, iTunes finds everything just where it expects.
>
> -- Sally

Sally, thanks, have tried a symbolic link from my user/music/iTunes ->
/volumes/iTunes... hopefully that will fix it, if not I'll repost!