PDA

View Full Version : Song transition does not work if seek to 10 sec before



Nirmal kushwah
2018-02-26, 04:24
If song seeks to 10 sec. before the end of the song, the song transition does not work.

Reproduce:

Play track and seek ~10 sec before the ending
Wait for transition

LMS Version: Logitech Media Server Version: 7.9.1 - 1489743085
LMS Client: Squeezelite v1.8

slartibartfast
2018-02-26, 04:37
If song seeks to 10 sec. before the end of the song, the song transition does not work.

Reproduce:

Play track and seek ~10 sec before the ending
Wait for transition

LMS Version: Logitech Media Server Version: 7.9.1 - 1489743085
LMS Client: Squeezelite v1.8

It works for me but I don't have a Squeezelite client.

Sent from my SM-G900F using Tapatalk

philippe_44
2018-02-26, 19:02
I assume you are trying crossfade. I have to look again at the code, but you probably don't have enough samples in the playback buffer. Increase outputbufsize. There was also a bug corrected a few month ago, but that was related to gain application

Nirmal kushwah
2018-03-08, 23:52
I assume you are trying crossfade. I have to look again at the code, but you probably don't have enough samples in the playback buffer. Increase outputbufsize. There was also a bug corrected a few month ago, but that was related to gain application

Hi Philippe
I set output buf size from 2000 to 5000, but the problem did not resolved i also changed the stream size to 2000 to 5000 but with that i get the same results, for more detiald info i am shearing debug logs with default output buf size,

[12:17:29.001181] process:494 strm
[12:17:29.001258] process_strm:256 strm command t
[12:17:29.001298] sendSTAT:171 STAT: STMt
[12:17:30.002440] sendSTAT:171 STAT: STMt
[12:17:31.003624] sendSTAT:171 STAT: STMt
[12:17:31.215980] process:494 strm
[12:17:31.216064] process_strm:256 strm command q
[12:17:31.216096] decode_flush:190 decode flush
[12:17:31.216126] output_flush:423 flush output buffer
[12:17:31.216475] sendSTAT:171 STAT: STMf
[12:17:31.231377] process:494 audg
[12:17:31.231459] process_audg:413 audg gainL: 65536 gainR: 65536 adjust: 1
[12:17:31.231492] set_volume:246 setting internal gain left: 65536 right: 65536
[12:17:31.234175] process:494 strm
[12:17:31.234249] process_strm:256 strm command s
[12:17:31.234280] process_strm:325 strm s autostart: 1 transition period: 10 transition type: 0 codec: m
[12:17:31.234312] sendSTAT:171 STAT: STMf
[12:17:31.234368] codec_open:218 codec open: 'm'
[12:17:31.234436] stream_sock:384 connecting to 10.13.17.219:9000
[12:17:31.234577] stream_sock:413 header: GET /stream.mp3?player=00:00:00:00:84:d1 HTTP/1.0


[12:17:31.234614] sendSTAT:171 STAT: STMc
[12:17:31.234671] process_strm:357 set fade mode: 0
[12:17:31.234730] process:494 audg
[12:17:31.234765] process_audg:413 audg gainL: 65536 gainR: 65536 adjust: 1
[12:17:31.234800] set_volume:246 setting internal gain left: 65536 right: 65536
[12:17:31.281841] stream_thread:176 headers: len: 116
HTTP/1.1 200 OK
Server: Logitech Media Server (7.9.1 - 1489743085)
Connection: close
Content-Type: audio/mpeg


[12:17:31.281971] sendRESP:202 RESP
[12:17:31.685392] stream_thread:249 end of stream
[12:17:31.685584] sendDSCO:190 DSCO: 0
[12:17:31.686173] process:494 strm
[12:17:31.686240] process_strm:256 strm command u
[12:17:31.686281] process_strm:312 unpause at: 0 now: 2720344
[12:17:31.686312] sendSTAT:171 STAT: STMr
[12:17:32.687400] sendSTAT:171 STAT: STMt
[12:17:33.000673] process:494 strm
[12:17:33.000751] process_strm:256 strm command t
[12:17:33.000784] sendSTAT:171 STAT: STMt
^C[12:17:33.434605] slimproto_stop:919 slimproto stop
[12:17:33.534833] decode_close:175 close decode
[12:17:33.624887] stream_close:322 close stream
[12:17:33.687451] output_close_alsa:890 close output


Thank you

slartibartfast
2018-03-09, 01:29
Hi Philippe
I set output buf size from 2000 to 5000, but the problem did not resolved i also changed the stream size to 2000 to 5000 but with that i get the same results, for more detiald info i am shearing debug logs with default output buf size,

[12:17:29.001181] process:494 strm
[12:17:29.001258] process_strm:256 strm command t
[12:17:29.001298] sendSTAT:171 STAT: STMt
[12:17:30.002440] sendSTAT:171 STAT: STMt
[12:17:31.003624] sendSTAT:171 STAT: STMt
[12:17:31.215980] process:494 strm
[12:17:31.216064] process_strm:256 strm command q
[12:17:31.216096] decode_flush:190 decode flush
[12:17:31.216126] output_flush:423 flush output buffer
[12:17:31.216475] sendSTAT:171 STAT: STMf
[12:17:31.231377] process:494 audg
[12:17:31.231459] process_audg:413 audg gainL: 65536 gainR: 65536 adjust: 1
[12:17:31.231492] set_volume:246 setting internal gain left: 65536 right: 65536
[12:17:31.234175] process:494 strm
[12:17:31.234249] process_strm:256 strm command s
[12:17:31.234280] process_strm:325 strm s autostart: 1 transition period: 10 transition type: 0 codec: m
[12:17:31.234312] sendSTAT:171 STAT: STMf
[12:17:31.234368] codec_open:218 codec open: 'm'
[12:17:31.234436] stream_sock:384 connecting to 10.13.17.219:9000
[12:17:31.234577] stream_sock:413 header: GET /stream.mp3?player=00:00:00:00:84:d1 HTTP/1.0


[12:17:31.234614] sendSTAT:171 STAT: STMc
[12:17:31.234671] process_strm:357 set fade mode: 0
[12:17:31.234730] process:494 audg
[12:17:31.234765] process_audg:413 audg gainL: 65536 gainR: 65536 adjust: 1
[12:17:31.234800] set_volume:246 setting internal gain left: 65536 right: 65536
[12:17:31.281841] stream_thread:176 headers: len: 116
HTTP/1.1 200 OK
Server: Logitech Media Server (7.9.1 - 1489743085)
Connection: close
Content-Type: audio/mpeg


[12:17:31.281971] sendRESP:202 RESP
[12:17:31.685392] stream_thread:249 end of stream
[12:17:31.685584] sendDSCO:190 DSCO: 0
[12:17:31.686173] process:494 strm
[12:17:31.686240] process_strm:256 strm command u
[12:17:31.686281] process_strm:312 unpause at: 0 now: 2720344
[12:17:31.686312] sendSTAT:171 STAT: STMr
[12:17:32.687400] sendSTAT:171 STAT: STMt
[12:17:33.000673] process:494 strm
[12:17:33.000751] process_strm:256 strm command t
[12:17:33.000784] sendSTAT:171 STAT: STMt
^C[12:17:33.434605] slimproto_stop:919 slimproto stop
[12:17:33.534833] decode_close:175 close decode
[12:17:33.624887] stream_close:322 close stream
[12:17:33.687451] output_close_alsa:890 close output


Thank youHave you tried turning off crossfade?

Sent from my SM-G900F using Tapatalk

Nirmal kushwah
2018-03-13, 07:08
Have you tried turning off crossfade?

Sent from my SM-G900F using Tapatalk

Yes, I tested the same with crossfade turned off, but the problem didn't seem to resolve.

philippe_44
2018-03-13, 09:21
Yes, I tested the same with crossfade turned off, but the problem didn't seem to resolve.

Do you mean FADE_IN and FADE_OUT do not work either?

Nirmal kushwah
2018-03-14, 05:53
Do you mean FADE_IN and FADE_OUT do not work either?

Yes, I have tested all possible combinations with LMS.

Nirmal kushwah
2018-05-24, 22:27
Yes, I have tested all possible combinations with LMS.
Can anyone respond on this issue I still facing this issue