PDA

View Full Version : BBC IPlayer runs late and slow



johnbeverley
2018-02-14, 02:50
BBC radio runs both late and slow. I shall explain.

When I switch on in the morning the time checks are in sync with real-life, but progressively during the day the time slips - as much as an hour or so at the end of the day.

And speech is ever so slightly slow - with the effect that presenters' voices sound deeper than they should.

I'm running LMS (Max2Play) on a Raspberry Pi. I have a mix of original Squeezebox devices and RPi using piCorePlayer. I've tried limiting the number of devices running simultaneously, but it make no difference. I have updated kernels and versions of everything else I can think of.

I have terrific broadband and a fast home wifi network.

Any thoughts?

bpa
2018-02-14, 03:20
Any thoughts?


What version of plugin ?
What settings ?
Have you changed the default Settings/Advanced/Filetypes AAC setting ? Can it still play native ?
Does this happen on a single Touch/Radio player, not synced ?
What other plugins installed ?

BBC audio is at 48kHz- it "feels" like audio is being played back at 44.1kHz - this can happen if LMS settings are changed so that a player should play in PCM and not in Flac or native codecs.

johnbeverley
2018-02-14, 03:41
What version of plugin ?
What settings ?
Have you changed the default Settings/Advanced/Filetypes AAC setting ? Can it still play native ?
Does this happen on a single Touch/Radio player, not synced ?
What other plugins installed ?

BBC audio is at 48kHz- it "feels" like audio is being played back at 44.1kHz - this can happen if LMS settings are changed so that a player should play in PCM and not in Flac or native codecs.

Thanks for speedy response.

I'm running BBC iPlayer (1.5.4.5)

Configured thus:

Live stream Dash>HLS>MP3>FlashAAC
On Demand Dash>HLS

Settings/Advanced/Filetypes:

AAC:
AAC Disabled
FLAC Disabled
MP3 Disabled
PCM faad

Other plugins:

BBC iPlayer Extra
Date & Time
Network Test
Powersave
Radio
Visualiser Screensaver

The phenomenon occurs across the estate, with different devices running independently. Coincidentally I cannot get synchronisation to stick, and have to re-enable it manually each time I want to use it.

Regards
John

bpa
2018-02-14, 04:01
AAC:
AAC Disabled
FLAC Disabled
MP3 Disabled
PCM faad


This is your problem. You have only enabled AAC to PCM transcoding. PCM has no header providing audio format details and so player assume a 44.1kHz 2ch 16bits stream.

Use defautl AAC setting (i.e. enable AAC natove, AAC Flac ) and all will be OK.

johnbeverley
2018-02-14, 04:11
This is your problem. You have only enabled AAC to PCM transcoding. PCM has no header providing audio format details and so player assume a 44.1kHz 2ch 16bits stream.

Use defautl AAC setting (i.e. enable AAC natove, AAC Flac ) and all will be OK.

I shall try that. Thank you.

johnbeverley
2018-02-21, 03:27
I shall try that. Thank you.


Worked. Thanks again.

bpa
2018-02-21, 03:33
Worked. Thanks again.

Why were the settings disabled in the first place ?
Changing default settign should only be done with care as side effects are inevitable.

johnbeverley
2018-02-21, 03:41
Why were the settings disabled in the first place ?
Changing default settign should only be done with care as side effects are inevitable.


I followed the guidance from "Soundcheck":


https://soundcheck-audio.blogspot.pt/2017/08/logitechmediaserver-settings-guide.html

bpa
2018-02-21, 04:35
I followed the guidance from "Soundcheck":

Trust your own ears and use default whenever possible.

Some of those suggestions have been the subject of very long "religious" arguments in the audiophile forum.

johnbeverley
2018-02-21, 05:15
Trust your own ears and use default whenever possible.

Some of those suggestions have been the subject of very long "religious" arguments in the audiophile forum.


Having messed around with those settings (and obviously heard things worse as a result) I unsuccessfully did search around for a listing of the default settings for "filetypes".

Can you point me at such a listing?

Regards
John

bpa
2018-02-21, 05:25
Having messed around with those settings (and obviously heard things worse as a result) I unsuccessfully did search around for a listing of the default settings for "filetypes".

Can you point me at such a listing?

There is no listing. The default setting is everything enabled - anything explicitly "disabled" is not default.

It is possible you may have installed plugin or other files that have changed the LMS supplied transcoding. The main default transcoding settings include: Native, lame, flac, faad and sox - alone or in combination. The less common formats have their own transcoder which I can't remember such as wvunpack and mppdec.

Plugins to support non standard LMS formats or extend existing ones may have their own transcoding such as HLS aka Apple m3u8 using ffpmeg or avconv.

johnbeverley
2018-02-21, 05:30
There is no listing. The default setting is everything enabled - anything explicitly "disabled" is not default.

It is possible you may have installed plugin or other files that have changed the LMS supplied transcoding. The main default transcoding settings include: Native, lame, flac, faad and sox - alone or in combination. The less common formats have their own transcoder which I can't remember such as wvunpack and mppdec.

Plugins to support non standard LMS formats or extend existing ones may have their own transcoding such as HLS aka Apple m3u8 using ffpmeg or avconv.

Ah. I see.

Everything working perfectly now.

Next on my to-do list - how to receive hi-res BBC R3 overseas?

bpa
2018-02-21, 07:13
Next on my to-do list - how to receive hi-res BBC R3 overseas?

The BBC restricts non UK to AAC 48kHz 96kbps for DASH & HLS or 128kbps 44.1kHz for shoutcast http/MP3

If playing DASH make sure the BBCiPlayer plugin both setting are set to "Use highest bitrate for DASH stream"

To get UK stream which provide higher quality - you need to use a VPN and appear to be based in the UK. I can't help on that issue.

The BBC test streamed R3 in Flac for last years Proms and that was available to non UK - no news on whether this experiment will be repeated.

NMarshall
2018-02-21, 13:23
I had the same problem for around 36 hours, then the delay disappeared. So
it must have been a BBC issue, rather than the iPlayer plugin.
Neil

-----Original Message-----
From: plugins-bounces (AT) lists (DOT) slimdevices.com
[mailto:plugins-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of
plugins-request (AT) lists (DOT) slimdevices.com
Sent: 21 February 2018 15:46
To: plugins (AT) lists (DOT) slimdevices.com
Subject: plugins Digest, Vol 155, Issue 70

Send plugins mailing list submissions to
plugins (AT) lists (DOT) slimdevices.com

To subscribe or unsubscribe via the World Wide Web, visit
http://lists.slimdevices.com/mailman/listinfo/plugins
or, via email, send a message with subject or body 'help' to
plugins-request (AT) lists (DOT) slimdevices.com

You can reach the person managing the list at
plugins-owner (AT) lists (DOT) slimdevices.com

When replying, please edit your Subject line so it is more specific than
"Re: Contents of plugins digest..."

bpa
2018-02-21, 13:45
I had the same problem for around 36 hours, then the delay disappeared. So
it must have been a BBC issue, rather than the iPlayer plugin.

Delay is not the same as slow. OP problem was that plaback ran at about 90% normal speed so 1 hours program would start at right time but take about 66 minutes to play.

A delay is when a program starts late but runs at the correct speed and so completed in the correct duration.

mikebainbridge
2018-02-24, 21:27
I have the same problem but it limited to only one device - My very first Slim Devices Squeezebox running firmware 40. iPlayer is v1.5.3 and LMS is 7.9.1 . All AAC file settings are 'on' and my 2 Picore players, 2 ipads and 2 iphones all play at the correct speed. It's most frustrating as after many years of not working with Spotify the Spotty plugin as brought it new life ! Any thoughts apart from 'get a more modern device?'

bpa
2018-02-25, 02:54
I have the same problem but it limited to only one device - My very first Slim Devices Squeezebox running firmware 40. iPlayer is v1.5.3 and LMS is 7.9.1 . All AAC file settings are 'on' and my 2 Picore players, 2 ipads and 2 iphones all play at the correct speed. It's most frustrating as after many years of not working with Spotify the Spotty plugin as brought it new life ! Any thoughts apart from 'get a more modern device?'

The player with firmware 40 is a SB1 which cannot play AAC natively and cannot play Flac so AAC is transcoded into 48KHz PCM which has no header so SB1 plays it has 44.1Khz. I'm not clear what you are talking about wrt Spotty as this a BBCiPlayer thread.

That is the problem and has been true for all files & stream 48kHz AAC on SB1 - not just BBCiPlayer and known for a long time ( http://forums.slimdevices.com/showthread.php?6405-48KHz-playback )

AFAICT no solution has been posted over the years but IIRC for most of that time 48kHz was only used in WMA and DVD and transcoding WMA solution for SB1 did resampling.

The only solution I can think of is to add sox in the "AAC-> PCM" trasncoding for SB1 to ensure a 44.1kHz but this will put a load on the LMS processor.
No details on your LMS server - so the following is for a Linux based server.
If lines below are edited to use correct MAC address (i.e. replace with AMAC of your SB1) and then saved in a custom-convert.conf file (make sure tabs are saved as tabs and not spaces) in the same directory as the LMS convert.conf file then after LMS restart LMS will always convert AAC streams to the device with MAC address into 44.1Khz streams.

MAC address of player can be found in LMS WebUI Setting/Information tab or on label of player.




aac pcm * aa:bb:cc:dd:ee:ff
# IF
[faad] -q -w -f 1 -b 1 $FILE$ | [sox] -q -t wav $FILE$ -t raw -r 44100 -c 2 -2 -s -


In theory for all SB1 type devices - the following would work.



aac pcm Squeezebox *
# IF
[faad] -q -w -f 1 -b 1 $FILE$ | [sox] -q -t wav $FILE$ -t raw -r 44100 -c 2 -2 -s -

mikebainbridge
2018-02-27, 15:55
Many thanks for this @BPA
Server is max2play 2.45 running on Odroid U2

1. Copied /etc/squeezeboxserver/convert.conf to convert.conf.safe
2. Added lines you suggested as below into convert.conf after existing entry


aac pcm * *
# IF
[faad] -q -w -f 2 -b 1 $FILE$

aac pcm * 00:04:20:05:90:fc
# IF
[faad] -q -w -f 1 -b 1 $FILE$ | [sox] -q -t wav $FILE$ -t raw -r 44100 -c 2 -2 -s -


3. Re-started Squeezeboxserver
4. Tried the BBC R4 'on demand' - "Connecting" displayed briefly then back to resting current time display
5. Same for live (overseas)

I'll now try the second suggestion

mikebainbridge
2018-02-27, 16:08
1. Removed previous line with MAC address
2. Added this line - note I removed the double space before the first pipe and before the second $FILES in your example


aac pcm Squeezebox *
# IF
[faad] -q -w -f 1 -b 1 $FILE$ | [sox] -q -t wav $FILE$ -t raw -r 44100 -c 2 -2 -s -


3. Squeezebox runs but slow so it's not "seeing" the name

Thanks for helping though - I'm going to have to do some reading as this is not in my field of expertise - Happy to try any suggestions and if I come up with something I'll be sure to post !

bpa
2018-02-27, 16:28
1. Removed previous line with MAC address
2. Added this line - note I removed the double space before the first pipe and before the second $FILES in your example


aac pcm Squeezebox *
# IF
[faad] -q -w -f 1 -b 1 $FILE$ | [sox] -q -t wav $FILE$ -t raw -r 44100 -c 2 -2 -s -


3. Squeezebox runs but slow so it's not "seeing" the name

Thanks for helping though - I'm going to have to do some reading as this is not in my field of expertise - Happy to try any suggestions and if I come up with something I'll be sure to post !

I said use a custom-convert.conf file. Do NOT change the convert.conf file

It "feels" like a syntax error in your convert.conf file.

Attach your convert.conf file to a post so I can check - spaces and tabs and end-of-line are critical (i.e a file edited on Windows editor often have incorrect end of line sequence)

Use the MAC address version - that is guaranteed to work. Don't use the "Squeezebox" one as I couldn't test that - e.g. there may be a case or spelling issue.

Check what is being executed by enabling logging player.source to debug and then try to play a BBC station. Note time of start of test, wait 30 secs and copy from log every line between start of test until end into a text file, zip and attach to a post. Do NOT edit any out - sometimes missing lines

mikebainbridge
2018-02-27, 18:12
Many thanks for the super-fast response. Apologies for my misinterpretation of your instructions.

1. Original convert.conf put back
2. New custom-convert.conf created and saved as per instructions :set list seems to show just NL which I think is what is required. (file attached)
3. Server re-started
4. Debug player.source enabled from Server settings / Advanced / Logging [apply]
5. Attempted to run BBC R4 on demand at 12:01- same as before: 'Connecting' on screen a brief flick of 'now playing' and then back to resting state.
6. 30 second wait and log file zipped and downloaded from web interface (attached) - The action seems to kick off at 18-02-28 12:01:31.4587
7. Debug turned off and applied

bpa
2018-02-28, 02:47
From the log below the conf file is OK and it has executed the correct command line. The problem is the command line does not seem to run on your system.

Check whether the faad and sox actually run on your system, try the following at a shell prompt - you should get banner lines.

/usr/share/squeezeboxserver/Bin/armhf-linux/faad
/usr/share/squeezeboxserver/Bin/armhf-linux/sox

You are playing HLS format streams. As I have no reference system for HLS streams, I don't support using HLS so there may be a problem with timing when streaming and then running faad/sox on ARM processor. Please set preferences to use DASH first.




[18-02-28 12:01:30.1082] Slim::Player::Song::open (363) hls://open.live.bbc.co.uk/mediaselector/5/redir/version/2.0/vpid/b09smgt9/mediaset/audio-syndication/proto/http|
[18-02-28 12:01:30.1095] Slim::Player::Song::open (387) seek=false time=0 canSeek=1
[18-02-28 12:01:30.1104] Slim::Player::TranscodingHelper::checkBin (242) Checking formats for: aac-aif-squeezebox-00:04:20:05:90:fc
[18-02-28 12:01:30.1108] Slim::Player::TranscodingHelper::checkBin (242) Checking formats for: aac-aif-*-00:04:20:05:90:fc
[18-02-28 12:01:30.1113] Slim::Player::TranscodingHelper::checkBin (242) Checking formats for: aac-aif-squeezebox-*
[18-02-28 12:01:30.1117] Slim::Player::TranscodingHelper::checkBin (242) Checking formats for: aac-aif-*-*
[18-02-28 12:01:30.1121] Slim::Player::TranscodingHelper::checkBin (242) Checking formats for: aac-pcm-squeezebox-00:04:20:05:90:fc
[18-02-28 12:01:30.1125] Slim::Player::TranscodingHelper::checkBin (242) Checking formats for: aac-pcm-*-00:04:20:05:90:fc
[18-02-28 12:01:30.1130] Slim::Player::TranscodingHelper::enabledFormat (209) Checking to see if aac-pcm-*-00:04:20:05:90:fc is enabled
[18-02-28 12:01:30.1134] Slim::Player::TranscodingHelper::checkBin (250) enabled
[18-02-28 12:01:30.1138] Slim::Player::TranscodingHelper::checkBin (252) Found command: [faad] -q -w -f 1 -b 1 $FILE$ | [sox] -q -t wav $FILE$ -t raw -r 44100 -c 2 -2 -s -
[18-02-28 12:01:30.1145] Slim::Player::TranscodingHelper::getConvertCommand 2 (446) Matched: aac->pcm via: [faad] -q -w -f 1 -b 1 $FILE$ | [sox] -q -t wav $FILE$ -t raw -r 44100 -c 2 -2 -s -
[18-02-28 12:01:30.1151] Slim::Player::Song::open (408) Transcoder: streamMode=I, streamformat=pcm
[18-02-28 12:01:30.1157] Slim::Player::Song::open (461) Opening stream (no direct streaming) using Plugins::BBCiPlayer::HLS [hls://open.live.bbc.co.uk/mediaselector/5/redir/version/2.0/vpid/b09smgt9/mediaset/audio-syndication/proto/http|]
[18-02-28 12:01:30.1183] Slim::Player::Song::open (482) URL is a song (audio): hls://open.live.bbc.co.uk/mediaselector/5/redir/version/2.0/vpid/b09smgt9/mediaset/audio-syndication/proto/http|, type=aac
[18-02-28 12:01:30.1193] Slim::Player::TranscodingHelper::tokenizeConvertCo mmand2 (617) Using command for conversion: "/usr/share/squeezeboxserver/Bin/armhf-linux/faad" -q -w -f 1 -b 1 - | "/usr/share/squeezeboxserver/Bin/armhf-linux/sox" -q -t wav - -t raw -r 44100 -c 2 -2 -s -
[18-02-28 12:01:30.1199] Slim::Player::Song::open (558) Tokenized command: "/usr/share/squeezeboxserver/Bin/armhf-linux/faad" -q -w -f 1 -b 1 - | "/usr/share/squeezeboxserver/Bin/armhf-linux/sox" -q -t wav - -t raw -r 44100 -c 2 -2 -s -

mikebainbridge
2018-02-28, 14:58
Thanks again for your time

Both faad and sox are there - banners below

faad -

*********** Ahead Software MPEG-4 AAC Decoder V2.7 ******************

Patched for Squeezebox Server:
* ALAC decoder integrated
* Seeking support with -j and -e switches
* STDIN support
* utgg win32 STDOUT patch
* Source at https://github.com/ralph-irving/faad2

Build: Apr 6 2017
Copyright 2002-2004: Ahead Software AG
http://www.audiocoding.com
Floating point version
etc.

sox

sox: SoX v14.3.1

Changed settings to Dash First
Re-enabled custom-cconvert.conf

Restarted server

Still same problem - Connecting / Now playing / Back to rest

Settings are:
24630

bpa
2018-02-28, 15:47
Can you get a log with player.source=DEBUG playing a "on-Demand" program from the BBCiPlayer menu (i.e. not from Extra and not live)

I want to do a direct compare against log which works on my system.

bpa
2018-02-28, 16:12
I tested the suggested custom-convert.conf before and I thought it worked.

I just I retested using the lines I had posted and I get same failure as you get. So I need to backtrack.

bpa
2018-02-28, 17:31
I must have pasted an old version - the following is custom-convert.conf that work. I had lost the "--ignore-length" option on sox.




aac pcm * aa:bb:cc:dd:ee:ff
# IF
[faad] -q -w -f 1 -b 1 $FILE$ | [sox] -q --ignore-length -t wav $FILE$ -t raw -r 44100 -c 2 -2 -s -

mikebainbridge
2018-02-28, 19:10
I've captured the log anyway just in case the change to the settings sheds any light- The log certainly looks different - I started the World at One R4 on demand at 13.05 local time.

24631

mikebainbridge
2018-02-28, 19:23
We 'crossed in the post'

Success !!

The latest string did the trick (once I'd realised that I hadn't changed the Mac address to mine) - A massive 'thank you'

This works perfectly with no server load problems my cursory look so far can tell. I'll look for something more formal to really check but I'm up and running at the right speed for sure.

"Top" shows about 23% processor usage by sox while running but no dropouts or pauses for the whole 30 minute programme.

bpa
2018-03-01, 02:34
This works perfectly with no server load problems my cursory look so far can tell. I'll look for something more formal to really check but I'm up and running at the right speed for sure.

"Top" shows about 23% processor usage by sox while running but no dropouts or pauses for the whole 30 minute programme.

Good that it works. Your system has a 4 core processor with "hard float" Linux so it should be able to keep up with necessary resampling without too much load.

As "sox" will be included when playing all AAC stream to the SB1 - you should check that AAC files/streams with 44.1kHz are not affected - sox should see source is 44.1kHz and do no processing.

mikebainbridge
2018-03-01, 03:59
All seems well with aac encoded 44.1 files - I'll have to look for streaming later as all the stations I listen to had the 48 'problem' !

Thanks again !