PDA

View Full Version : Help with Spotty on Rpi 3 getting IO::Socket::SSL error



benrjunk
2018-01-04, 09:17
It seems this has been covered many times. However I am unable to find a solution in the forums.

I am running a Raspberry Pi 3, current Raspbian release. LMS is installed. Unfortunately in the server log file, I am getting an error that says IO::Socket::SSL isn't installed. I can't figure out how to install it. Can anyone point me in the right direction?

Thank you so much,

Ben

Man in a van
2018-01-04, 10:08
sudo apt-get update


sudo apt-get install libio-socket-ssl-perl libnet-ssleay-perl

benrjunk
2018-01-04, 10:08
sudo apt-get install libio-socket-ssl-perl

This should be listed in the installation instructions for RPi

Ben

benrjunk
2018-01-04, 10:12
sudo apt-get update


sudo apt-get install libio-socket-ssl-perl libnet-ssleay-perl

Thank you ... you beat me to it by a few seconds! Don't need the ssleay library ... the ssl library automatically installs it.

Thanks again!!

yeme
2018-02-22, 06:47
Thank you ... you beat me to it by a few seconds! Don't need the ssleay library ... the ssl library automatically installs it.

Thanks again!!

Can anyone help me install this SSL on piCore? I am using piCorePlayer with LMS on a single Pi 3 and have the Spotty plugin telling me to install this module

Thanks

paul-
2018-02-22, 10:39
Can anyone help me install this SSL on piCore? I am using piCorePlayer with LMS on a single Pi 3 and have the Spotty plugin telling me to install this module

Thanks

It is already include with the pCP implementation. No need to download anything. Unless you are using a copy that is more than a year old, in which case you need to re-install LMS.

yeme
2018-02-22, 11:45
It is already include with the pCP implementation. No need to download anything. Unless you are using a copy that is more than a year old, in which case you need to re-install LMS.

Thanks Paul, it is in excess of one year...how simple.