PDA

View Full Version : squeezelite no sound on dmix device



riker1@gmx.net
2017-12-23, 02:18
Hi
strangewise i do not have any sound
using the dmix alsa device.

playing is fine with hwplug

error in log:
[09:36:56.700262] mixer_init_alsa:803 attach error: No such file or directory
[09:45:58.474343] output_init_alsa:912 Initialization of mixer failed, reverting to software volume
[09:58:56.192739] output_init_alsa:912 Initialization of mixer failed, reverting to software volume

#SL_SOUNDCARD="plughw:CARD=ALSA,DEV=0"
SL_SOUNDCARD="dmix:CARD=ALSA,DEV=0"

speaker-test -c 2 -t wav -d dmix:CARD=ALSA,DEV=0 is working as well

Running Jessie on RPI

aplay -L shows:
null
Discard all samples (playback) or generate zero samples (capture)
default:CARD=ALSA
bcm2835 ALSA, bcm2835 ALSA
Default Audio Device
sysdefault:CARD=ALSA
bcm2835 ALSA, bcm2835 ALSA
Default Audio Device
dmix:CARD=ALSA,DEV=0
bcm2835 ALSA, bcm2835 ALSA
Direct sample mixing device
dmix:CARD=ALSA,DEV=1
bcm2835 ALSA, bcm2835 IEC958/HDMI
Direct sample mixing device
dsnoop:CARD=ALSA,DEV=0
bcm2835 ALSA, bcm2835 ALSA
Direct sample snooping device
dsnoop:CARD=ALSA,DEV=1
bcm2835 ALSA, bcm2835 IEC958/HDMI
Direct sample snooping device
hw:CARD=ALSA,DEV=0
bcm2835 ALSA, bcm2835 ALSA
Direct hardware device without any conversions
hw:CARD=ALSA,DEV=1
bcm2835 ALSA, bcm2835 IEC958/HDMI
Direct hardware device without any conversions
plughw:CARD=ALSA,DEV=0
bcm2835 ALSA, bcm2835 ALSA
Hardware device with all software conversions
plughw:CARD=ALSA,DEV=1
bcm2835 ALSA, bcm2835 IEC958/HDMI
Hardware device with all software conversions

also remove the asound.conf
before that I used the minimal config :

pcm.!default {
type hw card 0
}
ctl.!default {
type hw card 0
}

any hints ?

Thanks T