PDA

View Full Version : Anyone running MUSICIP on QNAP 4.2/4.3 64bit?



yeomanspc
2017-12-18, 11:57
I tried asking on QNAP forum and got no takers (aside from suggestion I run all on a RPi), so trying here. I'm still running LMS on QTS 4.3, and all is well except MUSICIP. Still using modified SSOTS and fix for the BASH issue. We have 2 xQNAPs, and I prefer to leave it all there as I don't want the hassle of starting from zero to fix one issue. I have a hunch that Musicip might not be enabled for 64bit, and since QTS will >only< run 64bit, I suspect this is why it will not work. I get an error indicating the executable cannot be found, but it is there..

Running MusicMagicServer /opt/ssods4/var/home/MusicIP/mmserver: line 25: /opt/ssods4/bin/start-stop-daemon: No such file or directory

The start-stop daemon is trying to start MMS. I checked authorisations etc., but it seems ok.

As a workaround, since I anyway run a windows VM on the QNAP, I run the windows version of Musicip, and then use Sugarcube Dynamic Path Conversion on QNAP LMS to look at MUSICIP on the 'remote' (VM) windows server so I can use Sugarcube to make the mix. It works for sugarcube (not MUSICIP) but it's all a bit clunky.

So the simple question...
is anyone successfully running MusicIP on QNAP QTS 4.3 or 4.3?
If yes, I can go spend a bit of time to understand what is wrong with my version, but if not then I suspect I'll have to stay where I am, and offer up the above solution as a solution if others are in the same hole.
The non-SSOTS QPKG might have the same issue, and I am not sure of the new container builds (if QTS containers will only run pure 64bit)
Many thanks.