PDA

View Full Version : HOWTO: piCorePlayer disable power light and activity light on RPi2 and RPi3



Zounder1
2017-12-17, 10:13
FWIW. This is a quick post on how to turn off the power LED on my Raspberry Pi running piCorePlayer. Note: This does not work on the original Raspberry Pi A/B.

Go the PiCorePlayer web interface.
Click on "Main page"
Put the interface in Advanced mode (scoll to bottom of page and click on the "Normal" tab to make more options available on the web interface. "Advanced" and "Beta" will also reveal the required settings.)
Wait for the web interface to reload.
Click on "Tweaks"
Scroll to the bottom and enter in "User command #1" text box:
echo 0 | sudo tee /sys/class/leds/led1/brightness
Enter in "User command #2" text box:
echo 0 | sudo tee /sys/class/leds/led0/brightness
Click on "Save"
Reboot your piCorePlayer.
The power LED and activity LED will power off once your RPi has boot up PiCorePlayer

As a note, the "User command #2" is not really required as the piCorePlayer does not normally access the SD card once booted. I put it here for completeness in case some edge PiCorePlayer setup accesses the SD card regularly. (Perhaps if you are running LMS with piCorePlayer?)

I don't have a Raspberry Pi Zero to confirm, but you apparently need to run the following TWO commands to turn off the Power/Activity LED instead.
echo 1 | sudo tee /sys/class/leds/led0/brightness
echo none | sudo tee /sys/class/leds/led0/trigger

Paul Webster
2017-12-19, 13:47
Good idea.
I have a Pi with touchscreen in the original case which does leak red light out to the side.
It did not matter before but I recently moved it to be connected to the turntable in another room ... and there the light was annoying.
This resolved that.