PDA

View Full Version : squeezelite constant crashing



riker1@gmx.net
2017-12-15, 03:23
Hi

I have squeezelite running on raspberry with osmc.

the service is constant crashing.

any hints to find the problem?

memory, etc.

I do not see errors

Thanks T

DJanGo
2017-12-15, 13:42
Hi

I have squeezelite running on raspberry with osmc.

the service is constant crashing.

any hints to find the problem?

memory, etc.

I do not see errors

Thanks T

Hi,

if you want us to help you > you may have to put some more infos.
Which exact Version of squeezelite
what else is running
who is running squeezelite
all codec installed
and many more.

riker1@gmx.net
2017-12-16, 06:42
Hi

of course will provide all the info required. Thanks for helping.

it is a OSMC Leia with jessie based RPI 3 1 GB . But had same problem with Kodi 17.
Having gpu_mem_1024=256 set.


running: Squeezelite v1.8.6-957, Copyright 2012-2015 Adrian Smith, 2015-2017 Ralph Irving. See -t for license terms


- there is also ser2net running
- Spotitfy Connect Service / but disabled it for a while already
- Have USB audio device attached
card 0: Device [USB Audio Device], device 0: USB Audio [USB Audio]
Subdevices: 0/1
Subdevice #0: subdevice #0


-> should I disable the bcm2835 ?

Squeezelite is running as a service

sudo service squeezelite status -l
● squeezelite.service - LSB: Lightweight headless Squeezebox emulator
Loaded: loaded (/etc/init.d/squeezelite)
Active: active (running) since Fr 2017-12-15 19:09:44 CET; 19h ago
Process: 6719 ExecStop=/etc/init.d/squeezelite stop (code=exited, status=0/SUCCESS)
Process: 6729 ExecStart=/etc/init.d/squeezelite start (code=exited, status=0/SUCCESS)
CGroup: /system.slice/squeezelite.service
└─6736 /usr/bin/squeezelite -n WohnV1osmc95RPI3 -o default -V Speaker -a 0 -m 00 00 00 00 00 95 -d all debug -f /var/log/squeezelite.log

Logfile entries which I do not understand are:
[16:13:34.006277] slimproto_run:572 error reading from socket: closed
[17:28:07.539247] slimproto_run:572 error reading from socket: closed
[17:30:56.640772] slimproto_run:572 error reading from socket: closed
[10:45:17.100001] discover_server:821 error sending disovery
[15:17:04.924515] discover_server:821 error sending disovery
[03:57:49.988861] slimproto_run:572 error reading from socket: closed
[10:18:14.731232] mad_decode:231 mad_frame_decode error: bad main_data_begin pointer

No result for : dmesg -T | grep squeeze


memory :
$ free -m
total used free shared buffers cached
Mem: 747 666 81 14 75 385
-/+ buffers/cache: 205 542
Swap: 0 0 0



what else does help you?
Thanks T

DJanGo
2017-12-16, 08:33
└─6736 /usr/bin/squeezelite -n WohnV1osmc95RPI3 -o default -V Speaker -a 0 -m 00 00 00 00 00 95 -d all debug -f /var/log/squeezelite.log

please stop squeezelite and run
/usr/bin/squeezelite -l

try from bottom to top each of the listed device as parameter for -o

lame is installed as well?

why your using a mac from a xerox machine on your rpi???

riker1@gmx.net
2017-12-16, 09:36
Hi

what do you mean by :
mac from a xerox machine on your rpi



lame was not installed, should I better?

here the result from:
~$ /usr/bin/squeezelite -l
Output devices:
null - Discard all samples (playback) or generate zero samples (capture)
default:CARD=Device - USB Audio Device, USB Audio - Default Audio Device
sysdefault:CARD=Device - USB Audio Device, USB Audio - Default Audio Device
front:CARD=Device,DEV=0 - USB Audio Device, USB Audio - Front speakers
surround21:CARD=Device,DEV=0 - USB Audio Device, USB Audio - 2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=Device,DEV=0 - USB Audio Device, USB Audio - 4.0 Surround output to Front and Rear speakers
surround41:CARD=Device,DEV=0 - USB Audio Device, USB Audio - 4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=Device,DEV=0 - USB Audio Device, USB Audio - 5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=Device,DEV=0 - USB Audio Device, USB Audio - 5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=Device,DEV=0 - USB Audio Device, USB Audio - 7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=Device,DEV=0 - USB Audio Device, USB Audio - IEC958 (S/PDIF) Digital Audio Output
dmix:CARD=Device,DEV=0 - USB Audio Device, USB Audio - Direct sample mixing device
dsnoop:CARD=Device,DEV=0 - USB Audio Device, USB Audio - Direct sample snooping device
hw:CARD=Device,DEV=0 - USB Audio Device, USB Audio - Direct hardware device without any conversions
plughw:CARD=Device,DEV=0 - USB Audio Device, USB Audio - Hardware device with all software conversions
default:CARD=ALSA - bcm2835 ALSA, bcm2835 ALSA - Default Audio Device
sysdefault:CARD=ALSA - bcm2835 ALSA, bcm2835 ALSA - Default Audio Device
dmix:CARD=ALSA,DEV=0 - bcm2835 ALSA, bcm2835 ALSA - Direct sample mixing device
dmix:CARD=ALSA,DEV=1 - bcm2835 ALSA, bcm2835 IEC958/HDMI - Direct sample mixing device
dsnoop:CARD=ALSA,DEV=0 - bcm2835 ALSA, bcm2835 ALSA - Direct sample snooping device
dsnoop:CARD=ALSA,DEV=1 - bcm2835 ALSA, bcm2835 IEC958/HDMI - Direct sample snooping device
hw:CARD=ALSA,DEV=0 - bcm2835 ALSA, bcm2835 ALSA - Direct hardware device without any conversions
hw:CARD=ALSA,DEV=1 - bcm2835 ALSA, bcm2835 IEC958/HDMI - Direct hardware device without any conversions
plughw:CARD=ALSA,DEV=0 - bcm2835 ALSA, bcm2835 ALSA - Hardware device with all software conversions
plughw:CARD=ALSA,DEV=1 - bcm2835 ALSA, bcm2835 IEC958/HDMI - Hardware device with all software conversions

riker1@gmx.net
2017-12-16, 10:28
please stop squeezelite and run
/usr/bin/squeezelite -l

try from bottom to top each of the listed device as parameter for -o



Hi
how to I get rid of the -o default?

SB_EXTRA_ARGS="-V Speaker -o dmix:CARD=Device,DEV=0 -a :::0 -m 00:00:00:00:00:95 -d all=debug -f /var/log/squeezelite.log"

this ends up to

└─12618 /usr/bin/squeezelite -n WohnV1osmc95RPI3 -o default -V Speaker -o dmix:CARD=Device,DEV=0 -a 0 -m 00 00 00 00 00 95 -d all debug -f /var/log/squeezelite.log

riker1@gmx.net
2017-12-16, 10:29
please stop squeezelite and run
/usr/bin/squeezelite -l

try from bottom to top each of the listed device as parameter for -o

lame is installed as well?

why your using a mac from a xerox machine on your rpi???


what do you mean by this?

how to remove? which files are this?

ah understood: this option. without it lms server is not accessing right players was my exerience. I thought those addresses could be virtual fake more or less, wrong understanding?


-m <mac addr> Set mac address, format: ab:cd:ef:12:34:56

DJanGo
2017-12-16, 12:06
what do you mean by this?

how to remove? which files are this?

ah understood: this option. without it lms server is not accessing right players was my exerience. I thought those addresses could be virtual fake more or less, wrong understanding?


-m <mac addr> Set mac address, format: ab:cd:ef:12:34:56
sorry
i didnt understand most of your questions...
What do you mean?

riker1@gmx.net
2017-12-23, 02:08
why your using a mac from a xerox machine on your rpi???

sorry
i didnt understand most of your questions...
What do you mean?

Hi
I was confused about your mac related feedback. espacially abouzt the xerox machine. ...
First I could not identify what you mean, than I understood it is related to the -m option.

Are there any known issues using the -m option? or any special mac adresses to be avoided?

I have more squeezelite installations and could ony separate them using special mac adresse in -m options.

Do you think crashed are caused by -m option?

thanks t

bpa
2017-12-23, 02:24
The -m option is only needed when you have mulitple squeezelite running on same system.
By default squeezelite should use the mac address of the network hardware.

Are you running mulitple squeezelite instances ?

DJanGo
2017-12-23, 02:25
Are there any known issues using the -m option? or any special mac adresses to be avoided?

I have more squeezelite installations and could ony separate them using special mac adresse in -m options.

Do you think crashed are caused by -m option?

thanks t

Hi,

its more the -o i would try all the USB Devices like front:CARD=Device,DEV=0

and -m i do have plenty of rpis with squeezelite and most of them are build exactly like another.
Using -m would always end in a mess when copying a sd card to another system.

And -m is also called faking a mac address - i dont like fakes no boobjobs no turbo badges on a granny car.
Its the same with noobs in batchscript using @echo off in the first line and didnt knew what their doing and asking for help cause of the crashes..