View Full Version : SB1 changed its MAC address

2017-11-27, 02:43
My Squeezebox Classic died a few weeks ago so I dusted off an old Squeezebox 1 I had in a box. This is the model that has wireless but only WEP. I'm using ethernet so it should hold me over until I can get a decent deal on ebay.

I've been using the SB1 for a couple of weeks with no trouble, until today. I can't use Pandora, get an error message. Long story short, the MAC address on my SB1 has suddenly changed to something starting with 76:a2:ef... I searched and found a very old thread about this bug. And I saw instructions about how to set the MAC address using the remote. But this does not work for me.

The instructions basically said keep the left arrow pressed until you get to config, navigate to MAC, and then press the right arrow key to edit. Well, left arrow does nothing, I see one "bounce" on the SB1 but it doesn't go to a different menu.

I can navigate to Settings using the down arrow key, right to enter, down to Information, right to enter, down to PlayerName Information, right to enter, and then I can see current IP address, and the incorrect MAC. But right arrow does nothing at this stage, I just get a "bounce". Does anyone know how I can edit the MAC?

I tried to do a reset on the device using the '+' key on the remote while powering up, but I saw nothing to confirm that a reset actually happened. I also tried the '1' key to do a "Program Xilinx" but also saw no indication it did anything. My remote works fine, that is not the problem.

I tried using net-udap to connect to the SB1 but was not successful. Because I can't get it to reset?? I don't know. I've used net-udap on SB Classics before.

Anyone have any ideas? I really just need to set the MAC address back to what is printed on the bottom of the device. Thanks.

2017-11-27, 03:30
You could try to switch it off, stop LMS if you have one running, and restart SB1 without a running LMS. SB should then automatically start in setup mode.
If you’re connected to mysbc, disconnect the WAN from your internet router and restart SB.

2017-11-27, 03:55
I think the thread about mac address changing and xilinx are all related to 3rd genplayers such as SB2, SB3 and SB classic.

One user with a similar issue woith an SB1 and problem MAC address - turns out a new PSU and factory reset fixed the problem.

2017-12-05, 20:49
Well, I got it to go into setup mode - I'm not sure if disconnecting my desktop computer from the net or +Power finally worked. It powered on and asked the usual network questions. I didn't see anything that led me to believe it actually did a reset. No blinking or anything on the display.

In any case, I still couldn't get net-udap to connect, and no amount of futzing has led to a reset of the MAC address. And I can't find a way to edit it.

I am actually using a new power supply, because I thought that my help my SB Classic that died (I can see a red light through the optical port and that's it). A new power supply did not help the SB Classic, and does not seem to make any difference on this SB1.

Oh well, I guess I'm stuck until I can buy another SB Classic.

Thanks for the advice, cheers.