PDA

View Full Version : Still two issue to FIX



steff
2017-10-19, 05:42
I am now very happy with my player after several issues have been fixed (turbo mode enabled to let me play 24/352 high res file and Edimax WiFi dongle to stream from network even at the highest bitrate) but I still need to fix two minor issues:

1) every time I boot the player, I need to go in "choose player" and select the second one avaialble, since the first does not work.
Where come from these two players? How can I remove the not working one?

2) most of times I boot the player, the Internet radio are not avaialble and i have to restart.
How to fix?

regards.

drmatt
2017-10-19, 10:32
Fix what?


Transcoded from Matt's brain by Tapatalk

Mnyb
2017-10-19, 10:56
More context which player ? which OS ? what LMS version ? what interface do you "choose player" from ?

d6jg
2017-10-19, 13:34
I am now very happy with my player after several issues have been fixed (turobo mode enabled to let me play 24/352 high res file and Edimax WiFi dongle to stream from network even at the highest bitrate) but I still need to fix two minor issues:

1) every time I boot the player, I need to go in "choose player" and select the second one avaialble, since the first does not work.
Where come from these two players? How can I remove the not working one?

2) most of times I boot the player, the Internet radio are not avaialble and i have to restart.
How to fix?

regards.

I am guessing you are using a Pi

You probably have 2 x players because it has connected both wired and wireless - the network interfaces have different MAC addresses.

Man in a van
2017-10-19, 13:41
From previous posts by the Op i think you are correct, pCP with Jivelite and a screen i presume.

Could it be that there are two Wireless IP, as I think the OP has changed from 2.4 to 5 whatever hz or gb :confused::(

ronnie

steff
2017-10-20, 13:17
OK...

It is a Raspeberry Pi3 equipped with its LCD touchscreen.
Everything is running in the same box but the media files are on a NAS.

the Rpi3 has, of course, a wired ethernet port (not used, unplugged), a built-in WiFi (disabled by the piCorePlayer interface) and a Edimax WiFi USB WiFi adapter (the one used)

thanks a lot

DJanGo
2017-10-21, 00:48
the Rpi3 has, of course, a wired ethernet port (not used, unplugged), a built-in WiFi (disabled by the piCorePlayer interface) and a Edimax WiFi USB WiFi adapter (the one used)

thanks a lot

Show us the first 3 colums from the Mac Address of the "first does not work Player"
Its B827EB ???

steff
2017-10-21, 07:45
Show us the first 3 colums from the Mac Address of the "first does not work Player"
Its B827EB ???

how can I do that?

Man in a van
2017-10-22, 03:22
how can I do that?


My players are listed (with their MAC addresses) on the Information tab on the LMS Settings page :)

steff
2017-10-22, 14:40
My players are listed (with their MAC addresses) on the Information tab on the LMS Settings page :)

this is what I see

piCorePlayer
Modello del lettore: SqueezeLite
Tipo lettore: squeezelite
Firmware: v1.8.7-999
Indirizzo IP del lettore: 192.168.1.40
Indirizzo MAC del lettore: 74:da:38:xx:xx:xx

In the web page of my LMS (running in the same Rpi3) I can see just one player and its MAC address is the one of the Edimax WiFi USB adapter.


For the other problem (radio not always available) I noticed that stopping and restarting only the LMS solves the problem but it is very annoying because I can not (I am not able, I do not know how to do that) restart the LMS from the LCD touchscreen... I need the web browser.

Mnyb
2017-10-22, 16:16
But where do you have to pick the rigth player ? If LMS web UI only shows one ? The one with the Mac of the WiFi dongle .

steff
2017-10-23, 07:25
But where do you have to pick the rigth player ? If LMS web UI only shows one ? The one with the Mac of the WiFi dongle .

I was saying that on the touch LCD of the Raspberry, if I choose my music, then it wait some seconds then says impossible to connect; I have then to go to choose player and select the second row and it works.

On the LMS web interface I do not have any problem in controlling the piCorePlayer and in the menu (top roght corner) if I select the player I see just one player.

DJanGo
2017-10-23, 11:20
I was saying that on the touch LCD of the Raspberry, if I choose my music, then it wait some seconds then says impossible to connect; I have then to go to choose player and select the second row and it works.

On the LMS web interface I do not have any problem in controlling the piCorePlayer and in the menu (top roght corner) if I select the player I see just one player.

You didnt have a Linux / Unix issue you have a Picoreplayer issue.

Under "linux" i would say
grep _client: /var/lib/squeezeboxserver/prefs/server.prefs
Under Picoreplayer? No clue about it
Under Linux i would say just add something like -m "my:fa:vo:ri:te:ma:c1" to make sure squeezelite is using the right mac address to communicate with the lms portion.

you guess it - no clue how to do that in picoreplayer.

cheers.