PDA

View Full Version : LMS M4a Support ?



Adiomat
2017-09-15, 05:46
Hey there,
I use the SB for many ages now... due to streaming services i did Not stream too often from my own Library in the near past
Yesterday...i was Again crawling thrue my albums
I am actually Not able to Stream Any M4a file. In Former Versions i did Not have a Single Problem with that,

Am i totally wrong? Or was there a change in the recent versions?

Fans in advance

Hans

Stig Nygaard
2017-09-15, 08:23
Hey there,
I use the SB for many ages now... due to streaming services i did Not stream too often from my own Library in the near past
Yesterday...i was Again crawling thrue my albums
I am actually Not able to Stream Any M4a file. In Former Versions i did Not have a Single Problem with that,
Am i totally wrong? Or was there a change in the recent versions?


M4a plays fine for me using LMS 7.9.1 - 1503129892 @ Sat Aug 19 (LmsRepack version) on a Synology DS716+II. Tested on both SBTouch and a RPi3/Max2Play based player. I don't know if transcoding is needed for any of my devices. What player device are you using? Is it the same player device you used back when you remember it working?

Mnyb
2017-09-15, 08:58
In his signature there are SB3's they need transcoding.

M4a can be AAC or ALAC .

Adiomat
2017-09-15, 10:10
In his signature there are SB3's they need transcoding.

M4a can be AAC or ALAC .

Right!
Is it possible that transcoding was dropped in one of the recent updates?
I checked the server preferences. There is nothing disabled.
Any ideas?
Hans

Ps: and yes Qnap 239proII and 2*SB3. LMS 7.9.1

bpa
2017-09-15, 10:23
Right!
Is it possible that transcoding was dropped in one of the recent updates?
I checked the server preferences. There is nothing disabled.
Any ideas?
Hans

Ps: and yes Qnap 239proII and 2*SB3. LMS 7.9.1
Transcodgin hasn't been dropped . Check WebUI Settings/Advanced/FileTypes to see of AAC and Apple Lossless and also MP4 or MPEG-4 entries.

It is possible the transcoding executable is present doesn't run on your system.

To see what is happening when you try to play - you can enable logging player.source to INFO.

Mnyb
2017-09-15, 21:45
Right!
Is it possible that transcoding was dropped in one of the recent updates?
I checked the server preferences. There is nothing disabled.
Any ideas?
Hans

Ps: and yes Qnap 239proII and 2*SB3. LMS 7.9.1

No it's nit dropped . It migth not run properly on qnap for some reason .

Adiomat
2017-09-16, 00:50
No it's nit dropped . It migth not run properly on qnap for some reason .

hi,
good morning, and thanks for your effort. I found the time to look insinde the "normal" Server Logs
found the following:
/share/MD0_DATA/.qpkg/LogitechMediaServer/var/home/SqueezeboxServer/Bin/i386-linux/faad: /lib/libc.so.6: version `GLIBC_2.7' not found (required by /share/MD0_DATA/.qpkg/LogitechMediaServer/var/home/SqueezeboxServer/Bin/i386-linux/faad)

i just updated to the newest nightly release......--> no changes...same behaviour :-(

is there somewhere a verbos-mode to see more details =?

fanx in advance
hans

bpa
2017-09-16, 01:01
hi,
good morning, and thanks for your effort. I found the time to look insinde the "normal" Server Logs
found the following:
/share/MD0_DATA/.qpkg/LogitechMediaServer/var/home/SqueezeboxServer/Bin/i386-linux/faad: /lib/libc.so.6: version `GLIBC_2.7' not found (required by /share/MD0_DATA/.qpkg/LogitechMediaServer/var/home/SqueezeboxServer/Bin/i386-linux/faad)

i just updated to the newest nightly release......--> no changes...same behaviour :-(

is there somewhere a verbos-mode to see more details =?

fanx in advance
hans

libc.so (GLIB_2.7) is a system provided library and so either an LMS update or a NAS update has broken faad - there is now a version mismatch. You need to either build a version of faad on your system or find the version of faad (and also flac) that used to work and replace the broekn ones.

It mnay be best to ask how other users of the QNAP TurboStation TS-239PROII / LMS 7.9 got trasncoding to work.

mherger
2017-09-17, 23:53
We did indeed update faad a few months ago:

https://github.com/Logitech/slimserver/tree/public/7.9/Bin

From there you can grab an old copy and replace the one on your system.