PDA

View Full Version : Default Touch behaviour



zanoroy
2017-08-07, 16:00
Can someone tell me how to change the default behaviour when I select a song. I would like the context menu to appear when I left click (or hit enter) on an item/song.

I assume I need to modify the SlimBrowerApplet but I wanted to make sure before attempting to change things.

Also how do I get the debug messages, I see in then lua files that lots of debug information is posted, but I have no idea where to find it (or maybe I just donít know how to turn it on)

Any help appreciated.

Cheers

pippin
2017-08-07, 18:11
No need to do changes to the code.
Search for the Ądefeat destructive touch-to-playď option in the player settings of the web interface

zanoroy
2017-08-07, 18:56
Morning Pippin,
I have set the "defeat destructive touch-to-play" within LMS to always ask, but within Jivelite: I select a song and the song simply plays rather then prompting for an action. I have rebooted the server after changing the setting but that has not fixed the issue. I did go back and check that the setting was still set the Always Ask.

I am using the HD Grid Skin (skin name within the settings is - pigrid_1024x600) on a Raspberry Pi 3 - using a 7'' Touch screen, Max2Play with Jivelite v7.9. The only item I have changed is the Clock Applet to allow it to run on the higher resolution - eg I added the pigrid_1024x600 to be able to display)

Is there a setting I have not found?

Thank you

pippin
2017-08-08, 04:08
No idea. I thought JivrLite uses that same applet code as SqueezePlay, maybe itís using old versions?
Someone knowing JiveLite internals would have to answer.
You didnít mention JiveLite in the thread title so people might have missed that this is about JiveLite at all, I certainly did.

slartibartfast
2017-08-08, 05:07
Morning Pippin,
I have set the "defeat destructive touch-to-play" within LMS to always ask, but within Jivelite: I select a song and the song simply plays rather then prompting for an action. I have rebooted the server after changing the setting but that has not fixed the issue. I did go back and check that the setting was still set the Always Ask.

I am using the HD Grid Skin (skin name within the settings is - pigrid_1024x600) on a Raspberry Pi 3 - using a 7'' Touch screen, Max2Play with Jivelite v7.9. The only item I have changed is the Clock Applet to allow it to run on the higher resolution - eg I added the pigrid_1024x600 to be able to display)

Is there a setting I have not found?

Thank youJust a thought. The destructive touch to play settings are per player so are you sure that you applied the setting to the correct player?

Sent from my SM-G900F using Tapatalk