PDA

View Full Version : Squeezebox on Mac question



ghulse
2017-08-04, 13:31
Recently the hard drive on the MacMini died, so I replaced it with new 1TB hard drive and put a fresh install of Snow Leopard 10.6.8 and LMS 7.7.6. My player is PiCore Player on a Rasberry Pi 2.

I keep having a problem where the Logitech server is not available on the network and I have to restart the MacMini. I never used to have that problem, but this is also the first time I'm trying to run the MacMini headless. I can usually access the MacMIni from my laptop using ScreenShare and restart it.

Another issue that pops up frequently is that Squeezebox server is not available from the web interface on my laptop, but it does work when I use iPeng on my iPhone. When I check the IP address of LMS it comes up as 127.0.0.1. When the LMS is available via the web interface, the address is something like 192.xxx.xxx.xx.

This has become such a pain in the ass, I may just sell the MacMini and get a NAS drive. But maybe someone can help me figure out what's going on. Why does the LMS come up as IP address 127.0.0.1. instead of the usual 192.xxx.xxx.xx?

d6jg
2017-08-04, 13:36
127.0.0.1 is localhost
Every machine has this as its alternate default IP as well as something else (if the network is up)
On your Mac both http://127.0.0.1:9000 and http://192.168.1.x:9000 should work

ghulse
2017-08-04, 15:27
127.0.0.1 is localhost
Every machine has this as its alternate default IP as well as something else (if the network is up)
On your Mac both http://127.0.0.1:9000 and http://192.168.1.x:9000 should work

Well, that's the problem. If I try to connect to http://127.0.0.1:9000 I get a message "Unable to connect."

The other problem is that the MacMini disappears from the network after a period of inactivity. I tried selecting "Wake for Network Access" under Energy Prefs, but this seems to do nothing. I am suspecting that the no keyboard or mouse plugged into the Mac Mini is messing it up somehow.

d6jg
2017-08-04, 15:34
You can only connect on 127.0.0.1 on the actual machine LMS is running on - the Mac.
127.0.0.1 / localhost means THIS machine.
From other machines / devices you need http://192.x.x.x:9000 where 192.etc is the IP of the Mac.
I am not a Mac person but look for power options is System Prefs

ghulse
2017-08-04, 16:04
Normally if I go to the LMS preference pane on the Mac Mini, it gives me the server's IP address as 192.x.x.x and that's what I use on my other Mac, adding :9000 to the end of it to access the web interface. But now it only gives the server address as 127.0.0.1 and I know I will not be able to access the web interface no matter what. And, yet, iPeng can find the LMS server and play music.

Maybe LMS does have a normal 192.x.x.x address, but for some reason is not displaying it. I just don't know.

d6jg
2017-08-04, 16:09
Normally if I go to the LMS preference pane on the Mac Mini, it gives me the server's IP address as 192.x.x.x and that's what I use on my other Mac, adding :9000 to the end of it to access the web interface. But now it only gives the server address as 127.0.0.1 and I know I will not be able to access the web interface no matter what. And, yet, iPeng can find the LMS server and play music.

Maybe LMS does have a normal 192.x.x.x address, but for some reason is not displaying it. I just don't know.

It's the same as the IP of the Mac itself. You aren't running it with both wired and wireless on are you by any chance? In which case there are 2 x 192 addresses. You are best off running it only wired and with a static IP
IPeng uses a different discovery mode to find LMS so no surprise it finds it.

ghulse
2017-08-04, 17:15
It's the same as the IP of the Mac itself. You aren't running it with both wired and wireless on are you by any chance?

I should have known the LMS IP address is the same as the IP of the Mac. But I didn't. Thank you. I have my web interface back.

To answer your other question, no it's set up as wireless only.

As for the other problem, I'm going to just leave a keyboard and mouse plugged in to the Mac Mini for now to see if that resolves the music server disappearing. Thanks again for your help.