PDA

View Full Version : Networking/SS Debugging Help Please



Mick Trusler
2005-01-01, 05:14
Hi,

Please, I need some help with debugging. I have a
Slimp3 wired which is working fine but recently bought
a Squeezebox which is connect via wireless. With this
I'm getting 2 problems: -

1. The Squeezebox just freezes. Managed to catch the
following whilst this was happening -

2005-01-01 11:48:25.3698 songTime: [120.691375] =
(1931062(realpos) / 3297280(size) * 206.08(duration) *
1(rate)) + 0(time offset of started stream)
2005-01-01 11:48:25.7494 00:04:20:05:65:38: Underrun
while this mode: play
2005-01-01 11:48:26.3691 songTime: [121.652625] =
(1946442(realpos) / 3297280(size) * 206.08(duration) *
1(rate)) + 0(time offset of started stream)

and then will eventually restart playing song from
where it left off.


2. The Squeezebox does a "reboot" ie goes blank and
the Slimdevices startup message is displayed again. It
then restarts at the begining of the song it was
playing.

I did manage to catch the following at one point but
not sure how useful it is -

2004-12-29 11:47:14.7910 Opening connection to

http://www.slimdevices.com/update/?version=5.4.0&lang=EN:
[www.slimdevices.com on port 80 with

path /update/?version=5.4.0&lang=EN with timeout 5]
2004-12-29 11:47:14.8199 Can't open socket to
[www.slimdevices.com:80]: 22: Invalid argument


Can someone please tell me the best debug flags to set
on the server to try and catch what might be the
problem as I'm slowly going mad and likely to just
dump the Squeezebox.

Thanks


Mick

Jack Coates
2005-01-01, 08:59
Mick Trusler wrote:
> Hi,
>
> Please, I need some help with debugging. I have a
> Slimp3 wired which is working fine but recently bought
> a Squeezebox which is connect via wireless. With this
> I'm getting 2 problems: -
>
> 1. The Squeezebox just freezes. Managed to catch the
> following whilst this was happening -
>
> 2005-01-01 11:48:25.3698 songTime: [120.691375] =
> (1931062(realpos) / 3297280(size) * 206.08(duration) *
> 1(rate)) + 0(time offset of started stream)
> 2005-01-01 11:48:25.7494 00:04:20:05:65:38: Underrun
> while this mode: play
> 2005-01-01 11:48:26.3691 songTime: [121.652625] =
> (1946442(realpos) / 3297280(size) * 206.08(duration) *
> 1(rate)) + 0(time offset of started stream)
>
> and then will eventually restart playing song from
> where it left off.
>
>
> 2. The Squeezebox does a "reboot" ie goes blank and
> the Slimdevices startup message is displayed again. It
> then restarts at the begining of the song it was
> playing.
>

Both of these are probably wireless interference -- to troubleshoot, the
best thing to do is hook up temporarily with an ethernet cable and see
if it goes away. If it does, then try changing your AP's channel,
seeking out cordless phones, microwave ovens, neighbor's gear, &c.

> I did manage to catch the following at one point but
> not sure how useful it is -
>
> 2004-12-29 11:47:14.7910 Opening connection to
>
> http://www.slimdevices.com/update/?version=5.4.0&lang=EN:
> [www.slimdevices.com on port 80 with
>
> path /update/?version=5.4.0&lang=EN with timeout 5]
> 2004-12-29 11:47:14.8199 Can't open socket to
> [www.slimdevices.com:80]: 22: Invalid argument
>

This is a regular update check, it can be turned off. I expect you have
a firewall turned on; XP SP2?

>
> Can someone please tell me the best debug flags to set
> on the server to try and catch what might be the
> problem as I'm slowly going mad and likely to just
> dump the Squeezebox.
>
> Thanks
>
>
> Mick
>
>
>
>
>
>
>