PDA

View Full Version : SBT showing wrong time in LMS after power outage



Nick_G
2017-07-03, 23:11
Hi all.

We had an electrician do some work here yesterday and he had to switch off the mains power for a while. Since then LMS (running on a Raspberry Pi) is showing the wrong time (about 6 minutes fast). I've connected to MySB and this resets to the correct time but going back to LMS the time is still wrong. I've only been able to find settings for the correct time zone, rather than the time itself.

Any ideas please?

pozar@lns.com
2017-07-03, 23:29
Are you not running an NTP client on the RPi? You can either run ntpd
or ntpdate at startup. The former is better.

https://raspberrypi.stackexchange.com/questions/8231/how-to-force-ntpd-to-update-date-time-after-boot

On 7/3/17 11:11 PM, Nick_G wrote:
>
> Hi all.
>
> We had an electrician do some work here yesterday and he had to switch
> off the mains power for a while. Since then LMS (running on a Raspberry
> Pi) is showing the wrong time (about 6 minutes fast). I've connected to
> MySB and this resets to the correct time but going back to LMS the time
> is still wrong. I've only been able to find settings for the correct
> time zone, rather than the time itself.
>
> Any ideas please?
>
>
> ------------------------------------------------------------------------
> Nick_G's Profile: http://forums.slimdevices.com/member.php?userid=38427
> View this thread: http://forums.slimdevices.com/showthread.php?t=107604
>
>

slartibartfast
2017-07-04, 04:11
Hi all.

We had an electrician do some work here yesterday and he had to switch off the mains power for a while. Since then LMS (running on a Raspberry Pi) is showing the wrong time (about 6 minutes fast). I've connected to MySB and this resets to the correct time but going back to LMS the time is still wrong. I've only been able to find settings for the correct time zone, rather than the time itself.

Any ideas please?
Are you seeing incorrect time on devices? If so restart the devices or leave them for an hour or so.

Sent from my SM-G900F using Tapatalk

Nick_G
2017-07-04, 10:04
Thanks guys.

Sorry. I have no idea what an 'NBT client' is and I know virtually nothing about coding so nothing too technical please! I have the web interface of the Raspberry Pi via Max2Play, if that helps.

I've tried restarting the SBT but it hasn't made any difference.

I'm hoping there's a simple, idiot-proof solution to this...

Tex
2017-07-04, 16:34
The time zone setting is underneath the language setting. Just click to the right of it and set your zone. It took me a while to figure it out too:-)

Nick_G
2017-07-05, 16:12
The time zone setting is underneath the language setting. Just click to the right of it and set your zone. It took me a while to figure it out too:-)

Thanks. I've tried that and all it does is move the time forwards or backwards by an hour each time depending what zone you choose. The clock on the SBT is about 6 or 7 minutes ahead, and I can't see any easy way of fixing that.

Tex
2017-07-05, 20:41
If that doesn't work you might try to reset to the original settings on the Settings Reboot page. I use piCorePlayer now and had to reinstall it to the SD card and start from scratch after a power failure. Unfortunately I suspect you might have to do that to. The cards can get corrupted during a power failure.

Nick_G
2017-07-21, 09:58
If that doesn't work you might try to reset to the original settings on the Settings Reboot page. I use piCorePlayer now and had to reinstall it to the SD card and start from scratch after a power failure. Unfortunately I suspect you might have to do that to. The cards can get corrupted during a power failure.

Thanks for your help with this.

After that last post I left it because I really didn't want to go through the hassle of reinstalling LMS, which for me, would be like groping about blindly in the dark. However, after leaving things for a week or so, I checked again yesterday and the time on LMS has mysteriously corrected itself. Whether this had anything to do with going on Max2Play the previous day and checking for updates (there weren't any) had anything to do with it, or whether that was just a coincidence, I have no idea. Good that it's fixed though!

Julf
2017-07-22, 05:04
If a machine that uses NTP (Network Time Protocol) starts up with the time/date badly wrong, it can take a while for it to drift back into correct time.

Mnyb
2017-07-23, 21:31
I think there is a step method and slew option in NTP dependent on the config of it .

Slew slowly syncs the clcoks and it may not go backwards in time ? It slows down and catch up when the real time has the same time .

The reasoning is that there are programs that react badly to sudden time adjustments and going back in time .

So we see a slow gradtal correction .