PDA

View Full Version : Vortexbox suspending when laptop lid closed



s2kiwi
2017-06-29, 01:56
Does anyone know how to stop Vortexbox suspending when I shut the laptop lid.

I've tried a number of solutions I've found online, but they all seem to assume Gnome is installed onto the Fedora instance, which isn't the case in Vortexbox. So far nothing has worked so any ideas appreciated.

drmatt
2017-06-29, 02:35
What desktop environment *is* running? There will be a power options thing for it.


Transcoded from Matt's brain by Tapatalk

s2kiwi
2017-06-29, 03:03
What desktop environment *is* running? There will be a power options thing for it.

I installed the default Vortexbox environment which doesn't look to have a desktop environment, just a Command Line. I'm more than happy just using the command line as I normally work via SSH anyway, but this one bug is frustrating.

Currently the only way I can work out how to stop it is to log in on each boot, and enter the below to block the lid switch activating anything.
systemd-inhibit --what=handle-lid-switch --who=me --why=because --mode=block /bin/sh

s2kiwi
2017-06-29, 03:21
Actually, I may have found a way.

systemctl mask sleep.target suspend.target

Although that does feel a bit overkill.


Note to future-self, to reverse this use: systemctl unmask sleep.target suspend.target