PDA

View Full Version : Raspberry Pi 3 Wifi not working with picoreplayer 3.20



jncweb
2017-05-27, 10:52
I downloaded audio version and it installed okay. I can access with ethernet cable.

When I change the wifi setting it remembers my settings but it does not connect to wi-fi.

I get these messages when scanning.

Wifi IP: is missing - reboot or connect required

Scanning......

No wifi devices found!

Possible error:

1. USB wifi adapter missing - insert adapter.
2. wifi drivers and firmware missing - reboot required.

Any ideas?

One more question if I want to access only usb connected music files, do I need to update the library each time or can I do this via the touch screen?

Great product just need to get it working with touchscreen.

Eyerex
2017-05-29, 03:43
Had the same problem so went back to 3.11 Audio which works perfectly

scontin
2017-05-29, 09:57
audio version 3.20 do NOT have wireless enabled.

wtnh
2017-06-08, 15:26
audio version 3.20 do NOT have wireless enabled.

I had the same issue and wasted some time figuring out that it will not work. See reply #20 in this thread (http://forums.slimdevices.com/showthread.php?107352-Announce-piCorePlayer-3-20/page2).

In my case, I am using a Boss DAC hat.

I gave up on the built in wifi and used a spare TP Link router as a bridge to my main network, where my LMS resides. This setup works fine - just not very elegant.

Other options are to get a supported dongle, preferably one that runs at 5Ghz to avoid interference with some DACs.

It is sort of a shame since I had assumed that one of the advantages of the Pi 3 was the built-in wifi.

tkr001
2017-08-10, 00:24
I am using 3.21 non audio with a rpi3. Everything works fine using Ethernet. When I turn wifi on and enter the correct details for ssid pass phrase and wpa encryption disconnect Ethernet and reboot wlan0 is detected but a dhcp lease is never obtained. I am at my wits end.

If I do a scan in pcp it finds the ssid.

What can I do to troubleshoot?

epoch1970
2017-08-10, 01:04
I am using 3.21 non audio with a rpi3. Everything works fine using Ethernet. When I turn wifi on and enter the correct details for ssid pass phrase and wpa encryption disconnect Ethernet and reboot wlan0 is detected but a dhcp lease is never obtained. I am at my wits end.

If I do a scan in pcp it finds the ssid.

What can I do to troubleshoot?

Verify your access point is open to that new client. In general this means note the MAC address of the wifi card (PCP displays it) and enter that address in the list of allowed devices in the wifi access point/router.

Also, the wifi interface built in Pi 3 is 2.4GHz. Make sure your AP is not set to 5GHz only.

tkr001
2017-08-10, 02:52
Thanks for the suggestions. The AP is 2.4ghz only and is not restricted from allowing devices to connect i.e. All macs are ok. It is at my daughter's house but my android phone, iPad and surface pro all connect fine. I built the pcp at my home on Ethernet but she does not have her lounge cabled and I really don't want to run cable but it looks like I will have to if I can't get the pcp to connect via wifi.

Jeff07971
2017-08-10, 03:10
Thanks for the suggestions. The AP is 2.4ghz only and is not restricted from allowing devices to connect i.e. All macs are ok. It is at my daughter's house but my android phone, iPad and surface pro all connect fine. I built the pcp at my home on Ethernet but she does not have her lounge cabled and I really don't want to run cable but it looks like I will have to if I can't get the pcp to connect via wifi.

Pi3's WiFi is not very good at the best of times, I never use it.
An alternative to running Cat5 cable is powerline networking I have found that it is usually reliable (far better than pi3 Wifi)

bpa
2017-08-10, 03:56
Thanks for the suggestions. The AP is 2.4ghz only and is not restricted from allowing devices to connect i.e. All macs are ok. It is at my daughter's house but my android phone, iPad and surface pro all connect fine. I built the pcp at my home on Ethernet but she does not have her lounge cabled and I really don't want to run cable but it looks like I will have to if I can't get the pcp to connect via wifi.

Alternatives to powerline - a wifi travel router (e.g. tplink) operating in bridge mode (i.e. Ethernet from pi to router and then wifi to router) or a wifi USB adaptor (maybe with an antenna) on a long USB lead to find best signal.

epoch1970
2017-08-10, 07:31
Pi3's WiFi is not very good at the best of times, I never use it.
In my experience, Pi3 built-in wifi is surprisingly good.
Almost every Pi 3 I've setup is either using it for AP or bonding with ethernet.

The OP should look elsewhere: use of incompatible settings in the AP, weak signal, ...

IMHO powerline is a good option is you have bad wifi coverage and don't want to use ethernet cabling.
Another option I like is flat ethernet cables. Dimensions and flexibility like a (cooked) tagliatella, much easier to conceal than round cables.
Wireless extenders are no good: either they extend nothing really, or they break up themselves when too far from the AP.

d6jg
2017-08-10, 12:58
You say it doesn't get an IP address. If it's the router that does dhcp try rebooting the router.

Greg Erskine
2017-08-10, 16:31
Here is a list of common wifi issues.

http://picoreplayer.sourceforge.net/faq_wifi%20does_not_work.shtml

Please let me know if you have found a new one. :)

To help with diagnostics:

[Wifi Settings] in [Beta] mode > [Diagnostics]

tkr001
2017-08-10, 22:18
I am about to fly out of the country for a week. Will test some more when I get back. In the meantime powerline adaptors have done the trick.

jncweb
2017-08-29, 05:24
just to feedback on this making some progress on 3.11 as suggested, thanks!