PDA

View Full Version : LMS won't access \media folder



Vansloneker
2017-05-11, 06:39
I am in the process of setting up a new LMS-machine. Right now testing Mint 15, planning on Mint 18.1. Everything goes fine, except for one thing: I can't get LMS to access my music folders!
My Flac partition is mounted on \media\vansloneker\Flac and LMS does not see anything inside \media.

I followed the guide on http://wiki.slimdevices.com/index.php/Debian_Package to add LMS as group and set permissions, I tried setting permissions on the command line as well as with the file manager: alas.

I spent hours on Google and found no way out.

On my current machine I have mounted my Flac partition on \mnt\flac and I can't remember if I had problems getting it to find it there.
But having the partition mounted on \media is sort of standard and easier to access with the file manager that's why I would like it that way.

iPhone
2017-05-11, 07:13
I am in the process of setting up a new LMS-machine. Right now testing Mint 15, planning on Mint 18.1. Everything goes fine, except for one thing: I can't get LMS to access my music folders!
My Flac partition is mounted on \media\vansloneker\Flac and LMS does not see anything inside \media.

I followed the guide on http://wiki.slimdevices.com/index.php/Debian_Package to add LMS as group and set permissions, I tried setting permissions on the command line as well as with the file manager: alas.

I spent hours on Google and found no way out.

On my current machine I have mounted my Flac partition on \mnt\flac and I can't remember if I had problems getting it to find it there.
But having the partition mounted on \media is sort of standard and easier to access with the file manager that's why I would like it that way.
.
.
On LMS under Setting/Basic/Media Folder have you entered the new path you are using and most important did you verify the exact spelling of each path word and capitalization? You typed \media\vansloneker\Flac might it actually be flac? Also I use Fedora and it requires a forward / between file names does your OS require backslashes \ ?

SlimChances
2017-05-11, 08:22
It is usually a permission issue
Ownership of the folder/files needs may need to be changed. You can try this it has worked for me on new installs:
Here's one for anyone struggling with Linux file permissions.
It is run from a terminal window in the main folder housing your
music collection. Basically it does two things: 1) ensures all folders
and files are owned by your user account; 2) makes all directories and
files r/w to your account and read only to all others. Note : change username:groupname to your reflect your computer

sudo chown -R username:groupname * && find . -type d -execdir
sudo chmod 775 {} \; && sudo find . -name "*" -type f -exec chmod 644 {} \;

http://forums.slimdevices.com/showthread.php?t=92526&highlight=file+permissions

DJanGo
2017-05-11, 10:01
It is usually a permission issue
Note : change username:username to your own name as used in terminal


sudo chown -R username:username * && find . -type d -execdir
sudo chmod 775 {} \; && sudo find . -name "*" -type f -exec chmod 644 {} \;

http://forums.slimdevices.com/showthread.php?t=92526&highlight=file+permissions

STOP

sudo chown -R username:groupname!!!

http://wiki.slimdevices.com/index.php/Debian_Package#Users_and_Groups (http://wiki.slimdevices.com/index.php/Debian_Package#Users_and_Groups)

SlimChances
2017-05-11, 10:12
STOP

sudo chown -R username:groupname!!!

http://wiki.slimdevices.com/index.php/Debian_Package#Users_and_Groups (http://wiki.slimdevices.com/index.php/Debian_Package#Users_and_Groups)

Sorry your quite right . I will correct it, although I did it that way without issue

Vansloneker
2017-05-12, 13:55
Thanks for the replies.
I installed Mint 18.1
The music partition is automatically mounted by the name FLAC.
I applied the Debian Package page.

Sadly, it's the same story. LMS apparently has no access to /media and the mounted partitions.
Again I tried several approaches, like allowing lms via the file manager.
But no luck.

Vansloneker
2017-05-12, 23:14
By going into the /media folder then setting chmod -R 664 /vansloneker/FLAC I got LMS to see /media/vansloneker. But not /media/vansloneker\FLAC :confused:

Going into /media/vansloneker then chmodding FLAC doesn't help either.

Here's a clue, on the command line I can't cd into FLAC: permission denied.

With the filemanager looking at permissions as root, every single folder has the remark: "the folder permissions are inconsistent" and the option to fix it. I wonder if this has to do with copying the files disk to disk on another machine using FreeFileSync. However, another partition made on this machine is also inaccessible for LMS.
Anyway I will try to format the partition and start all over, see if that changes anything.

Mnyb
2017-05-13, 00:33
Is it an USB drive ? I sugest mounting it via fstab instead of automatically ?

Vansloneker
2017-05-13, 03:21
No it's a regular partition. Ext4 SDA4.

Vansloneker
2017-05-20, 11:48
Update:

I tried everything. New installs, existing Mint installations. 15, 17, 18. All the same.
A big dent in my Linux confidence. Must be some Mint bug though.

So I had to find a different approach. I decided on the latest Debian 8.8. Installing wasn't easy. The small image netinstall failed. Tried again with DVD ISO with non free drivers. Debian has a weird approach to partitioning, better leave that alone and go for guided full disk, later boot external and resize-add partitions to fit your needs.
Debian is not user friendly and misses many obvious things you find in *buntu's. By default it looks like Windows 3.1. Anyway I got LMS up and running and detecting my files in /media/FLAC. That is not /media/vansloneker/FLAC like it used to be on my current system so I will have to edit my playlists.

I had a hard time getting access through Samba. Solved by editing and saving a sample samba.conf.


It's still a setup on a test-rig. What remains is moving the setup to a disk and PC where it is supposed to. Never a problem, but with all the difficulties not so sure.