PDA

View Full Version : USB Stick Mount Issue PiCore 3.02? Anyone?



jags
2017-04-18, 14:06
Hey,

I have installed on a Pi3 PicorePlayer 3.02 (latest version). All seems to work properly but I can't get the USB stick mounted.
I reformatted the USB stick but no luck. Reformatted with FAT32 or NTFS, does not matter, does not work.
I tried another USB stick, not working.

I installed linux.utils as well. No change.

When I connect the USB stick (any) I can see 4 partitions for some reason.
When I try to mount one of them I am getting an error, could not mount and reboot.

Anyone got an idea?

Greg Erskine
2017-04-18, 14:56
Hi jags,

In my experience USB sticks automatically load under /mnt/sda1. (use df command)

If it doesn't dynamically load try rebooting or using the command $ sudo mount /dev/sda1

A USB stick won't have 4 partitions unless you added them.

You need to supply more info, like type of USB stick, error messages, output of df, what you tried to do to mount it, what were you expecting?

BTW: I assume you are using piCorePlayer 3.20 beta?

regards
Greg

Mnyb
2017-04-18, 21:14
Reformat the USB stick it may have these extra partitions with bundled spamware.