PDA

View Full Version : Picoreplayer Japanese/Chinese characters display as pinyin?



gadgetwiz
2017-04-06, 18:15
Just installed PCP on a pi zero to test for use as an LMS server playing off my NAS and I must say it's brilliant in terms of playback on my old but trusty SB3 player (which has the slim devices logo on the fascia!). The primary reason to use this was that the NAS (a buffalo linkstation quad) has only a cut down (and now old) version of LMS and wouldn't display non English characters at all and the plug ins didn't work either.

Anyway on the SB3 (using PCP) Japanese and Chinese characters in my music tags show up in pinyin form (ie romanised characters eg the character 明 shows up as "ming" instead of the character). From google searches it would seem that I need to replace certain fonts in LMS but I can't seem to access this on the pi (I have direct access to the pi and can find my way around linux a bit but can't seem to find where the LMS files are). I might add that when looking at the media files on my windows pc browser pointing to the LMS address XX.XX.XX.XX:9000 will show the characters properly.

Can anyone help me fix this?

As a secondary issue the time on the PCP home page doesn't display correctly - I'm stuck in 1970 so it's not picking up the time at bootup.

Edit: and I'm on the latest 3.2b5

mherger
2017-04-07, 00:18
> Anyway on the SB3 (using PCP) Japanese and Chinese characters in my
> music tags show up in pinyin form (ie romanised characters eg the
> character 明 shows up as "ming" instead of the character). From google
> searches it would seem that I need to replace certain fonts in LMS but I
> can't seem to access this on the pi (I have direct access to the pi and

Would you get those characters when running LMS from a different
platform (PC or Mac)?

I don't think the issue is the font. The references you found most
likely apply to the Squeezeplay based devices. But for display on the
Classic I thought we had a more or less complete font. The problem here
is that it requires a Perl module which might be missing from pCP.

> As a secondary issue the time on the PCP home page doesn't display
> correctly - I'm stuck in 1970 so it's not picking up the time at bootup.

What if you restarted LMS only (not pCP)?

--

Michael

gadgetwiz
2017-04-07, 03:20
Would you get those characters when running LMS from a different
platform (PC or Mac)?


Do you mean hosting LMS on a windows pc? If so I haven't done that.

But when I access LMS from a windows pc I can see the fonts render correctly.



I don't think the issue is the font. The references you found most
likely apply to the Squeezeplay based devices. But for display on the
Classic I thought we had a more or less complete font. The problem here
is that it requires a Perl module which might be missing from pCP.


As a test I have just installed LMS 7.9 directly on the pi zero running jessie lite but ended up with the same font/pinyin issue (but it did solve my time problem :-)). So perhaps not an issue with Tiny Core or pcp.

Doing a search for this issue raised a solitary thread from 2014 which discusses the same issue as I have (unfortunately not resolved):
https://forum.synology.com/enu/viewtopic.php?t=84577

Prior to installing the NAS quite some years ago I was using a pc running clarkconnect and LMS's incarnation at the time which was squeezebox server. What version it was I can't recall but would have definitely have been pre V7. And the fonts displayed perfectly on the SB3.

Edit: Found this other thread which seems to have a solution - I will try later tonight.
http://forums.slimdevices.com/showthread.php?103014-Unicode-chars-not-displayed-on-the-Transporter-with-the-latest-LMS-7-9/page2

gadgetwiz
2017-04-07, 06:08
Thanks mherger (seeing as it was yours and kezz's solution!). I referenced this old thread

http://forums.slimdevices.com/showthread.php?103014-Unicode-chars-not-displayed-on-the-Transporter-with-the-latest-LMS-7-9

and followed the instructions which were simply:

sudo perl -MCPAN -e 'install Font::FreeType'

and then

sudo rm -rf /usr/share/squeezeboxserver/Font

has the SB3 displaying asian characters as they should be!

Now - how do I do the same within the tiny core distro and pcp? (Although running jessie lite doesn't really incur much of a performance penalty - only a little longer to wait before LMS starts)

paul-
2017-04-07, 07:27
Its a bit harder on pCP, as you will need a full set of compile tools. I can make an extension for you later today.


Michael,

Is this a package we should install on pCP by default?

Paul

gadgetwiz
2017-04-07, 07:52
That would be great if it could be incorporated into the build as pcp is so easy to install and configure (excellent job BTW guys!)

paul-
2017-04-09, 11:50
That would be great if it could be incorporated into the build as pcp is so easy to install and configure (excellent job BTW guys!)

Well that was a little bit of a challange. There are many dependencies for freetype. As this is a fairly heavy install, I'm not including it by default.

From the Main Menu, you need to be in advanced mode (or beta mode)

Select the "Extensions" button
Select the "piCoreplayer sourceforge repository", the press the "Set" button
In the list of Available Extensions, find "perl_font_freetype.tcz", then press the Load button


Make sure your file system is expanded, this download is about 22MB.

Let me know how this works for you on pCP LMS.

mherger
2017-04-09, 22:44
>> Would you get those characters when running LMS from a different
>> platform (PC or Mac)?
>
> Do you mean hosting LMS on a windows pc? If so I haven't done that.

Yes, that's what I was asking.

> But when I access LMS from a windows pc I can see the fonts render
> correctly.

It's not about the display where you're seeing the characters, but about
the server. SB3 is a dumb device. All content is rendered on the server.
Therefore the server needs to be able to render your characters. I would
expect this to work on a PC, but fail on many other systems.

--

Michael

mherger
2017-04-09, 22:46
> Well that was a little bit of a challange.

Thanks a lot for accepting it :-). This and the little request I saw led
me to give up on building it for newer systems...

But then pCP comes with its own Perl build anyway, doesn't it? You're
using 5.24?

Thanks a lot!
--

Michael

gadgetwiz
2017-04-09, 23:03
Make sure your file system is expanded, this download is about 22MB.

Let me know how this works for you on pCP LMS.

Brilliant! I will test it out tonight when I'm home and post back.

gadgetwiz
2017-04-10, 02:01
Unfortunately it is still displaying pinyin instead of asian characters. The extension is showing as installed and the pi was rebooted for good measure as well.

paul-
2017-04-10, 09:03
Unfortunately it is still displaying pinyin instead of asian characters. The extension is showing as installed and the pi was rebooted for good measure as well.

Can you check the LMS logs to make sure it is finding the perl libraries ok. Perhaps there is something else needed.

gadgetwiz
2017-04-10, 15:36
This is from the log on startup:

[17-04-11 08:21:33.9669] main::init (388) Starting Logitech Media Server (v7.9.0, 1488878280, Wed Mar 8 14:07:50 UTC 2017) perl 5.024000 - arm-linux-gnueabihf-thread-multi-64int

Is this working correctly?

Edit: Not sure if this is helpful but I note from my jessie lite installation that LMS will fail to pick up the new perl freetype font if the original font in the LMS install is still present?

mherger
2017-04-10, 21:38
> [17-04-11 08:21:33.9669] main::init (388) Starting Logitech Media Server
> (v7.9.0, 1488878280, Wed Mar 8 14:07:50 UTC 2017) perl 5.024000 -
> arm-linux-gnueabihf-thread-multi-64int

Paul - could there be a timing problem? The extension being initialized
after LMS or something?

--

Michael

mherger
2017-04-10, 21:43
> This is from the log on startup:

Please add debug logging for player.fonts (Settings/Advanced/Logging),
check the "keep settings for restart" (or similar) box at the top of
that page, restart LMS. Then check the server.log again.

--

Michael

gadgetwiz
2017-04-11, 02:09
Got it - here is the log.

[17-04-11 18:57:08.9182] main::init (388) Starting Logitech Media Server (v7.9.0, 1488878280, Wed Mar 8 14:07:50 UTC 2017) perl 5.024000 - arm-linux-gnueabihf-thread-multi-64int
[17-04-11 19:01:19.2145] main::init (388) Starting Logitech Media Server (v7.9.0, 1488878280, Wed Mar 8 14:07:50 UTC 2017) perl 5.024000 - arm-linux-gnueabihf-thread-multi-64int
[17-04-11 19:01:44.5378] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/threeline.3.font.bmp
[17-04-11 19:01:44.5469] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/threeline.2.font.bmp
[17-04-11 19:01:44.5551] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/threeline.1.font.bmp
[17-04-11 19:01:44.5641] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/standard_n.2.font.bmp
[17-04-11 19:01:44.5723] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/standard_n.1.font.bmp
[17-04-11 19:01:44.5817] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/standard.2.font.bmp
[17-04-11 19:01:44.5901] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/standard.1.font.bmp
[17-04-11 19:01:44.5982] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/small.2.font.bmp
[17-04-11 19:01:44.6070] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/small.1.font.bmp
[17-04-11 19:01:44.6155] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/medium.2.font.bmp
[17-04-11 19:01:44.6255] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/medium.1.font.bmp
[17-04-11 19:01:44.6341] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/logoSB2.2.font.bmp
[17-04-11 19:01:44.6537] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/logo.font.bmp
[17-04-11 19:01:44.6628] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/light_n.2.font.bmp
[17-04-11 19:01:44.6712] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/light_n.1.font.bmp
[17-04-11 19:01:44.6806] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/light.2.font.bmp
[17-04-11 19:01:44.6889] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/light.1.font.bmp
[17-04-11 19:01:44.6973] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/large.2.font.bmp
[17-04-11 19:01:44.7064] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/huge.2.font.bmp
[17-04-11 19:01:44.7145] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/high.2.font.bmp
[17-04-11 19:01:44.7267] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/full_n.2.font.bmp
[17-04-11 19:01:44.7349] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/full.2.font.bmp
[17-04-11 19:01:44.7477] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/blockanimateSBG.1.font.bmp
[17-04-11 19:01:44.7560] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/blockanimateSB2.1.font.bmp
[17-04-11 19:01:45.8837] Slim::Display::Lib::Fonts::fontfiles (598) prebuild cache is valid
[17-04-11 19:01:45.8890] Slim::Display::Lib::Fonts::loadFonts (624) Retrieving font data from font cache: /usr/local/slimserver/Graphics/corefonts.bin

mherger
2017-04-11, 02:20
By the time you posted this log snippet, did you try to display one of the Japanese/Chinese items? The font would only be loaded once required.

gadgetwiz
2017-04-11, 03:01
Ah no. Here is the updated log.

[17-04-11 19:58:27.0459] main::init (388) Starting Logitech Media Server (v7.9.0, 1488878280, Wed Mar 8 14:07:50 UTC 2017) perl 5.024000 - arm-linux-gnueabihf-thread-multi-64int
[17-04-11 19:58:48.5395] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/threeline.3.font.bmp
[17-04-11 19:58:48.5473] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/threeline.2.font.bmp
[17-04-11 19:58:48.5552] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/threeline.1.font.bmp
[17-04-11 19:58:48.5629] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/standard_n.2.font.bmp
[17-04-11 19:58:48.5705] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/standard_n.1.font.bmp
[17-04-11 19:58:48.5782] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/standard.2.font.bmp
[17-04-11 19:58:48.5860] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/standard.1.font.bmp
[17-04-11 19:58:48.5944] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/small.2.font.bmp
[17-04-11 19:58:48.6026] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/small.1.font.bmp
[17-04-11 19:58:48.6106] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/medium.2.font.bmp
[17-04-11 19:58:48.6184] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/medium.1.font.bmp
[17-04-11 19:58:48.6262] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/logoSB2.2.font.bmp
[17-04-11 19:58:48.6339] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/logo.font.bmp
[17-04-11 19:58:48.6417] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/light_n.2.font.bmp
[17-04-11 19:58:48.6494] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/light_n.1.font.bmp
[17-04-11 19:58:48.6579] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/light.2.font.bmp
[17-04-11 19:58:48.6657] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/light.1.font.bmp
[17-04-11 19:58:48.6734] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/large.2.font.bmp
[17-04-11 19:58:48.6811] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/huge.2.font.bmp
[17-04-11 19:58:48.6889] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/high.2.font.bmp
[17-04-11 19:58:48.6966] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/full_n.2.font.bmp
[17-04-11 19:58:48.7047] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/full.2.font.bmp
[17-04-11 19:58:48.7150] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/blockanimateSBG.1.font.bmp
[17-04-11 19:58:48.7228] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/blockanimateSB2.1.font.bmp
[17-04-11 19:58:50.3345] Slim::Display::Lib::Fonts::fontfiles (598) prebuild cache is valid
[17-04-11 19:58:50.3403] Slim::Display::Lib::Fonts::loadFonts (624) Retrieving font data from font cache: /usr/local/slimserver/Graphics/corefonts.bin
[17-04-11 19:59:53.8746] Slim::Display::Lib::Fonts::__ANON__ (83) Loading Font::FreeType
[17-04-11 19:59:53.9512] Slim::Display::Lib::Fonts::__ANON__ (85) Warning: Unable to load TrueType font support: Font::FreeType object version 0.07 does not match $Font::FreeType::VERSION 0.03 at /usr/local/lib/perl5/5.24.0/arm-linux-gnueabihf-thread-multi-64int/DynaLoader.pm line 210.
Compilation failed in require at /usr/local/slimserver/Slim/Display/Lib/Fonts.pm line 84.

mherger
2017-04-11, 04:52
> [17-04-11 19:59:53.8746] Slim::Display::Lib::Fonts::__ANON__ (83)
> Loading Font::FreeType
> [17-04-11 19:59:53.9512] Slim::Display::Lib::Fonts::__ANON__ (85)
> Warning: Unable to load TrueType font support: Font::FreeType object
> version 0.07 does not match $Font::FreeType::VERSION 0.03 at
> /usr/local/lib/perl5/5.24.0/arm-linux-gnueabihf-thread-multi-64int/DynaLoader.pm
> line 210.
> Compilation failed in require at
> /usr/local/slimserver/Slim/Display/Lib/Fonts.pm line 84.

Ok, this is the crucial part: LMS is loading the pure Perl part of
Front::FreeType from its own folders, while the binary part is provided
by Paul's extension. Unfortunately the version numbers of these two
don't match...

Paul - you could remove CPAN/Font from LMS' installation folder when LMS
is being installed. That should work around this issue.

(And I actually believe those files shouldn't even be part of the noCPAN
bundle, as it doesn't make sense to only ship part of a module...)

--

Michael

paul-
2017-04-11, 06:35
Remove these files?



usr/local/slimserver/CPAN/Font/FreeType/Glyph.pm
usr/local/slimserver/CPAN/Font/FreeType/Face.pm
usr/local/slimserver/CPAN/Font/FreeType.pm


Should I move all of the files under CPAN over to the slimserver-CPAN.tcz extension. Even though I named the extension slimserver-CPAN, I only put files that were generated by slimserver-vendor build script in this extension.

mherger
2017-04-11, 06:55
> Remove these files?

Yes.

> Should I move all of the files under CPAN over to the
> slimserver-CPAN.tcz extension. Even though I named the extension
> slimserver-CPAN, I only put files that were generated by
> slimserver-vendor build script in this extension.

Well... the "noCPAN" label is a bit misleading, as only the binary parts
of the CPAN folder would be stripped. As I said I think we should not
include the Perl parts of those modules requiring some binary in the
noCPAN tarballs.

But for now I'd suggest you remove only what conflicts.

--

Michael

paul-
2017-04-11, 08:36
Gadgetwiz,

As a test, do this.

1) Stop LMS from the web page
2) Open an ssh session and login
3) sudo rm -rf /usr/local/slimserver/CPAN/Font
4) Restart LMS

That change will not survive a reboot, but will verify if anything else is needed before I repackage.

Thanks
Paul

gadgetwiz
2017-04-11, 15:11
Hi Paul, first off, appreciate the effort!

Here is the fresh log. And I can confirm correct display of Asian characters on the SB3 as a result.

[17-04-12 08:04:11.0437] main::init (388) Starting Logitech Media Server (v7.9.0, 1488878280, Wed Mar 8 14:07:50 UTC 2017) perl 5.024000 - arm-linux-gnueabihf-thread-multi-64int
[17-04-12 08:04:32.2211] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/threeline.3.font.bmp
[17-04-12 08:04:32.2313] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/threeline.2.font.bmp
[17-04-12 08:04:32.2398] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/threeline.1.font.bmp
[17-04-12 08:04:32.2478] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/standard_n.2.font.bmp
[17-04-12 08:04:32.2559] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/standard_n.1.font.bmp
[17-04-12 08:04:32.2637] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/standard.2.font.bmp
[17-04-12 08:04:32.2717] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/standard.1.font.bmp
[17-04-12 08:04:32.2804] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/small.2.font.bmp
[17-04-12 08:04:32.2884] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/small.1.font.bmp
[17-04-12 08:04:32.2964] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/medium.2.font.bmp
[17-04-12 08:04:32.3043] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/medium.1.font.bmp
[17-04-12 08:04:32.3123] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/logoSB2.2.font.bmp
[17-04-12 08:04:32.3203] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/logo.font.bmp
[17-04-12 08:04:32.3289] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/light_n.2.font.bmp
[17-04-12 08:04:32.3377] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/light_n.1.font.bmp
[17-04-12 08:04:32.3457] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/light.2.font.bmp
[17-04-12 08:04:32.3536] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/light.1.font.bmp
[17-04-12 08:04:32.3616] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/large.2.font.bmp
[17-04-12 08:04:32.3696] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/huge.2.font.bmp
[17-04-12 08:04:32.3779] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/high.2.font.bmp
[17-04-12 08:04:32.3859] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/full_n.2.font.bmp
[17-04-12 08:04:32.3938] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/full.2.font.bmp
[17-04-12 08:04:32.4044] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/blockanimateSBG.1.font.bmp
[17-04-12 08:04:32.4124] Slim::Display::Lib::Fonts::fontfiles (579) found: /usr/local/slimserver/Graphics/blockanimateSB2.1.font.bmp
[17-04-12 08:04:34.0518] Slim::Display::Lib::Fonts::fontfiles (598) prebuild cache is valid
[17-04-12 08:04:34.0575] Slim::Display::Lib::Fonts::loadFonts (624) Retrieving font data from font cache: /usr/local/slimserver/Graphics/corefonts.bin
[17-04-12 08:08:23.8493] Slim::Display::Lib::Fonts::__ANON__ (83) Loading Font::FreeType

paul-
2017-04-11, 19:27
slimserver.tcz has been updated on the repo. You will either need to remove LMS from pCP then reinstall.

or perform a manual update like this.

If you open an ssh session and do the following.



tc@piCorePlayer:~$ mkdir /mnt/mmcblk0p2/tce/optional/upgrade
tc@piCorePlayer:~$ cd /mnt/mmcblk0p2/tce/optional/upgrade
tc@piCorePlayer:~$ wget http://picoreplayer.sourceforge.net/tcz_repo/8.x/armv6/tcz/slimserver.tcz
Connecting to picoreplayer.sourceforge.net (216.34.181.96:80)
slimserver.tcz 100% |************************************************* ************************************************** *| 0:00:00 ETA
tc@piCorePlayer:~$ wget http://picoreplayer.sourceforge.net/tcz_repo/8.x/armv6/tcz/slimserver.tcz.md5.txt
Connecting to picoreplayer.sourceforge.net (216.34.181.96:80)
slimserver.tcz. 100% |************************************************* ************************************************** *| 0:00:00 ETA
tc@piCorePlayer:/mnt/mmcblk0p2/tce/optional/upgrade$ md5sum -c slimserver.tcz.md5.txt
slimserver.tcz: OK
tc@piCorePlayer:/mnt/mmcblk0p2/tce/optional/upgrade$


as long as you get an OK on the md5sum check, then you can reboot, and your system will use the new extension

gadgetwiz
2017-04-12, 03:42
Updated LMS as per instructions and all is good. Thank you very much for this - will be making a donation shortly!

ply3908
2018-05-18, 16:02
I just did LMS update on piCore. The display problem is back again. Delete the /usr/local/slimserver/CPAN/Font directory and restart LMS will fix it temporary.

paul-
2018-05-18, 19:15
the update process pulls directly from Logitech servers. So it gets re-added. What version did you update to?

I've updated the update script to handle this folder. Whenever the next update happens, it will resolve this.

ply3908
2018-05-18, 20:36
Thanks for your quick support. I just did a "LMS Update" from the LMS tab. I don't have the version number now since I reverted LMS manually by using your instructions in post #24. All is well now.

paul-
2018-05-18, 20:39
Thanks for your quick support. I just did a "LMS Update" from the LMS tab. I don't have the version number now since I reverted LMS manually by using your instructions in post #24. All is well now.

Good to hear, I just updated that package too. Check your information screen in LMS, it should show

Logitech Media Server Version: 7.9.2 - 1524841547 @ Thu May 3 15:16:48 CEST 2018

ply3908
2018-05-18, 21:55
Thanks. Removed and re-install LMS and get the new version now.