PDA

View Full Version : [Howto] build LMS for aarch64



Roland0
2017-04-02, 10:07
While installing LMS on a Raspberry Pi3 64bit, I noticed some build failures even with the newest versions of some 3rd party libraries due to the lack of support for this architecture.
I've attached a build script including fixes for these.
To build LMS, follow these instructions (http://forums.slimdevices.com/showthread.php?107040-Howto-update-perl-modules-bundled-with-LMS), substituting the new script for the old buildme.sh.
Also, download libpng-1.6.29.tar.gz instead of libpng-1.6.28.tar.gz

The server has been running for a couple of days without issues, I'd expect this to work on similar platforms (Odroid etc.) as well.