PDA

View Full Version : Protocol handler not working



BertdeJong
2017-02-14, 06:39
I can't get the protocol handler to serve my PiCore Player and Radio, works fine on Touch.
I have activated my account (Family, but let's have one account run first) in both msb.com and protocol handler on the server (a Windows 2012 Essentials server) added Spotifyd to the firewall. The application does not show on the Picore Player. It does show on te radio but I can't start it.

With my Touch everything runs fine, and I can even use Search now.
My PiCore Player and Radio are not so lucky. The Triode Plugin was more limited, but worked fine and could be managed from my android phone. I don't see haw I can manage my player playing Spotify from my Android phone, since it can not operate Mysqueezebox.com from any of the apps that I know of.

What could be wrong? How can I make the protocol handler plugin run on my Radio and PiCore Player? Your help is much appreciated

mherger
2017-02-14, 07:16
> I can't get the protocol handler to serve my PiCore Player and Radio,
> works fine on Touch.

Is your Touch connected to the same LMS as the other players?

--

Michael

BertdeJong
2017-02-14, 07:54
> I can't get the protocol handler to serve my PiCore Player and Radio,
> works fine on Touch.

Is your Touch connected to the same LMS as the other players?

--

Michael

Yes I have only one LMS.

Kind regards,

Bert

mherger
2017-02-14, 08:10
> Yes I have only one LMS.

And it's not connected to mysb.com either? Can you post your server.log
file?

--

Michael

BertdeJong
2017-02-14, 13:44
> Yes I have only one LMS.

And it's not connected to mysb.com either? Can you post your server.log
file?

--

Michael

I would love to, but simply pasting her will not work. How do I post the log file?

It tells me I should enable the official plugin. It says about the same on the Radio display.

I have the official plugin enabled on mysqueezebox.com. Am i forgetting something? Yesssssssss, I was. I forgot to enable it in the plugin console, silly me.

Appears to be solved now

Kind regards,

Bert

mherger
2017-02-14, 22:08
> I would love to, but simply pasting her will not work. How do I post the
> log file?

https://www.dropbox.com/request/T3RctyzGgNg0oFDubq6a

And you can confirm the Touch is not connected to mysb.com?


--

Michael

karlek
2017-02-14, 23:09
He solved it, as his edit says.
TE forgot to activate the Plugin for his other SBen.

BertdeJong
2017-02-15, 10:55
Now almost everything works. The Spotify app now works in my Touch and my PiCore Player. But still not in my Radio. I suspect that it has something to do with the fact that the Radio does not show up in mysqueezebox.com. All My Players do show up, even my PicorePlayer, but not my Radio. Do I need to do the setup of my Radio again so I can connect it with mysqueezebox.com?

Kind regards,

Bert

karlek
2017-02-15, 11:28
Is this a second hand radio? Then the former owner forgot to delete it from his own mysbc account.

BertdeJong
2017-02-15, 14:00
Is this a second hand radio? Then the former owner forgot to delete it from his own mysbc account.

Correct, I now have done a reset (restore factory settings) and it gave me the opportunity to change to my own account.

And now everything works!!!!!! jayyyyy!