PDA

View Full Version : Squeezebox with LMS 7.9 - Internetradio not working



bigcookie
2017-01-17, 13:24
Hello,

since a few days (and longer), my internet radio (tunein) doesnt work anymore. I can select a station and the UI looks like playing, but no sound at all is coming out of the boxes. The log file doesnt contain any error. Same setup worked previously.
LMS is running on a QNAP NAS (Logitech Media Server Version: 7.9.0 - 1428327734 @ Sun May 10 04:21:09 UTC 2015). Clients are 1 touch, 2 radios and one duet.
Anything else works. I checked the OPML link from tunein, and it delivers a proper m3u link, which I can playback in VLC.

Previously the Squeezebox UI was complaining about a missing Tunein account. This I created now and entered the username in the tunein configuration of the Squeezebox server.
Still no sound.

Any help is appreciated. I am running out of ideas. Server (LMS and NAS) was rebooted/restarted - no help. I didnt reinstall LMS yet, though this might be the last option.

regards,

André

toby10
2017-01-18, 00:33
Try a router reboot? LMS reboot by itself (sounds like you did)? Try switching a player directly to MySB.com (no LMS)? Try a non-TuneIn station/service?
You don't need a TuneIn account to play stations within Internet Radio menus (even though this is also TuneIn).

bigcookie
2017-01-18, 02:35
Hello toby,

thanks for the hint. I will try to switch to mysb.com on one player - though it would only tell me if I have problems with the local installation. I hoped, that I might not be the only one, but it seems that I am - so I will try.
Router reboot should not be a problem, as I can clearly play the OPML URL and it is received by LMS (shows up in the web UI menu).

Tunein is the only problem I do have in the network. will try other services now as well.

I found three suspicious (always repeating lines) in the server.log when trying to playback a TuneIn station:
[17-01-17 20:49:25.3403] Slim::Utils::Misc::msg (1220) Warning: [20:49:25.3378] Argument "" isn't numeric in addition (+) at /share/MD0_DATA/.qpkg/LogitechMediaServer/var/home/SqueezeboxServer/HTML/Default/xmlbrowser.html line 463.
[17-01-17 20:49:25.3514] Slim::Utils::Misc::msg (1220) Warning: [20:49:25.3490] Argument "" isn't numeric in addition (+) at /share/MD0_DATA/.qpkg/LogitechMediaServer/var/home/SqueezeboxServer/HTML/Default/xmlbrowser.html line 463.
[17-01-17 20:49:25.3625] Slim::Utils::Misc::msg (1220) Warning: [20:49:25.3600] Argument "" isn't numeric in addition (+) at /share/MD0_DATA/.qpkg/LogitechMediaServer/var/home/SqueezeboxServer/HTML/Default/xmlbrowser.html line 191.


Also what was suspicious was the note in the players UI that a TuneIn account is missing. Probably that goes in the direction that I have problems mit mysb.com (I am still logged in with the Mysb account).

Next steps:
- will try router reboot
- will try one player to use mysb.com only
- will try removing the mysb.com account

Any hint regarding the warning in the log file is again appreciated.

Thanks, Andre

Man in a van
2017-01-18, 04:44
Andre, try also, if it is possible, running an instance of LMS on a computer and see if you have the same problem.

Lots of us who previously ran LMS on a Qnap have now switched to a rpi3 and use the Nas as a file server.

Ronnie

bigcookie
2017-01-18, 11:30
Tanks for the advices, but RPi is not a target for me, though I use them for different purposes. I just wandered, why Radio stopped working. Weirdly, I hit "Connect to MSB.com" on a radio. Nothing happened in the UI, but now Radio is playing and local music as well. Nevertheless MSB.com still shows non of the players as connected... I think I will reinstall LMS sooner or later with the latest 7.9.

Until now I never had problems with LMS on QNAP. RPi is not a goal as more devices are not my target, though I know it is an option (last resort for me).

Anyway, it seems now to be working, but one issue: the image of the radio stream is not appearing on my touch and radio, BUT it shows up in the web interface of the LMS. Everything very strange.

I guess I will save the settings for LMS (prefs) and re-install and then redo the settings manually (in case something is messed up in the configuration file).

I do have now a workaround, but I dont know how stable this is. Further hints for debugging are still welcome, but in general the system works now.

Thanks for the help

toby10
2017-01-18, 11:39
.... Nevertheless MSB.com still shows non of the players as connected...

That is normal and expected. Your players are connected to LMS so MySB.com is correctly showing those players as "not connected". If you actually switched the players to MySB.com (no LMS) they would show as "connected".

bigcookie
2017-01-18, 11:46
Latest news:
As it seems the workaround effect got lost on LMS restart. Trying again didnt work. It seems like a configuration issue or corruption on LMS side on QNAP NAS. I will try a re-installation.

@Tobi:
Then I dont understand what "Umschalten auf MSB.com" in the player menu does... and then radio worked. Anyway, it seems that the installation is somehow corrupted. Would have loved to get around the new installation, but i will simply do this. Will be faster than further debugging. Thanks again.

toby10
2017-01-18, 14:29
..... Then I dont understand what "Umschalten auf MSB.com" in the player menu does....

It does what it says, switches player to MySB.com (and removes player from LMS), *if* LMS is functioning correctly. Turn off LMS computer, now select the "switch to MySB.com". If it still won't switch try a player reboot, then select MySB.com.

Mnyb
2017-01-18, 20:06
In your LMS setting are your my squeezebox.com credentials correct when the qnap is running try to,restart LMS only .

bigcookie
2017-01-19, 02:28
Thanks to all. I tried to switch to MySB.com while LMS was running. The screen flickered, radio worked (in the beginning) and MySB.com didnt show a connected player.
It seems, that something was really going wrong. Ah, and yes, MySB credentials are correct.

I uninstalled LMS and SSOTS completely and reinstalled everything (including the Plugin patch for 7.9 and upgrade to latest 7.9 version). Settings have not been saved and replaced, I simply set everything in the UI. Over night the music collection was rescanned.
-> Radio playback works now
-> Radio Artwork works now

Seems to have been a corruption on NAS side.