PDA

View Full Version : Spotify configuration - first time setup & having problems



sparkle999
2016-12-18, 06:31
Hi, didnt want to hijack the other post regarding spotify problems, current setup as follows, using a rather old Thecus NAS box (N5200 Pro):-


Logitech Media Server Version: 7.8.0 - 1384496306 @ Fri Nov 15 19:18:59 PST 2013
Hostname: MILHOUSE
Server IP Address: 192.168.1.201
Server HTTP Port Number: 9000
Operating system: linux - EN - iso-8859-1
Platform Architecture: i686-linux
Perl Version: 5.12.2 - i686-linux-thread-multi
Database Version: DBD::SQLite 1.34_01 (sqlite 3.7.7.1)
Total Players Recognized: 3

Have
- installed Spotify app via mysqueezebox.com
- signed up to a premium spotify trial
- installed logitech spotify plugin on my LMS
- installed spotify protocol handler v1.1.1 (triode/m herger)
- entered config settings in the protocol handler so it has my userid/password
- rebooted

Been unable to stream from my SB3, so enabled debug and log as follows (have removed user id):-



[13:18:44.517172] main:448 /raid/data/module/SQUEEZEBOXSERVER/system/SlimCache/InstalledPlugins/Plugins/SpotifyProtocolHandler/Bin/i386-linux/spotifydnoflac10 2.3.8 started ( libspotify: 10.1.16.g7a6bc7ea Release Linux-i686 )
[13:18:44.517361] main:478 Config: username: sparkle998 cachedir: /raid/data/module/SQUEEZEBOXSERVER/system/SlimCache/spotifycache bitrate: 320 volnorm: 0 httpport: 9005 cliport: 9090 cacheaudio: 1
[13:18:45.515430] main:567 new connection
[13:18:45.515515] main:677 attempting login for user: xxxxxxxxxx
[13:18:45.515576] log_message:81 log: 13:18:45.515 I [offline_authorizer.cpp:289] Unable to login offline: no such user
[13:18:45.518104] log_message:81 log: 13:18:45.518 I [ap:1766] Connecting to AP ap.spotify.com:4070
[13:18:45.544125] log_message:81 log: 13:18:45.544 I [ap:1224] Connected to AP: 193.235.232.5:4070
[13:18:45.641840] log_message:81 log: 13:18:45.641 E [ap:4097] Connection error: 115
[13:18:45.641915] log_message:81 log: 13:18:45.641 I [ap:1766] Connecting to AP ap.spotify.com:443
[13:18:45.641987] log_message:81 log: 13:18:45.641 E [ap:4097] Connection error: 116
[13:18:45.642039] log_message:81 log: 13:18:45.642 I [ap:1766] Connecting to AP ap.spotify.com:80
[13:18:45.642067] log_message:81 log: 13:18:45.642 E [ap:4097] Connection error: 116
[13:18:45.642099] log_message:81 log: 13:18:45.642 I [ap:1766] Connecting to AP ap.spotify.com:4070
[13:18:45.642131] log_message:81 log: 13:18:45.642 E [ap:1704] AP Socket Error: Timeout reached (20000)
[13:18:45.658491] log_message:81 log: 13:18:45.658 E [ap:4097] Connection error: 117
[13:18:45.658527] log_message:81 log: 13:18:45.658 I [ap:1766] Connecting to AP ap.spotify.com:443
[13:18:45.658554] log_message:81 log: 13:18:45.658 E [ap:1704] AP Socket Error: Timeout reached (20000)
[13:18:45.658578] log_message:81 log: 13:18:45.658 E [ap:4097] Connection error: 117
[13:18:45.658608] log_message:81 log: 13:18:45.658 I [ap:1766] Connecting to AP ap.spotify.com:80
[13:18:45.658691] log_message:81 log: 13:18:45.658 E [ap:1704] AP Socket Error: Timeout reached (20000)
[13:18:45.658716] log_message:81 log: 13:18:45.658 E [ap:4097] Connection error: 117
[13:18:45.659266] log_message:81 log: 13:18:45.659 I [ap:1766] Connecting to AP ap.spotify.com:4070
[13:18:45.659295] log_message:81 log: 13:18:45.659 E [ap:1704] AP Socket Error: Timeout reached (20000)
[13:18:45.659319] log_message:81 log: 13:18:45.659 E [ap:4097] Connection error: 117
[13:18:46.537211] logged_in:51 logged in error: Can not connect to Spotify
[13:18:46.568450] connection_error:66 connection error: Can not connect to Spotify
[13:18:46.568587] log_message:81 log: 13:18:46.568 I [offline-mgr:2090] 0 files are locked. 0 images are locked
[13:18:46.568613] log_message:81 log: 13:18:46.568 I [offline-mgr:2116] 0 files unlocked. 0 images unlocked


Do I conclude it's a firewall problem? Any pointers appreciated
Cheers
Nige

sparkle999
2016-12-18, 07:45
Haven't made any significant progress
- established doesn't play from LMS
- also doesn't play from mysqueezebox.com

latest summary in settings window following another reboot as follows:



Helper App: Running
Not logged in to Spotify
Login Error: No error
Last Error: No error


Debug log as follows:


[14:34:43.590804] main:448 /raid/data/module/SQUEEZEBOXSERVER/system/SlimCache/InstalledPlugins/Plugins/SpotifyProtocolHandler/Bin/i386-linux/spotifydnoflac10 2.3.8 started ( libspotify: 10.1.16.g7a6bc7ea Release Linux-i686 )
[14:34:43.609795] main:478 Config: username: xxxxxxxxxx cachedir: /raid/data/module/SQUEEZEBOXSERVER/system/SlimCache/spotifycache bitrate: 320 volnorm: 0 httpport: 9005 cliport: 9090 cacheaudio: 1
[14:38:17.197963] main:567 new connection
[14:38:17.198063] main:619 req: status.json res: (null) par: (null) prot: HTTP/1.0 auth: (null)
[14:38:17.198091] process_status:1464 process status


In spotify config the following apps are enabled (not sure what middle one is, but probs nothing to do with this problem):


Spotify for Squeezebox
Lithium Community - Production
support.spotify.com login

pablolie
2016-12-18, 09:46
Which players do you have? Only Touch and Radio support Spotify (unless you enable an additional plug in). Make also sure you're not synching players for now.

Buddy0611
2016-12-18, 11:16
I have a standard SB Touch in regular WLAN and my premium Spotify connention runs via mysqueezebox.com. Everything simple. The squeezebox is buffering every few seconds so that no Song runs. This is only with Spotify. Not with the Radio and not with Podcasts. Spotify runs also well on all other Hardware.


Gesendet von iPad mit Tapatalk

sparkle999
2016-12-18, 12:31
Which players do you have? Only Touch and Radio support Spotify (unless you enable an additional plug in). Make also sure you're not synching players for now.

Thanks for the reply. I have a couple of SB3's - the classic squeezebox player, preceded the SB Touch. I thought that these devices could be made to work through the use of the Spotify Protocol Handler plugin, which per my original post, I've installed and configured with spotify user & password. Can you confirm this is the additional plugin that you are referring to?

I also have some SB Radios, however have not looked at those yet, all my activity so far has been via the LMS web interface, mysqueezebox.com and the SB3 which I have been using to test if it works or not.

Am not synching players.

pablolie
2016-12-18, 12:50
Yes, the Protocol plugin by Triode and M Herger is what it takes. Note you have to enter user info again.

It does work with my config -see sig- on SB Boom (which have the same limitations as SB3). On the stable release it would have issues with some regularity (never found out why).

I seem to remember it took an LMS service restart or two to get it to work.

mherger
2016-12-18, 14:32
> Have
> - installed Spotify app via mysqueezebox.com
> - signed up to a premium spotify trial
> - installed logitech spotify plugin on my LMS
> - installed spotify protocol handler v1.1.1 (triode/m herger)
> - entered config settings in the protocol handler so it has my
> userid/password
> - rebooted

Did you enter the Spotify credentials on mysb.com, too? You'd even have
to enter them, then go through the authorization flow again.

--

Michael

mherger
2016-12-18, 14:33
> Helper App: Running
> Not logged in to Spotify

Not logged in. You might need to enter your credentials for the Protocol
Handler once more.


--

Michael

sparkle999
2016-12-18, 15:56
Did you enter the Spotify credentials on mysb.com, too? You'd even have
to enter them, then go through the authorization flow again.




Not logged in. You might need to enter your credentials for the Protocol
Handler once more.


Thanks for taking the time to help Michael, appreciated.

Yes, when I configured mysb.com I entered the spotify credentials and went through the auth process.
To be sure, I've deleted and redone it, re-authorised, then went through the config with the protocol handler again too.
I've rebooted the server, status in the protocol handler still as follows:



Helper App: Running
Not logged in to Spotify
Login Error: No error
Last Error: No error


Log file with debug mode on as follows:



[22:27:09.646193] main:448 /raid/data/module/SQUEEZEBOXSERVER/system/SlimCache/InstalledPlugins/Plugins/SpotifyProtocolHandler/Bin/i386-linux/spotifydnoflac10 2.3.8 started ( libspotify: 10.1.16.g7a6bc7ea Release Linux-i686 )
[22:27:09.664630] main:478 Config: username: xxxxxxxx cachedir: /raid/data/module/SQUEEZEBOXSERVER/system/SlimCache/spotifycache bitrate: 320 volnorm: 0 httpport: 9005 cliport: 9090 cacheaudio: 1
[22:35:06.012007] main:567 new connection
[22:35:06.012095] main:619 req: status.json res: (null) par: (null) prot: HTTP/1.0 auth: (null)
[22:35:06.012123] process_status:1464 process status



Log file from media server isn't happy...


[16-12-18 22:24:27.0424] Plugins::SpotifyProtocolHandler::Settings::__ANON_ _ (223) failed to set password
[16-12-18 22:24:57.3872] Slim::Utils::Timers::__ANON__ (273) Error: Timer Slim::Networking::Async::_async_error failed: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /raid0/data/module/SQUEEZEBOXSERVER/squeezeboxserver/Slim/Networking/IO/Select.pm line 150.


Not sure if I'm going to be able to get this working, I know the Thecus box is a bit of pain, maybe something to do with that perhaps. Anyhow if anything obvious springs to mind, please let me know
Cheers
Nige

pablolie
2016-12-18, 20:05
What Linux version is your box running? Honestly I'd move to 7.9, it's super stable (and I have never upgraded from the first version), seems to support Spotify very well.

sparkle999
2016-12-19, 04:12
Hi pablolie, thanks for your advice, appreciated.

I'm on v7.8 of the software, AFAIK v7.9 has not been packaged up as a module for the N5200 Pro, so I'm a bit stuck on that front. I've dropped a note to iletunic who may give me a hand, although he may have moved on with his setup by now.

In terms of the linux version, info as follows:-



root@127.0.0.1:/etc# uname -a
Linux MILHOUSE 2.6.13N5200 #135 Thu Mar 12 15:24:22 CST 2009 i686 unknown




root@127.0.0.1:/etc# cat /proc/version
Linux version 2.6.13N5200 (root@WIG_devel) (gcc version 3.3.6) #135 Thu Mar 12 15:24:22 CST 2009

sparkle999
2016-12-19, 16:18
Ivica kindly replied, he has moved away from the Thecus box, so is unable to support the packaging of new modules for the NAS box. I was grateful for his support whilst it was there :)
I'll be on the current version for now then, so if that turns out to be the root cause then I'll have to accept temporary defeat.

pablolie
2016-12-19, 21:25
Sorry - but honestly the hardware requirements for an LMS server are so low it can be scored for free, more or less.

I just support it on a VM that runs on the side... it's totally free and I can move it anywhere and anytime I please... Spotify has run like a charm since I did that.

d6jg
2016-12-22, 14:14
Ivica kindly replied, he has moved away from the Thecus box, so is unable to support the packaging of new modules for the NAS box. I was grateful for his support whilst it was there :)
I'll be on the current version for now then, so if that turns out to be the root cause then I'll have to accept temporary defeat.

Consider running LMS on a Pi but keep your music files on the NAS. It resolves the issue completely.

budjer
2017-02-07, 06:03
Hello Sparkle999,

I am using a Thecus N3200PRO together with the latest LMS 7.9 nightlies with no issues.

As a framework I installed once the module from Ivica many years ago. But I am updating the binaries manually. This works like charm now for many years...


Best regards

André

stop-spinning
2017-02-08, 13:12
There are many Spotify plugins for LMS now, I've only loaded Triodes version (no protocol handlers etc) - this single and only install seems OK - but is this the optimised installation for LMS?

I ask because it works - but playlists are slow to load in Spotify.

Thanks all.

mherger
2017-02-11, 22:19
> I ask because it works - but playlists are slow to load in Spotify.

If you're new to Spotify on LMS then I wouldn't use that plugin any
more. I think the combination of the official plugin with the Spotify
Protocol Handler (if you need playback on players other than Touch and
Radio) is the way to go.

--

Michael

ho_kuku
2017-03-02, 05:07
http://www.theverge.com/2017/3/1/14776780/spotify-hi-fi-preparing-launch-lossless-audio-tier

mherger
2017-03-02, 05:44
> http://www.theverge.com/2017/3/1/14776780/spotify-hi-fi-preparing-launch-lossless-audio-tier

http://forums.slimdevices.com/showthread.php?t=107047

--

Michael

bb1959
2017-03-04, 10:53
I would drop Tidal in a heartbeat if this happened!


> http://www.theverge.com/2017/3/1/14776780/spotify-hi-fi-preparing-launch-lossless-audio-tier

http://forums.slimdevices.com/showthread.php?t=107047

--

Michael