PDA

View Full Version : Auto-detection of full and half-duplex



Christopher Jacob
2004-12-20, 09:04
Perhaps my less than stellar grasp of networking will come into play here
but... It doesn't seem to me that the squeezebox communicates up stream very
often, so when it does have to send a packet or two the data stored in the
buffer should compensate for the downstream blocking...

Now on the other hand, it says its 10/100 full duplex so I guess it should
perform as advertised. I just don't know if you are going to see any
detectable performance increases.

~c

> -----Original Message-----
> From: discuss-bounces (AT) lists (DOT) slimdevices.com [mailto:discuss-
> bounces (AT) lists (DOT) slimdevices.com] On Behalf Of David Brittain
> Sent: Sunday, December 19, 2004 10:17 AM
> To: Slim Devices Discussion
> Subject: [slim] Auto-detection of full and half-duplex
>
> I would be interested in the answer to this too. I have just moved to a
> new switch, and am experiencing regular drop-outs. The switch shows the
> connection to the squeezebox as being half-duplex. I am wondering if
> this might be part of the problem.
>
> Dave
>
> Olav Sunde wrote:
>
> > I have just startet to use my wired Squeezebox - in very nice Triple
> > Platinum colour :>). Easy to set up and every thing is working as
> > expected so far. But looking at the log of my network switch, an HP
> > J4813A, I notice that the switch is negotiating half-duplex with the
> > SB. Also I see some collisions and quite a bit of deferred TX.
> > If I force the switch port to 10Mbps full-duplex the SB clearly does
> > not sense this and the switch reports excessive CRC and alignment
> > errors and various other stuff because of the duplex mismatch. I have
> > checked cables and connectors etc. and moved the SB to other ports
> > with no change. None of the other 12 active ports on the switch show
> > any trouble.
> > The technical specification of the SB states "Auto-detection of full
> > and half-duplex modes" on the ethernet port, but this does not seem to
> > be correct.
> > Anyone else with experience/suggestions here?
> > Can I send a command to the SB via SlimServer or some other way to set
> > the ethernet port to full-duplex?
> >
> > Thanks
> >
> > Olav Sunde
> >
> >