PDA

View Full Version : Clicking the "M" on LMS doesn't work in Tidal



basslover99
2016-03-24, 19:30
If I click the "M" on a cut that's playing on the right in Tidal, the left panel becomes blank. Above, it reads "Home/Tidal Error".

This happens about 95% of the time. Once in a while the information will appear on the left panel.

It's been like this for a long time.

mherger
2016-03-24, 23:41
As you've had this problem for a long time, I'm sure your server.log file is full of related error messages you want to share with us.

basslover99
2016-03-25, 00:06
I just tried clicking the M's again and here are the messages (along with the previous couple). This is beyond my pay grade so please tell me if this is not what you wanted to see.

[16-03-24 12:10:30.8072] Slim::Networking::SqueezeNetwork::_error (596) Unable to login to SN: malformed JSON string, neither array, object, number, string or atom, at character offset 0 (before "<html><head><meta ht...") at /<C:\PROGRA~2\SQUEEZ~1\server\SqueezeSvr.exe>Slim/Networking/SqueezeNetwork.pm line 571.
[16-03-24 12:10:30.8384] Slim::Networking::SqueezeNetwork::_error (596) Unable to login to SN: malformed JSON string, neither array, object, number, string or atom, at character offset 0 (before "<html><head><meta ht...") at /<C:\PROGRA~2\SQUEEZ~1\server\SqueezeSvr.exe>Slim/Networking/SqueezeNetwork.pm line 571.
[16-03-24 12:10:30.8702] Slim::Networking::SqueezeNetwork::_error (596) Unable to login to SN: malformed JSON string, neither array, object, number, string or atom, at character offset 0 (before "<html><head><meta ht...") at /<C:\PROGRA~2\SQUEEZ~1\server\SqueezeSvr.exe>Slim/Networking/SqueezeNetwork.pm line 571.
[16-03-24 19:23:02.5526] Slim::Networking::IO::Select::__ANON__ (147) Error: Select task failed calling Slim::Networking::Async::HTTP::_http_read_body: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /<C:\PROGRA~2\SQUEEZ~1\server\SqueezeSvr.exe>Slim/Networking/IO/Select.pm line 150.
; fh=Slim::Networking::Async::Socket::HTTP=GLOB(0xa5 8fcc4)
[16-03-24 19:23:05.5649] Slim::Networking::IO::Select::__ANON__ (147) Error: Select task failed calling Slim::Networking::Async::HTTP::_http_read_body: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /<C:\PROGRA~2\SQUEEZ~1\server\SqueezeSvr.exe>Slim/Networking/IO/Select.pm line 150.
; fh=Slim::Networking::Async::Socket::HTTP=GLOB(0x7f 7391c)

mherger
2016-03-25, 00:21
> [16-03-24 12:10:30.8072] Slim::Networking::SqueezeNetwork::_error (596)
> Unable to login to SN: malformed JSON string, neither array, object,
> number, string or atom, at character offset 0 (before "<html><head><meta
> ht...") at
> /<C:\PROGRA~2\SQUEEZ~1\server\SqueezeSvr.exe>Slim/Networking/SqueezeNetwork.pm
> line 571.

That seems to be a generic problem accessing mysb.com, not only Tidal
related. Please open the LMS web UI, go to Settings/Advanced/Logging. At
the top there's a dropdown list from which you can select "Internet
Radio" or similar. Three lines further down there's a checkbox to make
the setting stick. Apply. Then restart LMS. Do you Tidal things. Then
grab a copy of the _full_ server.log file (path shown at the top of that
settings page, ZIP file available in LMS 7.9) and drop it to me:

https://www.dropbox.com/request/T3RctyzGgNg0oFDubq6a

Then select the default settings from the dropdown box, check the sticky
box again, apply. Restart LMS. This last step is just to make sure your
server.log file isn't flooded with tons of debug output.
--

Michael