PDA

View Full Version : constant rebuffering on Tidal using Squeezebox but not on desktop



basslover99
2016-01-23, 01:44
Controller firmware is the latest (just updated yesterday).

Receiver firmware also latest (just updated yesterday).

Bridge.

D-Link DIR-655 latest firmware.

I have a fast (100 Mbps) connection. Tidal FLAC's play fine on my desktop. But on Squeezebox there's constant rebuffering during songs when playing Tidal FLAC's. Not all FLAC's, but a lot of them. While the rebuffering is going on, I tried playing the same song on the desktop, and there was no rebuffering there.

What could be causing the rebuffering on the Duet? I was not connected to the PC, but to MySB.com.

Your help is most appreciated!

Thanks!

mherger
2016-01-23, 03:01
> What could be causing the rebuffering on the Duet? I was not connected
> to the PC, but to MySB.com.

Unfortunately those players date back from when 192kbps was high
quality. They have minuscule buffers compared to your computer. I don't
remember the exact numbers, but the Receiver's memory probably can
buffer one or two seconds of flac. While this is ok in a LAN
environment, the internet is relatively unreliable. Even if it can
deliver 100mbps, the player can't consume this amount of data. Therefore
a minor hiccup in the connection can lead to rebuffering.

Using LMS and proxied streaming can considerably reduce this issue.

--

Michael

basslover99
2016-01-25, 02:38
Thanks so much for this clear explanation. I will try what you suggested.

pippin
2016-01-25, 02:56
Michael, are you communicating the player's IP address to TIDAL? Otherwise there also could be peering problems with their CDN. They use a header field for that.
We originally had such issues with ickStream, too.

It's that nasty net neutrality (or lack thereof) issue: backbone peering no longer works for streaming services.

mherger
2016-01-25, 05:21
> Michael, are you communicating the player's IP address to TIDAL?

Streaming always happens between your player or LMS directly. mysb.com
is not involved.

--

Michael

pippin
2016-01-25, 10:48
No, but MySB sits in Ireland or in New York or wherever the US data center is.
And if that's from where you access the API then TIDAL's CDN thinks that's where your player is. MySB does the authentication and URL resolution, doesn't it?
At least that was an issue we originally had.
They had some x-header in the http requests to communicate the real target IP.

I'm not sure they still use that, maybe TIDAL does now check where the actual stream request comes from, they've made a lot of changes to their CDN but originally we had this issue with TIDAL.

basslover99
2016-01-29, 05:06
> Using LMS and proxied streaming can considerably reduce this issue.

Is there a setting for proxied streaming? I can't find it (although I thought I once saw it).

Thanks!

garym
2016-01-29, 06:15
Is there a setting for proxied streaming? I can't find it (although I thought I once saw it).

Thanks!

LMS > SETTINGS > PLAYER tab > Audio, look for "mp3 streaming method" (note the proxied streaming works whether it is mp3 or other format)

basslover99
2016-01-29, 06:20
LMS > SETTINGS > PLAYER tab > Audio, look for "mp3 streaming method" (note the proxied streaming works whether it is mp3 or other format)

Thanks! Is there a way to do proxied streaming when using the remote in MySB.com as opposed to PC?

(Or does this setting in LMS also apply to MySB.com?)

garym
2016-01-29, 06:27
Thanks! Is there a way to do proxied streaming when using the remote in MySB.com as opposed to PC?

(Or does this setting in LMS also apply to MySB.com?)

I don't think so, because I think the proxied streaming is using your LMS on local pc/mac.

mherger
2016-01-29, 06:53
> I don't think so, because I think the proxied streaming is using your
> LMS on local pc/mac.

Correct. Because unless the proxy is in your home, there's no reason to
have one (reliability wise). If things were proxied through mysb.com,
the paths between the buffering proxy and your player would be even
longer than with direct streaming.

--

Michael

basslover99
2016-01-29, 16:56
Thanks for the replies. It's great to be on a forum with such knowledgeable people!