PDA

View Full Version : Sound Opinions Podcast no longer working on Squeezeboxes (running LMS)



garym
2015-10-15, 16:50
For several years I could listen to the podcasts from "Sound Opinions" on my squeezeboxes via the podcast application. I use the following RSS URL for the podcast app.
http://feeds.feedburner.com/TheSoundOpinionsPodcast

It seems something has changed in the last month or so. I can see the shows in my podcast app on the squeezeboxes (all connected to LMS 7.8.0 running on a vortexbox (fedora linux) and select particular episodes. But when trying to play I get a an error message "unable to play file type for [name of podcast episode]. In the server log, I see this message:


[15-10-15 19:25:42.6372] Slim::Player::Song::open (409) Error: Couldn't create command line for mp4 playback for [http://wbez.podcast.streamguys1.com/sound_opinions/audio/515-spooner-oldham-opinions-on-janet-jackson.m4a]

I have the same problem whether playing through Transporter, Boom, or TOUCH. I also have the same problem if I try to play using my Win7 LMS 7.9 as the server. I've also tried connecting my TOUCH to mysqueezebox.com and playing from there and also fails to play.

It seems odd to me that this podcast is reported by LMS in "mp4" format (although the file itself shows as m4a). But I never paid attention in the past. Any thoughts on this. Can anyone else get it to work? Thanks in advance.

ChrisNY
2015-10-15, 20:22
I tried listening through the TuneIn app. Interestingly, I can listen to episodes from 509 backwards. The recent episodes do not seem to play. Wondering if they made some kind of change to the format recently. I am running 7.8.1 on Ubuntu.

-Chris

garym
2015-10-15, 20:30
I tried listening through the TuneIn app. Interestingly, I can listen to episodes from 509 backwards. The recent episodes do not seem to play. Wondering if they made some kind of change to the format recently. I am running 7.8.1 on Ubuntu.

-Chris

Yes, I too think they've made some sort of change. Older episodes I can listen to, but not the newer ones. Thanks for testing..

cybergrimes
2015-10-19, 16:03
All of the episodes appear to be MPEG-4/AAC LC in an M4A container. This is true of every random episode I checked back to episode #1, however, it was not until episode 510 that MediaInfo is showing "Writing application: iTunes 12.3.0.44" I'm surprised you can play the older episodes but not the newer. There must be something else.

Do your servers have LAME/faad installed?

garym
2015-10-19, 16:12
All of the episodes appear to be MPEG-4/AAC LC in an M4A container. This is true of every random episode I checked back to episode #1, however, it was not until episode 510 that MediaInfo is showing "Writing application: iTunes 12.3.0.44" I'm surprised you can play the older episodes but not the newer. There must be something else.

Do your servers have LAME/faad installed?

Yes. Have lame/faad. In rechecking I see now that I can't play any of the episodes, old or new. Thanks for testing. Can you play on your server?

Edit. If I find episodes on soundcloud via ickstream, I can play them. Odd.

cybergrimes
2015-10-19, 17:42
I can't play it either but none of my existing podcast feeds are MPEG-4/AAC. They are all MP3. My server is a Synology NAS, no LAME installed and possibly a very out of date default faad installation. I listened to this a bit earlier and am I am now interested in this podcast though ;)

The difference between SoundCloud and the direct RSS feed might be the audio encapsulation/mime content type of how each site serves the data. Someone uploaded the files to SoundCloud, so it's serving them directly and perhaps differently than the normal RSS feed? Just a guess here.

Episode 516 is hosted as "audio/x-m4a" on the RSS feed. My servers types.conf file has that associated with ID mp4 and suffix m4a. So, I have no idea ;/

garym
2015-10-19, 17:47
I can't play it either but none of my existing podcast feeds are MPEG-4/AAC. They are all MP3. My server is a Synology NAS, no LAME installed and possibly a very out of date default faad installation. I listened to this a bit earlier and am I am now interested in this podcast though ;)

The difference between SoundCloud and the direct RSS feed might be the audio encapsulation/mime content type of how each site serves the data. Someone uploaded the files to SoundCloud, so it's serving them directly and perhaps differently than the normal RSS feed? Just a guess here.

Episode 516 is hosted as "audio/x-m4a" on the RSS feed. My servers types.conf file has that associated with ID mp4 and suffix m4a. So, I have no idea ;/

Thanks for digging through this. By the way, what sort of software/process do you use to examine the underlying detail of the file being streamed.

cybergrimes
2015-10-19, 18:05
I went directly to the stream in the browser and inspected the page elements to find the mime/stream type. I don't know much about it but a couple years ago had problems with another podcast that the mime type settings in the LMS types.conf file was unable to handle. There was a thread here that solved the issue for me, in that instance it was as simple as adding the mime type to the configuration file. Edit: in this instance it appears already in place...

By the way, I'm getting the same error as you in my server log
(409) Error: Couldn't create command line for mp4 playback

garym
2015-10-19, 18:15
I went directly to the stream in the browser and inspected the page elements to find the mime/stream type. I don't know much about it but a couple years ago had problems with another podcast that the mime type settings in the LMS types.conf file was unable to handle. There was a thread here that solved the issue for me, in that instance it was as simple as adding the mime type to the configuration file. Edit: in this instance it appears already in place...

By the way, I'm getting the same error as you in my server log
(409) Error: Couldn't create command line for mp4 playback

Thanks. Odd that I listened regularly to exact same rss podcast stream up until a few episodes ago with no issues. And my lms and server have not changed in the meantime. I'll keep exploring...

bpa
2015-10-20, 02:53
Not sure why your old episodes actually played for you (they don't for me) so I guess you have some sort of mod or different player but an explanation for default LMS.

The MIME type for the episode detailed in OP is audio/x-m4a which si determined by LMS to be mp4. The mp4 rule in convert.conf says it can play these using faad if they are files and not stream (i.e. http)

If you want to play mp4 stream (e.g. mp4 podcast) then faad cannot do it but ffmpeg or avconv can.

For Linux ( not sure about Windows or OSX) the following can be used to create a "custom-convert.conf" file in the same directory convert.conf and it cna play mp4 hhtp podcasts.



mp4 mp3 * *
# FRB:{BITRATE=-B %B}T:{START=-ss %s}
[avconv] -loglevel quiet -f mp4 -i $FILE$ -f wav - | [lame] --silent -q $QUALITY$ $BITRATE$ - -

mp4 pcm * *
# FRB:{BITRATE=-B %B}T:{START=-ss %s}
[avconv] -loglevel quiet -f mp4 -i $FILE$ -f u16le -

mp4 flc * *
# FRB:{BITRATE=-B %B}T:{START=-ss %s}
[avconv] -loglevel quiet -f mp4 $START$ -i $FILE$ -f flac -

garym
2015-10-20, 04:24
Not sure why your old episodes actually played for you (they don't for me) so I guess you have some sort of mod or different player but an explanation for default LMS.

The MIME type for the episode detailed in OP is audio/x-m4a which si determined by LMS to be mp4. The mp4 rule in convert.conf says it can play these using faad if they are files and not stream (i.e. http)

If you want to play mp4 stream (e.g. mp4 podcast) then faad cannot do it but ffmpeg or avconv can.

For Linux ( not sure about Windows or OSX) the following can be used to create a "custom-convert.conf" file in the same directory convert.conf and it cna play mp4 hhtp podcasts.



mp4 mp3 * *
# FRB:{BITRATE=-B %B}T:{START=-ss %s}
[avconv] -loglevel quiet -f mp4 -i $FILE$ -f wav - | [lame] --silent -q $QUALITY$ $BITRATE$ - -

mp4 pcm * *
# FRB:{BITRATE=-B %B}T:{START=-ss %s}
[avconv] -loglevel quiet -f mp4 -i $FILE$ -f u16le -

mp4 flc * *
# FRB:{BITRATE=-B %B}T:{START=-ss %s}
[avconv] -loglevel quiet -f mp4 $START$ -i $FILE$ -f flac -


Thanks. I'll try when I return home. Also, I've never created a custom convert file. I assume I copy the above code in a text file, give it the right file name and put it in the right directory and that's it???

ps. The old episodes don't play for me now. But they used to play.

bpa
2015-10-20, 04:34
Thanks. I'll try when I return home. Also, I've never created a custom convert file. I assume I copy the above code in a text file, give it the right file name and put it in the right directory and that's it???

ps. The old episodes don't play for me now. But they used to play.

Not quite copy - the convert.conf file and custom-convert.conf required the use of tabs which are often lost when pasted into a forum post.

So before the "# FRB" and thr "[avconv]" it is a Tab character and not spaces.

garym
2015-10-20, 04:37
Not quite copy - the convert.conf file and custom-convert.conf required the use of tabs which are often lost when pasted into a forum post.

So before the "# FRB" and thr "[avconv]" it is a Tab character and not spaces.

Got it. Thanks.

garym
2015-10-21, 06:10
Still getting same error

[15-10-21 08:16:57.0275] Slim::Player::Song::open (409) Error: Couldn't create command line for mp4 playback for [http://wbez.podcast.streamguys1.com/sound_opinions/audio/516-twin-peaks-opinions-on-the-dead-weather.m4a]

I used the provided info above in my custom-convert.conf file. I noted that I already had an active "custom-convert.conf" file related to mplayer and 'mov' (I didn't create, but must have been created with my vortexbox install or a plugin install). So I added the new info. Current custom-convert.conf file I'm using is reproduced below (and I used tab not spaces as noted)


wma wav * *
[mplayer] -really-quiet -vc null -vo null -cache 64 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=/dev/fd/4 $FILE$ 4>&1 1>/dev/null
mov flc * *
# F
[faad] -q -w -f 2 $FILE$ | [flac] -cs --totally-silent --compression-level-0 --endian little --sign signed --channels 2 --bps 16 --sample-rate 44100 -
mov mp3 * *
# FB:{BITRATE=-B %B}
[faad] -q -w -f 2 $FILE$ | [lame] --resample 44100 --silent -q $QUALITY$ $BITRATE$ -r - -
mov wav * *
# F
[faad] -q -w -f 2 $FILE$ 2>/dev/null

mp4 mp3 * *
# FRB:{BITRATE=-B %B}T:{START=-ss %s}
[avconv] -loglevel quiet -f mp4 -i $FILE$ -f wav - | [lame] --silent -q $QUALITY$ $BITRATE$ - -

mp4 pcm * *
# FRB:{BITRATE=-B %B}T:{START=-ss %s}
[avconv] -loglevel quiet -f mp4 -i $FILE$ -f u16le -

mp4 flc * *
# FRB:{BITRATE=-B %B}T:{START=-ss %s}
[avconv] -loglevel quiet -f mp4 $START$ -i $FILE$ -f flac -

How would I tell whether avconv is installed in my system? I see that in my LMS > Settings > Filetypes the following is shown for mpeg-4 (note the disabled)

19051


And with this new custom convert I can't play any m4a files (inlcuding local files).

I undid my changes to custom convert file, and now m4a files play (filetypes shows following):

19052

I'm sure I'm doing something wrong...any tips appreciated. Thanks.

bpa
2015-10-21, 06:22
You seem to have ffmpeg on your system as it used on the Apple HLS. avconv and ffmpeg are essentially the same - there was some sort of split in the development community.

Change the avconv to ffmpeg in the suggested lines.

When the conversion program is available and executable then the conversion will show up as an option in File Types otherwise LMS will only offer "Disabled".

garym
2015-10-21, 06:46
19055
You seem to have ffmpeg on your system as it used on the Apple HLS. avconv and ffmpeg are essentially the same - there was some sort of split in the development community.

Change the avconv to ffmpeg in the suggested lines.

When the conversion program is available and executable then the conversion will show up as an option in File Types otherwise LMS will only offer "Disabled".

Thanks. I changed avconv to ffmpeg, producing:


wma wav * *
[mplayer] -really-quiet -vc null -vo null -cache 64 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=/dev/fd/4 $FILE$ 4>&1 1>/dev/null
mov flc * *
# F
[faad] -q -w -f 2 $FILE$ | [flac] -cs --totally-silent --compression-level-0 --endian little --sign signed --channels 2 --bps 16 --sample-rate 44100 -
mov mp3 * *
# FB:{BITRATE=-B %B}
[faad] -q -w -f 2 $FILE$ | [lame] --resample 44100 --silent -q $QUALITY$ $BITRATE$ -r - -
mov wav * *
# F
[faad] -q -w -f 2 $FILE$ 2>/dev/null

mp4 mp3 * *
# FRB:{BITRATE=-B %B}T:{START=-ss %s}
[ffmpeg] -loglevel quiet -f mp4 -i $FILE$ -f wav - | [lame] --silent -q $QUALITY$ $BITRATE$ - -

mp4 pcm * *
# FRB:{BITRATE=-B %B}T:{START=-ss %s}
[ffmpeg] -loglevel quiet -f mp4 -i $FILE$ -f u16le -

mp4 flc * *
# FRB:{BITRATE=-B %B}T:{START=-ss %s}
[ffmpeg] -loglevel quiet -f mp4 $START$ -i $FILE$ -f flac -

This produced the following filetype result:

19053

But with this outcome, I couldn't play the podcast stream and I couldn't play local m4a files. The local m4a files seem to only play with faad. So I changed ffmpeg to faad to see if that helped. Same outcome, couldn't play podcast stream OR local m4a files. Removed all the new info and it reverted back to being able to play local m4a files (but still fails of course on podcast).

My system doesn't seem to like something about this.

edit: I wonder if this is relevant re: mpeg4 SLS (this is outcome with my original settings):
19055

bpa
2015-10-21, 08:00
But with this outcome, I couldn't play the podcast stream and I couldn't play local m4a files. The local m4a files seem to only play with faad. So I changed ffmpeg to faad to see if that helped. Same outcome, couldn't play podcast stream OR local m4a files. Removed all the new info and it reverted back to being able to play local m4a files (but still fails of course on podcast).

If I read this right you just edited the custom-convert.conf file ffmpeg lines and changed to faad and it didn't work. That is to be expected as the command line option for ffmpeg are wrong for faad.

I prefaced the conf suggestion saying for running Linux - Are you running these tests on Linux or Windows ?

Also you using 7.9 - I need to test for other 7.9 changes - I run 7.8 normally - there were some for podcasts in 7.9

garym
2015-10-21, 08:03
If I read this right you just edited the custom-convert.conf file ffmpeg lines and changed to faad and it didn't work. That is to be expected as the command line option for ffmpeg are wrong for faad.

I prefaced the conf suggestion saying for running Linux - Are you running these tests on Linux or Windows ?

Also you using 7.9 - I need to test for other 7.9 changes - I run 7.8 normally - there were some for podcasts in 7.9

Thanks for following up bpa. I'm running LMS 7.8.0 on fedora linux 20 (Vortexbox). And yes, after trying the ffmpeg option earlier (which didn't work), I tried the faad.

bpa
2015-10-21, 08:17
Thanks for following up bpa. I'm running LMS 7.8.0 on fedora linux 20 (Vortexbox). And yes, after trying the ffmpeg option earlier (which didn't work), I tried the faad.

In what way did ffmpeg not work ?

If you got a message "couldn't create command" then the ffmpeg option wasn't selected for the file type or the file type has changed or security is blockig it

The "not work" I would have expected with a wrong ffmpeg options is no audio and perahps the clock playing to 5 secs and then resetting

garym
2015-10-21, 08:22
In what way did ffmpeg not work ?

If you got a message "couldn't create command" then the ffmpeg option wasn't selected for the file type or the file type has changed or security is blockig it

The "not work" I would have expected with a wrong ffmpeg options is no audio and perahps the clock playing to 5 secs and then resetting

Away from home now....i'll have to revisit later. But my recollection is that I was getting the same "could not create command" error. And in terms of selected filetypes, this is what the LMS > Settings > Advanced > Filetypes showed after I used the ffmpeg custom-convert file changes. Seems this is showing that the ffmpeg option is selected???:

19053

bpa
2015-10-21, 09:03
Away from home now....i'll have to revisit later. But my recollection is that I was getting the same "could not create command" error. And in terms of selected filetypes, this is what the LMS > Settings > Advanced > Filetypes showed after I used the ffmpeg custom-convert file changes. Seems this is showing that the ffmpeg option is selected???:

19053

"Could not create command" means that there was no rule with a valid executable (i.e. ffmpeg) which transcodes a remote (i.e. FRB) stream for that filetype. Things need to be rechecked and messages in the log file examined. Looking at the your copy of custom-convert.conf posted - the spacing before the "#" and [ffmpeg]/[faad] is different for the "mov" and the "mp4" - I don't this is the issue but it is the level of detail that needs to be checked.

Later I'll try 7.9 to see if there is a 7.9 issue.

garym
2015-10-21, 09:06
"Could not create command" means that there was no rule with a valid executable (i.e. ffmpeg) which transcodes a remote (i.e. FRB) stream for that filetype. Things need to be rechecked and messages in the log file examined. Looking at the your copy of custom-convert.conf posted - the spacing before the "#" and [ffmpeg]/[faad] is different for the "mov" and the "mp4" - I don't this is the issue but it is the level of detail that needs to be checked.

Later I'll try 7.9 to see if there is a 7.9 issue.

I'll follow up later tonight. thanks.

garym
2015-10-21, 14:31
"Could not create command" means that there was no rule with a valid executable (i.e. ffmpeg) which transcodes a remote (i.e. FRB) stream for that filetype. Things need to be rechecked and messages in the log file examined. Looking at the your copy of custom-convert.conf posted - the spacing before the "#" and [ffmpeg]/[faad] is different for the "mov" and the "mp4" - I don't this is the issue but it is the level of detail that needs to be checked.

Later I'll try 7.9 to see if there is a 7.9 issue.

Running LMS 7.8.0 on Vortexbox linux setup (uses Fedora Ver 20 linux).

with server.log set to debug, I now see the following (and this seems to be obviously the key problem, but I'm not sure of correct syntax):


[15-10-21 17:20:35.0868] Slim::Player::TranscodingHelper::_getCapabilities (167) Capabilities for mp4-mp3-*-*: syntax error in FRB:{BITRATE=-B %B}T:{START=-ss %s}
[15-10-21 17:20:35.0878] Slim::Player::TranscodingHelper::_getCapabilities (167) Capabilities for mp4-pcm-*-*: syntax error in FRB:{BITRATE=-B %B}T:{START=-ss %s}
[15-10-21 17:20:35.0887] Slim::Player::TranscodingHelper::_getCapabilities (167) Capabilities for mp4-flc-*-*: syntax error in FRB:{BITRATE=-B %B}T:{START=-ss %s}

This is with a convert-config.conf file containing only this info (I removed the older info that was there just to have a cleaner test). And note that the indentions are TABs and not spaces in the file below.



mp4 mp3 * *
# FRB:{BITRATE=-B %B}T:{START=-ss %s}
[ffmpeg] -loglevel quiet -f mp4 -i $FILE$ -f wav - | [lame] --silent -q $QUALITY$ $BITRATE$ - -

mp4 pcm * *
# FRB:{BITRATE=-B %B}T:{START=-ss %s}
[ffmpeg] -loglevel quiet -f mp4 -i $FILE$ -f u16le -

mp4 flc * *
# FRB:{BITRATE=-B %B}T:{START=-ss %s}
[ffmpeg] -loglevel quiet -f mp4 $START$ -i $FILE$ -f flac -

If I try to play the podcast in question I get this in log:


[15-10-21 17:27:06.7183] Slim::Player::Song::open (409) Error: Couldn't create command line for mp4 playback for [http://50.31.159.34/sound_opinions/audio/516-twin-peaks-opinions-on-the-dead-weather.m4a?listeningSessionID=5627da1cf6a8027a_10 512_omo6CqA8_000000000aV]

And note that I can no longer play a local m4a file from my server either. I also get a "Error: Couldn't create command line for mp4 playback for" the local file.

The filetypes advanced settings shows:

19057

bpa
2015-10-21, 16:33
I assume it is a typo when you said the name of the file was custom-config.conf and not custom-convert.conf

The MPEG4-SLS type has nothing to do with mp4 type - rule for it appears as the type sls in the convert.conf and types.conf files.

The error shown in the log indicates that the mp4 conversion rules have been discarded by LMS as invalid which is why mp4 files won't play.

I have tested the same custom-convert,conf file on 7.9 and it works OK and plays

How did you create the custom-convert.conf file ?

It isn't a Windows file copied over to Linux as this will insert extra chars at end of line ?

Use Linux "file" command to make sure it is an ASCII text and not something else

If you attach the custom-convert.conf file (you may need to rename it ) to a post - I'll try it on my system.

garym
2015-10-21, 17:28
I assume it is a typo when you said the name of the file was custom-config.conf and not custom-convert.conf

The MPEG4-SLS type has nothing to do with mp4 type - rule for it appears as the type sls in the convert.conf and types.conf files.

The error shown in the log indicates that the mp4 conversion rules have been discarded by LMS as invalid which is why mp4 files won't play.

I have tested the same custom-convert,conf file on 7.9 and it works OK and plays

How did you create the custom-convert.conf file ?

It isn't a Windows file copied over to Linux as this will insert extra chars at end of line ?

Use Linux "file" command to make sure it is an ASCII text and not something else

If you attach the custom-convert.conf file (you may need to rename it ) to a post - I'll try it on my system.

Thanks again. yes, name was typo. I created the file with windows7 "NOTEPAD" (text editor). It says saving with ANSI coding. Other options are unicode, unicode big endian, UTF-8. I've attached my file from dropbox, link below:
https://dl.dropboxusercontent.com/u/27403489/custom-convert.conf

p.s. How would I use "linux file command" to determine something is truly ASCII?** I can run command line in linux but have zero knowledge.....I just enter commands that someone else instructs me to enter....
**EDIT: I assume you mean create the ASCII file using command line within linux rather than creating the file in windows as text file and copying over....

Mnyb
2015-10-21, 21:42
You could also recreate the file directly on your Linux box to ensure UNIX type of line endings . If you got no desktop you probably have vi or nano to use
Or is there a better text editor for Windows like emacs ?

bpa
2015-10-22, 01:17
Or is there a better text editor for Windows like emacs ?

Yes - Wordpad on Windows can make files with Linux line endings but IIRC it is a save option. Notepad is only useful for files intended for WIndows only.

Howeve I still need to check to see if line endings is the source of the problem.

edit:

Line endings is the source fo the problem.

Wordpad will not create the right text file if new file. Better to follow conversion suggestion in next post.

bpa
2015-10-22, 01:49
Thanks again. yes, name was typo. I created the file with windows7 "NOTEPAD" (text editor). It says saving with ANSI coding. Other options are unicode, unicode big endian, UTF-8. I've attached my file from dropbox, link below:
https://dl.dropboxusercontent.com/u/27403489/custom-convert.conf

p.s. How would I use "linux file command" to determine something is truly ASCII?** I can run command line in linux but have zero knowledge.....I just enter commands that someone else instructs me to enter....
**EDIT: I assume you mean create the ASCII file using command line within linux rather than creating the file in windows as text file and copying over....

The "file" command will not help - I thought it might distinguish between line endings but it does not.

My suggestion about the Wordpad editor will not work for new files.

The Line ending is the problem causing the error "Capabilities for mp4-mp3-*-*: syntax error in FRB:{BITRATE=-B %B}T:{START=-ss %s}"

The following command run on Linux in the directory will change the line endings of the custom-convert.conf file to the acceptable sort.


perl -pi -e 's/\r\n/\n/' custom-convert.conf

edit:

The "cat" command has an "-e" which will show up line endings. For diagnosis use the following command

cat -e custom-convert.conf

MSDOS line ending show up as ^M$ wheres Linux endings are just $

garym
2015-10-22, 04:39
Success!

After fixing the line endings, all works. I can play local m4a files (as I could before) and I can now play the "Sound Opinions" podcast stream. Thanks bpa for the detailed help and on this.

p.s. I'm curious about the fact that my "file types" now shows "ffmpeg" or "ffmpeg/lame" for mpeg-4 file types and previously showed "faad" or "faad/lame" for mpeg-4. Does this mean that my local m4a files are now converted using ffmpeg rather than faad? And what does that actually mean? Is one better than the other? the same?

Thanks again. And I learned something along the way about linux file format.

bpa
2015-10-22, 04:49
p.s. I'm curious about the fact that my "file types" now shows "ffmpeg" or "ffmpeg/lame" for mpeg-4 file types and previously showed "faad" or "faad/lame" for mpeg-4. Does this mean that my local m4a files are now converted using ffmpeg rather than faad? And what does that actually mean? Is one better than the other? the same?

ffmpeg can do lots of different conversion but faad just does aac. So faad is small lightweight but can only convert files - it cannot handle http. LMS can strip AAC from simple http stream which is why LMS can play AAC stream such as somafm but AFAICT LMS cannot strip AAC out of mp4 streams over http.

LMS rules deal with audio formats and not transport mechanism so changing mp4 rules means ffmpeg will do all AAC/MP4 conversion and not faad. Main loss of functionality is seeking - as currently setup ffmpeg rules cannot seek to a specific point in a file

garym
2015-10-22, 05:32
ffmpeg can do lots of different conversion but faad just does aac. So faad is small lightweight but can only convert files - it cannot handle http. LMS can strip AAC from simple http stream which is why LMS can play AAC stream such as somafm but AFAICT LMS cannot strip AAC out of mp4 streams over http.

LMS rules deal with audio formats and not transport mechanism so changing mp4 rules means ffmpeg will do all AAC/MP4 conversion and not faad. Main loss of functionality is seeking - as currently setup ffmpeg rules cannot seek to a specific point in a file

Thanks for the explanation. Yep, I see no seeking in the streaming mp4/m4a podcast, but I can still move within a file to a different point for my local m4a files.

strim
2015-11-06, 10:39
Yes !! thanks you all, it works, finally after a couple of years.

http://feeds.djpod.com/corstenscountdown

Thanks again

Sander

strim
2015-11-07, 02:43
It just worked once
Now i got this message:
[15-11-07 10:40:14.0130] Slim::Formats::XML::gotViaHTTP (238) XML/JSON parse error: Invalid XML feed
[15-11-07 10:40:14.0150] Slim::Plugin::InternetRadio::Plugin::_gotRadioErro r (65) Unable to retrieve radio directory from SN: Kan niet parseren

What is wrong ?

Happy to hear,

Sander

bpa
2015-11-07, 04:30
It just worked once
Now i got this message:
[15-11-07 10:40:14.0130] Slim::Formats::XML::gotViaHTTP (238) XML/JSON parse error: Invalid XML feed
[15-11-07 10:40:14.0150] Slim::Plugin::InternetRadio::Plugin::_gotRadioErro r (65) Unable to retrieve radio directory from SN: Kan niet parseren

What is wrong ?

Information ? details ? always help - without information (system, version, player, URLs etc) all is guess work.

That message means no response was got from either the source site or Squeezenetwork (SN) - feels like network problems.

This fix was for use with LMS systems - I don't knwo why Squeezenetwork isinvolved.

strim
2015-11-07, 16:04
Hi Bpa,

I am running LMS Repack 7.9.0 on Synology DS 213 with a Receiver and Radio.
I always like to hear these podcasts, Tiesto, Ferry Corsten and Fedde le Grand, but when they distributed in M4a it stopped playing on the Squeezebox.
Finally i found this thread how to handle, installed ffmpeg and did the instructions you provided.
Now i can play my favorite podcasts again with the lms podcastplayer, thanks again.
But the podcast by Ferry Corsten can only be played when downloaded, not by streaming with the podcastplayer.
What do you mean with the Squeezenetwork? Is that my squeezebox.com, never understand the usage of that.

Happy to hear if you have the solution.

http://feeds.djpod.com/corstenscountdown

Sander

bpa
2015-11-07, 16:31
Hi Bpa,

I am running LMS Repack 7.9.0 on Synology DS 213 with a Receiver and Radio.
I always like to hear these podcasts, Tiesto, Ferry Corsten and Fedde le Grand, but when they distributed in M4a it stopped playing on the Squeezebox.
Finally i found this thread how to handle, installed ffmpeg and did the instructions you provided.
Now i can play my favorite podcasts again with the lms podcastplayer, thanks again.
But the podcast by Ferry Corsten can only be played when downloaded, not by streaming with the podcastplayer.
What do you mean with the Squeezenetwork? Is that my squeezebox.com, never understand the usage of that.

Happy to hear if you have the solution.

http://feeds.djpod.com/corstenscountdown

Sander

The podcasts in the corstenscountdown feed are tagged as text/plain which means LMS assumes they are are not audio. This might be a deliberate error to avoid streaming from the site and only do downloads.

Squeezenetwork.com allows SB player to play internet radio, podcasts and internet services such as spotify, deezer etc. without having a PC running LMS but no transcoding is supported by Squeezenetwork.

strim
2015-11-08, 03:39
i Bpa,

That was exactly what you told me a couple of years ago, but after installing ffmpeg with your instructions it finally works again.
http://forums.slimdevices.com/showthread.php?98560-Cannot-play-podcast-m4a&highlight=

I had these problems with all m4a podcasts, just highlighted these popular ones.
Guess i am not the only one plays these podcasts ?

Now the Tiesto podcast works good;
http://feeds.feedburner.com/tiestos_club_life

But the Ferry Corsten only plays when downloaded
http://feeds.djpod.com/corstenscountdown

This must be some setting or other configuration thing, so it must be possible.
I am happy already, with playing various podcasts now, and more happy if i can play the Corsten countdown as it should be.

Happy to hear again,

Sander

bpa
2015-11-08, 03:51
I am happy already, with playing various podcasts now, and more happy if i can play the Corsten countdown as it should be.

How about asking the feed creator to correctly tag the podcast as audio and not text as per podcast standards ?

Most suppliers like to be told about mistakes that prevent their feed being accessed by more people.

strim
2015-11-08, 04:17
How about asking the feed creator to correctly tag the podcast as audio and not text as per podcast standards ?

Most suppliers like to be told about mistakes that prevent their feed being accessed by more people.

Just did, hoping i found the right email address !

Sander

strim
2015-11-08, 06:36
Hi Bpa

I found another one:

http://feeds.djpod.com/martingarrixfrance

Normally i listen at these podcasts in my car from the iPhone.
Is this also a text tagged podcast?

Happy to hear

Sander

bpa
2015-11-08, 06:45
I haven't time to check out each podcast feed so you need to learn to do it yourself.

If you open the feed in a browser such as Chrome it will show the XML feed in XML notation.

The text to look for are the "enclosure" so for example of one podcast from djpod. Note the text in red. The podcast tagged audio/mpeg3 should play (unless LMS conf files have been changed) as it is a type supported by LMS. If it does not play there is another reasonm - so you need to look at your log file for messages.


<description>
<![CDATA[
http://www.facebook.com/MartinGarrixFrance<br /> http://www.facebook.com/martin.garrix<br /> http://www.martingarrix.com
]]>
</description>
<pubDate>Mon, 03 Aug 2015 00:04:00 +0200</pubDate>
<enclosure url="http://download.djpod.com/martingarrixfrance/Martin_Garrix_-_The_Martin_Garrix_Show_047.mp3" length="107029087" type="audio/mpeg3"/>
<itunes:subtitle>Martin Garrix Podcast</itunes:subtitle>
<itunes:author>Martin Garrix</itunes:author>
<itunes:summary>
<![CDATA[
http://www.facebook.com/MartinGarrixFrance http://www.facebook.com/martin.garrix http://www.martingarrix.com
]]>
</itunes:summary>
<itunes:duration>55:44</itunes:duration>
<itunes:keywords>
<![CDATA[ ]]>
</itunes:keywords>
</item>
<item>
<title>Martin Garrix @ Tomorrowland - 25-07-2015</title>
<link>
https://djpod.com/martingarrixfrance/martin-garrix-tomorrowland-25-07-2015
</link>
<guid>https://djpod.com/martingarrixfrance/?id=124967</guid>
<description>


Whereas a [odcast from the Corsten feed is as follows


<description>
<![CDATA[
In Corsten's Countdown, Ferry Corsten introduces the best and latest dance tracks. The listeners can vote for their favorite track, right after each show. The three tracks with the most votes, will be played again the week after in the Corsten's Countdown Top 3. If a track get's voted #1 for three times in a row, it will become Corsten's Countdown hattrick. So help your favorite track become a hit and vote via www.corstenscountdown.com or www.ferrycorsten.com/app!
]]>
</description>
<pubDate>Thu, 05 Nov 2015 16:35:00 +0100</pubDate>
<enclosure url="http://download.djpod.com/corstenscountdown/fc_20151104.m4a" length="58544497" type="text/plain"/>
<itunes:subtitle>Corsten's Countdown Official Podcast</itunes:subtitle>
<itunes:author>Ferry Corsten</itunes:author>
<itunes:summary>
<![CDATA[
In Corsten's Countdown, Ferry Corsten introduces the best and latest dance tracks. The listeners can vote for their favorite track, right after each show. The three tracks with the most votes, will be played again the week after in the Corsten's Countdown Top 3. If a track get's voted #1 for three times in a row, it will become Corsten's Countdown hattrick. So help your favorite track become a hit and vote via www.corstenscountdown.com or www.ferrycorsten.com/app!
]]>
</itunes:summary>
<itunes:duration>58:34</itunes:duration>
<itunes:keywords>
<![CDATA[ ]]>
</itunes:keywords>
</item>
<item>
<title>Corsten's Countdown #435</title>
<link>
https://djpod.com/corstenscountdown/corsten-s-countdown-435
</link>
<guid>https://djpod.com/corstenscountdown/?id=133684</guid>
<description>

strim
2015-11-08, 08:58
Thanks for your time Bpa
I have to study on that ;-)

thanks

Sander