PDA

View Full Version : squeezeslave on el capitan



banned for life
2015-10-01, 11:26
I am getting a deprecation message for the Carbon Component Manager.

Will there be (is there) a newer replacement version?

B4L

ralphy
2015-10-03, 04:58
I am getting a deprecation message for the Carbon Component Manager.

Will there be (is there) a newer replacement version?

B4L
What squeezeslave version are you using? 1.4.421 is the latest.

Can you provide the depreciated messages from the console log(s)?

banned for life
2015-10-05, 12:45
What squeezeslave version are you using? 1.4.421 is the latest.

Can you provide the depreciated messages from the console log(s)?

Looks like 1.3-390 28 Dec 12

"WARNING: 140: This application, or a library it uses, is using the deprecated Carbon Component Manager for hosting Audio Units. Support for this will be removed in a future release. Also, this makes the host incompatible with version 3 audio units. Please transition to the API's in AudioComponent.h."

I guess I should try to find a newer one.. I don't see any 1.4 on code.google.com

B$Life

ralphy
2015-10-06, 04:09
Looks like 1.3-390 28 Dec 12

"WARNING: 140: This application, or a library it uses, is using the deprecated Carbon Component Manager for hosting Audio Units. Support for this will be removed in a future release. Also, this makes the host incompatible with version 3 audio units. Please transition to the API's in AudioComponent.h."

I guess I should try to find a newer one.. I don't see any 1.4 on code.google.com

B$Life

Thanks for the log.

Googlecode has been dead to me for several years now. All newer builds are on my mediafire site.

Click the Squeezebox client builds link in my signature.

banned for life
2015-10-06, 05:35
Thanks for the log.

Googlecode has been dead to me for several years now. All newer builds are on my mediafire site.

Click the Squeezebox client builds link in my signature.

I guess their site showing near the top was Google not being evil.

B4L

banned for life
2015-10-06, 11:51
I have replaced /opt/local/bin/squeezeslave with the newer version from squeezeslave-1.4-421-osx (dated 24 Jan 2015.) and the warning 140 still appears.

Banned 4 (a reason?)

ralphy
2015-10-07, 04:12
I have replaced /opt/local/bin/squeezeslave with the newer version from squeezeslave-1.4-421-osx (dated 24 Jan 2015.) and the warning 140 still appears.

Banned 4 (a reason?)

But it's only a warning. Squeezeslave still works correct?

banned for life
2015-10-08, 06:54
But it's only a warning. Squeezeslave still works correct?

Yes. Works and thank you.

ralphy
2015-10-19, 05:51
Yes. Works and thank you.

You're welcome.

The deprecated warning has been traced to the portaudio library.

The issue has been raised with the portaudio developers and they are currently looking at adding support for the replacement AudioComponent manager api. According to an apple insider, we have about another year before the deprecated api is removed from OSX.